Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: restoring db's not working.  (Read 2371 times)

0 Members and 1 Guest are viewing this topic.

victor78

  • Guest
restoring db's not working.
« on: September 18, 2006, 08:24:21 PM »

I'm running anope 1.7.15 on linux.  I am not using the mysql server.
I lost all the database information recently and I am trying to restore the .db files from a previous backup.  I tried to restore the files and nothing works.  Here's the processes I used.

1) kill services
2) copy the .db's over.
3) restart anope

Result:  No channels or nicks registered

I tried using operserv to do the update and it still does not work.

Does it take a while to update?  What am I doing wrong here?
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #1 on: September 18, 2006, 10:40:46 PM »

Though i'm not sure at this, do you use the *.db files from the backup folder :-?
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #2 on: September 18, 2006, 11:55:59 PM »

if you copy them to the shell over ftp/sftp, make sure they have the right permissions...
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)
Pages: [1]   Go Up