Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Run Error: 1.7.15 won't start service  (Read 3374 times)

0 Members and 1 Guest are viewing this topic.

TiG4

  • Guest
Run Error: 1.7.15 won't start service
« on: September 14, 2006, 07:57:18 AM »

Running UBUNTU 6.06 with UnrealIRCd.

Everything compiled smoothly however whenever I try to run it, the log shows this error:

[Sep 14 02:04:20 2006] Every UserKey must be different. It's for YOUR safety! Remember that!
[Sep 14 02:04:20 2006] Loading IRCD Protocol Module: [unreal32]
[Sep 14 02:04:20 2006] status:
  • [Module, Okay - No Error]
[Sep 14 02:04:20 2006] Anope 1.7.15 (1128) (ircd protocol: UnrealIRCd 3.2+) starting up
[Sep 14 02:04:20 2006] ns_sendpass requested unload...
[Sep 14 02:04:20 2006] debug: trying to load core module [ns_sendpass]
[Sep 14 02:04:20 2006] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Sep 14 02:04:20 2006] cs_sendpass requested unload...
[Sep 14 02:04:20 2006] debug: trying to load core module [cs_sendpass]
[Sep 14 02:04:20 2006] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Sep 14 02:04:20 2006] ms_rsend requested unload...
[Sep 14 02:04:20 2006] debug: trying to load core module [ms_rsend]
[Sep 14 02:04:20 2006] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Sep 14 02:04:21 2006] Databases loaded
[Sep 14 02:04:21 2006] Info: Reflecting database records.
[Sep 14 02:04:21 2006] FATAL: Can't connect to server: Connection refused


Any ideas?
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #1 on: September 14, 2006, 08:07:19 AM »

services.conf:

#UserKey1 9866235
#UserKey2 8362013
#UserKey3 2362899

don't use the default UserKey (s). You need to make your own 7 digits random number for that. "It's for YOUR safety! Remember that!" ...

[Sep 14 02:04:21 2006] FATAL: Can't connect to server: Connection refused

it looks like something on your Link blocks from the ircd is not properly configured. And also check RemotServer from services.conf :

RemoteServer    127.0.0.1 6667 "pass"

# ServerName <name>  [REQUIRED]
#     Specifies the IRC server name which Services should use.  May be
#     overridden by the -name command-line option.

ServerName  "services.localhost.net"

the ServerName must match the hostname  from your IRCd link blocks
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.

TiG4

  • Guest
(No subject)
« Reply #2 on: September 14, 2006, 05:04:56 PM »

SERVICES.CONF

RemoteServer    irc.rcirc.net 6969 "x"
ServerName  "services.rcirc.net"

UNREALIRCD.CONF
link            irc.rcirc.net
{
    username    *;
    hostname     irc.rcirc.net;
    bind-ip     irc.rcirc.net;
    port         9696;
    hub             *;
    password-connect "x";
    password-receive "x";
    class           servers;
        options {
            autoconnect;
            /*ssl;
            zip;*/
        };
};

link services.rcirc.net
{
 username *;
 hostname services.rcirc.net;
 port 9696;
 bind-ip irc.rcirc.net;
 password-connect "x";
 password-receive "x";
 class servers;
};

link stats.rcirc.net
{
 username *;
 hostname stats.rcirc.net;
 port 9696;
 bind-ip irc.rcirc.net;
 password-connect "x";
 password-receive "x";
 class servers;
};


ulines {
   services.rcirc.net;
   stats.rcirc.net;
};

Just changed it and rehashed but still won't connect. Still get FATAL ERROR: Connection Refused
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #3 on: September 14, 2006, 05:39:16 PM »

/stats u ... check whether your ircd is actually listeninng on port 9696
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

Tom65789

  • Anope User
  • Offline Offline
  • Posts: 343
    • www.t65789.co.uk
(No subject)
« Reply #4 on: September 14, 2006, 05:39:52 PM »

lol chaz is fixing this, i think he sent his configs.

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #5 on: September 14, 2006, 06:31:22 PM »

Aye, fixed it about an hour ago i think.

Closing.
Logged
Pages: [1]   Go Up