Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Config problem with UnrealIRCD  (Read 8702 times)

0 Members and 1 Guest are viewing this topic.

arew264

  • Guest
Config problem with UnrealIRCD
« on: September 06, 2006, 03:31:38 AM »

Well, this is my first time setting up an irc server, and I have googled and red documentation to where I have an UnrealIRCD server up and running that really works (the generic ircd that was packaged for my distro was still using I: lines, etc). The problem comes when I try to start anope, and get an error that my IRCD isn't configured correctly. Here's the pertinent info from configs:
anope:
RemoteServer    127.0.0.1 8067 "pass"

UnrealIRCD:
listen         *:8067;

link            127.0.0.1
{
        username        *;
        hostname        127.0.0.1;
        bind-ip         127.0.0.1;
        port            8067;
        password-connect "pass";
        password-receive "pass";
        class           servers;
};

ulines {
        localhost;
        127.0.0.1;
};

EDIT:
Just wanted to note that if you want to call me dumb, you are free to do so, because I think this is prolly some incredibly obvious mistake that I completely missed.

Also, versions:
UnrealIRCD 3.2.5
Anope 1.7.15

I had to use 1.7.15 because the latest stable version gave me syntax errors on compile

[Edited on 6-9-2006 by arew264]
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #1 on: September 06, 2006, 03:42:04 AM »

try this:
Code: [Select]

listen 127.0.0.1:8067;

link services.localhost.net
{
username *;
hostname 127.0.0.1;
bind-ip 127.0.0.1;
port 8067;
password-connect "pass";
password-receive "pass";
class servers;
};

ulines {
services.localhost.net;
};


and try starting your services using: ./services -debug -nofork
if services isn't still starting up, check the logs file located inside services/logs folder and paste the log file.
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.

arew264

  • Guest
(No subject)
« Reply #2 on: September 06, 2006, 04:30:54 AM »

Well, here's the output that appears to be pertinent from starting services with the options you suggested:

[Sep 05 22:29:13.131243 2006] status:
  • [Module, Okay - No Error]
[Sep 05 22:29:13.131354 2006] debug: Received: :irc.fwet.dyndns.org NOTICE AUTH :*** Looking up your hostname...
[Sep 05 22:29:13.167706 2006] debug: Received: :irc.fwet.dyndns.org NOTICE AUTH :*** Found your hostname
[Sep 05 22:29:13.168467 2006] debug: Received: ERROR :Link denied (No matching link configuration) [@127.0.0.1.33530]
[Sep 05 22:29:13.168608 2006] debug: Link denied (No matching link configuration) [@127.0.0.1.33530]
[Sep 05 22:29:13.168741 2006] Error: Your IRCD's link block may not setup correctly, please check unrealircd.conf
[Sep 05 22:29:13.169049 2006] debug: Received: ERROR :Closing Link: [127.0.0.1] (Link denied (No matching link configuration))
[Sep 05 22:29:13.169167 2006] debug: Closing Link: [127.0.0.1] (Link denied (No matching link configuration))
[Sep 05 22:29:13.169271 2006] Error: Your IRCD's link block may not setup correctly, please check unrealircd.conf
[Sep 05 22:29:13.169434 2006] debug: Emitting event "shutdown" (1 args)
[Sep 05 22:29:13.169546 2006] Read error from server: No such file or directory (error num: 2)
[Sep 05 22:29:13.169799 2006] debug: Sent: SQUIT fwet.dyndns.org :Read error from server: No such file or directory (error num: 2)
[Sep 05 22:29:13.169923 2006] debug: firstuser() returning NULL (end of list)
[Sep 05 22:29:13.170027 2006] debug: Emitting event "shutdown" (1 args)

Where the heck is it getting the 127.0.0.1.33530 from? That can't be right...

I didn't post the log because all the pertinent log info is already here

[Edited on 6-9-2006 by arew264]
Logged

Dave Robson

  • Team
  • *
  • Offline Offline
  • Posts: 357
(No subject)
« Reply #3 on: September 06, 2006, 07:33:09 AM »

[Sep 05 22:29:13.169049 2006] debug: Received: ERROR :Closing Link: [127.0.0.1] (Link denied (No matching link configuration))
[Sep 05 22:29:13.169167 2006] debug: Closing Link: [127.0.0.1] (Link denied (No matching link configuration))
[Sep 05 22:29:13.169271 2006] Error: Your IRCD's link block may not setup correctly, please check unrealircd.conf

Those 3 lines should give you a good clue where to start.

the 127.0.0.1 / 33530 is your ip / port used in the connection, dont worry about it, it looks perfectly fine.

Also what ServerName have you give services in the config? since your link block is for a name of 127.0.0.1 which is odd.
Logged
Pages: [1]   Go Up