Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: 1 [2]   Go Down

Author Topic: Making the services (NickServ, ChanServ...) join a channel  (Read 38326 times)

0 Members and 1 Guest are viewing this topic.

PreciousAlly

  • Anope User
  • Offline Offline
  • Posts: 20
    • http://www.thesims2source.com/
(No subject)
« Reply #25 on: September 05, 2006, 05:09:54 PM »

Well, at first when I type: "/os modload os_clientjoin", I get a pop-up that says: "This application has failed to start because MSVCR80.dll was not found. Re-installing the application may fix this problem."

In the logs, I get this:

"[Sep 05 12:03:26 2006] OperServ: PreciousAlly: set debug on
[Sep 05 12:03:26 2006] Debug mode activated
[Sep 05 12:03:26 2006] debug: Sent: :OperServ NOTICE PreciousAlly :Services are now in debug mode.
[Sep 05 12:03:28 2006] debug: Received: :PreciousAlly PRIVMSG OperServ@services.thesims2source.com :modload os_clientjoin
[Sep 05 12:03:28 2006] OperServ: PreciousAlly: modload os_clientjoin
[Sep 05 12:03:28 2006] Trying to load module [os_clientjoin]
[Sep 05 12:03:28 2006] Runtime module location: .\modules\runtime\os_clientjoin.dll.a10860
[Sep 05 12:03:31 2006] The specified module could not be found.


[Sep 05 12:03:31 2006] debug: Sent: :OperServ NOTICE PreciousAlly :Unable to load module os_clientjoin
[Sep 05 12:03:31 2006] Module loading status: 6
[Sep 05 12:03:35 2006] debug: Received: :PreciousAlly PRIVMSG OperServ@services.thesims2source.com :set debug off
[Sep 05 12:03:35 2006] OperServ: PreciousAlly: set debug off
[Sep 05 12:03:35 2006] Debug mode deactivated"
Logged

PreciousAlly

  • Anope User
  • Offline Offline
  • Posts: 20
    • http://www.thesims2source.com/
(No subject)
« Reply #26 on: September 05, 2006, 05:13:52 PM »

Gman, maybe try downloading THIS
Logged

Tom65789

  • Anope User
  • Offline Offline
  • Posts: 343
    • www.t65789.co.uk
(No subject)
« Reply #27 on: September 05, 2006, 07:22:01 PM »

[Sep 05 12:03:31 2006] The specified module could not be found.

it obviously cant find it for some reason. are you sure its in /data/modules/ ??

PreciousAlly

  • Anope User
  • Offline Offline
  • Posts: 20
    • http://www.thesims2source.com/
(No subject)
« Reply #28 on: September 05, 2006, 07:57:53 PM »

[edit by Rob]
Sorry, i've deleted this post, there are so many issues with using raw its best not to post strings on here, as a general rule, we dont even try to support networks using the Raw command as as soon as you use it, you have (almost certainly) caused a de-sync in the state of the network i.e. services think one thing, and the ircd thinks another, which more often than not, leads to "odd" bugs in both the ircd and services.

Rob
[/edit]

[Edited on 5-9-2006 by Rob]
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #29 on: September 05, 2006, 08:22:02 PM »

what you just posted is not supported....

could a mod delete these references to *** ?

[Edited on 5-9-2006 by Viper]
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

Tom65789

  • Anope User
  • Offline Offline
  • Posts: 343
    • www.t65789.co.uk
(No subject)
« Reply #30 on: September 05, 2006, 08:33:57 PM »

i'll just quote :)

"RAW is a developer tool ONLY. Only a fool would ever have it enabled on a network with real users. RAW has the ability to crash your network, desync your services and comprimise any network security you have. You may be banned for typing raw strings in this room, and we refuse to support people who have raw enabled."

so some of you may have lost support \o/ as Rob edited that post too

[Edited on 5-9-2006 by Tom65789]

PreciousAlly

  • Anope User
  • Offline Offline
  • Posts: 20
    • http://www.thesims2source.com/
(No subject)
« Reply #31 on: September 05, 2006, 08:56:42 PM »

Ooops, my apologies... I'm not aware of the commands harm, I was just given the command from a friend who I asked if it was possible to make the network services join the channel. It won't happen again. :)

Regards,
Allison
Logged

Tom65789

  • Anope User
  • Offline Offline
  • Posts: 343
    • www.t65789.co.uk
(No subject)
« Reply #32 on: September 05, 2006, 09:08:52 PM »

and that is what the module is for. better to use this module rather than RAW

Gman

  • Guest
(No subject)
« Reply #33 on: September 06, 2006, 10:06:15 AM »

Thanks, Tom and PreciousAlly

I downloaded a new version of Anope (1.7.15) and all successfully working :)
Logged

Ajay

  • Guest
(No subject)
« Reply #34 on: September 10, 2006, 09:35:19 AM »

deleted.


[Edited on 10-9-2006 by Rob]


Ajay: Sorry, I have used raw before and it never caused any problems. I still don't know what kind of damage it could do but I guess you guess would know better than me. ;) I just thought since posters in this thread are going through all the trouble of doing this that they might have wanted a simple alternative.

[Edited on 10-9-2006 by Ajay]
Logged

Tom65789

  • Anope User
  • Offline Offline
  • Posts: 343
    • www.t65789.co.uk
(No subject)
« Reply #35 on: September 10, 2006, 11:37:59 AM »

k let me make this clear.

RAW is very dodgy and should NEVER be USED. this MODULE is to work instead of using RAW. so STOP posting RAW strings because as said above. those that have posted RAW strings obviously have used it, therefore if you have any problems it is most likely you will NOT get support because it may be something you caused yourself so the devs will be looking for a problem that doesnt exist.

owine

  • Anope User
  • Offline Offline
  • Posts: 130
(No subject)
« Reply #36 on: September 10, 2006, 06:04:57 PM »

here is what i get tom
Code: [Select]
[Sep 10 17:02:45.415897 2006] debug: Received: :owine PRIVMSG operserv@services.hak5.org :modload os_clientjoin
[Sep 10 17:02:45.416406 2006] OperServ: owine: modload os_clientjoin
[Sep 10 17:02:45.416531 2006] Trying to load module [os_clientjoin]
[Sep 10 17:02:45.418272 2006] Runtime module location: /home/hak5/services/modules/runtime/os_clientjoin.so.85ZHwm
[Sep 10 17:02:45.421634 2006] Module os_clientjoin compiled against current or newer anope revision 1128, this is 1128
[Sep 10 17:02:45.422080 2006] Displaying command list for CLIENTJOIN
[Sep 10 17:02:45.422126 2006] 1:  0x0x8549600
[Sep 10 17:02:45.422160 2006] end
[Sep 10 17:02:45.422291 2006] debug: existing msg: (0x0x851bd00), new msg (0x0x8545d40)
[Sep 10 17:02:45.422328 2006] Displaying message list for reload
[Sep 10 17:02:45.422359 2006] 1: 0x0x8545d40
[Sep 10 17:02:45.422390 2006] 2: 0x0x851bd00
[Sep 10 17:02:45.422421 2006] 3: 0x0x8511440
[Sep 10 17:02:45.422451 2006] 4: 0x0x8502600
[Sep 10 17:02:45.422482 2006] 5: 0x0x8502520
[Sep 10 17:02:45.422513 2006] 6: 0x0x84f2ce0
[Sep 10 17:02:45.422543 2006] 7: 0x0x84f20e0
[Sep 10 17:02:45.422574 2006] end
[Sep 10 17:02:45.425155 2006] os_clientjoin: Config: OSClientJoinModes: [+sOi]
[Sep 10 17:02:45.425631 2006] os_clientjoin: Config: OSClientJoinBots: [1] - BotServ bots will now join on the command.
[Sep 10 17:02:45.425823 2006] PANIC! buffer = :owine PRIVMSG operserv@services.hak5.org :modload os_clientjoin
[Sep 10 17:02:45.426145 2006] debug: Sent: :services.hak5.org GLOBOPS :PANIC! buffer = :owine PRIVMSG operserv@services.hak5.org :modload os_clientjoin

any help would be appreciated... thanks
Logged

Tom65789

  • Anope User
  • Offline Offline
  • Posts: 343
    • www.t65789.co.uk
(No subject)
« Reply #37 on: September 10, 2006, 06:55:33 PM »

k. did a very quick change to it. havent tested it because i am in a rush but download it from here again:

http://www.area51designz.com/c/anope/os_clientjoin.c
http://www.area51designz.com/c/anope/os_clientjoin.dll


havent tested it so make sure you test it before using it on a public network
Pages: 1 [2]   Go Up