Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Anope 1.6.4 - Can't connect to UnrealIRCd 3.2.5  (Read 9329 times)

0 Members and 1 Guest are viewing this topic.

lacop

  • Guest
Anope 1.6.4 - Can't connect to UnrealIRCd 3.2.5
« on: August 03, 2006, 04:03:59 PM »

Hi,

I have Anope 1.6.4 and UnrealIRCd 3.2.5 on linux (debian).

When I start Anope with ./services I get a error message from UnrealIRCd:
*** LocOps -- Link denied (Authentication failed [Bad password?]) [@127.0.0.1.54883]

-- Parts of UnrealIRCd config file --

Code: [Select]

listen *:6667;

link services.localhost
{
 username *;
 hostname 127.0.0.1;
 port *;
 bind-ip *;
 password-connect "qweasdfg";
 password-receive "qweasdfg";
 class servers;
};

ulines {
 services.localhost;
};


-- Parts of Anope config file --

Code: [Select]

RemoteServer    localhost 6667 "qweasdfg"
ServerName  "services.localhost"



What's the problem? Pls help :)


[Edited on 3-8-2006 by lacop]
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #1 on: August 03, 2006, 04:07:24 PM »

If this is a shell server, you should not use 127.0.0.1.

1.6.4 does not officially support unreal3.2.5
Logged

lacop

  • Guest
(No subject)
« Reply #2 on: August 03, 2006, 04:11:23 PM »

when I replace 127.0.0.1 with localhost in link block I get following error:

*** LocOps -- Link denied for services.localhost(unknown@127.0.0.1) (Server is in link block but IP/host didn't match) [@127.0.0.1.45494]
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #3 on: August 03, 2006, 04:17:17 PM »

Are you the only user on this system? - If so, use 127.0.0.1 in the link block, AND remoteserver.

If there are other users, you should use your assigned IP.
Logged

lacop

  • Guest
(No subject)
« Reply #4 on: August 03, 2006, 04:29:22 PM »

any combination of localhost/127.0.0.1/my IP in Anope/unrealircd config files isn't working :(
what versions of anope and unreal do you recommend?
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #5 on: August 03, 2006, 04:32:56 PM »

If you were asking for my opinion i would reccomend UnrealIRCd 3.2.5 with Anope 1.7.14 which all works wonderfully well for me.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

lacop

  • Guest
(No subject)
« Reply #6 on: August 03, 2006, 04:35:41 PM »

Quote
Originally posted by Jobe1986
If you were asking for my opinion i would reccomend UnrealIRCd 3.2.5 with Anope 1.7.14 which all works wonderfully well for me.


ok, thank you (and thanks to chaz too :) )
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #7 on: August 03, 2006, 04:38:22 PM »

I'd agree. And if you still have problems, nip onto irc.anope.org #anope
Logged

lacop

  • Guest
(No subject)
« Reply #8 on: August 03, 2006, 05:07:50 PM »

thx, it's working now :)
Logged
Pages: [1]   Go Up