Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: strange error message, in logfile  (Read 11838 times)

0 Members and 1 Guest are viewing this topic.

psychomarine

  • Guest
strange error message, in logfile
« on: July 04, 2006, 12:05:53 AM »

hello,


ive been looking at this error for a week now, and I must turn to you for help, which kills my pride.

This is the error message im getting in the services log



[Jul 03 18:00:24 2006] Anope 1.6.4 (874) (compiled for UnrealIRCd 3.1.1+) starting up
[Jul 03 18:00:24 2006] Attempting to load V3 HS Database
[Jul 03 18:00:24 2006] Databases loaded
[Jul 03 18:00:24 2006] Connected to Server 1 (localhost:10000)
[Jul 03 18:00:25 2006] Read error from server: Success




This is my services.conf (passwords changed for obvious reasons)


Code: [Select]

RemoteServer    localhost 10000 "muahahaha"
ServerName  "services.enigmagroup.org"



and this is my unrealircd.conf file, version 3.2.


Code: [Select]


listen         *:10000;

link            services.enigmagroup.org
{
username *;
hostname localhost;
bind-ip *;
port 10000;
hub             *;
password-connect "muahahaha";
password-receive "muahahaha";
class           servers;
options {
/* Note: You should not use autoconnect when linking services */
autoconnect;
};
};

ulines {
services.enigmagroup.org;

};





I really dont understand why it said error, then success.  


Also,  the services are not working , linking , or anything.   Im not getting an error in the ircd log either.


Please help me figure this problem out, as soon as you can.  thank you,

psychomarine

[EDIT] Moderator edit to remove unrelated material as well as to make the thread shorter for easier reading. - katsklasw

[Edited on 4-7-2006 by katsklaw]
Logged

katsklaw

  • Guest
(No subject)
« Reply #1 on: July 04, 2006, 03:01:17 AM »

Code: [Select]

options {
/* Note: You should not use autoconnect when linking services */
autoconnect;
};


See the note!!! NO AUTOCONNECT FOR SERVICES!!

/me sends an email to stskeeps to make that bold print ...

secondly try using 127.0.0.1 instead.

[Edited on 4-7-2006 by katsklaw]
Logged

psychomarine

  • Guest
(No subject)
« Reply #2 on: July 04, 2006, 03:10:08 AM »

well im sorry i left that in there, but its not in my setup, I took it out, and tested minutes before this post, I just didnt edit it on my old paste.
Logged

katsklaw

  • Guest
(No subject)
« Reply #3 on: July 04, 2006, 03:24:58 AM »

tis ok .. it happens alot, which is why I seemed a little annoyed. Anyway .. try the IP 127.0.0.1 see if that fixes it.

Also for a little furture info .. we just need the link info pertaining to services .. not the whole conf unless we ask for it :)
Logged

psychomarine

  • Guest
(No subject)
« Reply #4 on: July 04, 2006, 04:09:05 AM »

ok,  thanks, changing localhost to 127.0.0.1 worked, thanks.  I dont know why i didnt think of that, but there it is, working.  lol  thanks
Logged

Wulfstan

  • Guest
(No subject)
« Reply #5 on: July 06, 2006, 05:00:37 AM »

1 you are better off not connecting tby autoconnect the more defined connection the better off you are here is a copy of a working link

but if you lookyou run your unrealircd or any ircd then log in to it and to operserv and watch the status window also by typing ./services -debug and check the log you will find what is blocking you


*/
link services.gorean-chat.dyndns.ws
{
   username   *;
   hostname    *;
   bind-ip    *;
   port       8067;
   hub             hub;
   password-connect "ksedufi";
   password-receive "ksedufi";
   class           servers;
      options {
         /* Note: You should not use autoconnect when linking services */
         ssl;
      };
};
Logged

Dave Robson

  • Team
  • *
  • Offline Offline
  • Posts: 357
(No subject)
« Reply #6 on: July 06, 2006, 07:51:53 AM »

that isnt a working link to anope, since anope dosnt support ssl; connections....

( it might well work if your unreal is compiled without ssl, but it will tell you that the option is useless each time you start up )
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #7 on: July 06, 2006, 08:43:00 AM »

Logged

netpants

  • Guest
(No subject)
« Reply #8 on: July 14, 2006, 08:26:29 AM »

Ok I am hvaing the same problem

[Jul 14 03:21:08 2006] Anope 1.6.4 (874) (compiled for UnrealIRCd 3.1.1+) starting up
[Jul 14 03:21:08 2006] Attempting to load V3 HS Database
[Jul 14 03:21:08 2006] Databases loaded
[Jul 14 03:21:08 2006] Connected to Server 1 (irc.freegamespot.net:6601)
[Jul 14 03:21:09 2006] Read error from server: Success

Code: [Select]
/* Note: You should not use autoconnect when linking services */
link services.freegamespot.net {
username *;
hostname 127.0.0.1;
bind-ip *;
port 6601;
password-connect eek;
password-receive eek};
hub *;
class servers;
options {
};
};

[Edited on 14-7-2006 by netpants]
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #9 on: July 14, 2006, 08:54:25 AM »

Why do you have a close brace ( } ) after your receive pass?

Put your entire unreal and services confs into www.anope.org/paste2.php enable the password option and link to it, and I'll look at it. Do you get an error or anything?
Logged

netpants

  • Guest
(No subject)
« Reply #10 on: July 14, 2006, 09:06:15 AM »

Ok I got it to get past the Server Read Error: Success thing and now I get this

Server is in link block but IP/host didn't match

- in IRC

with this is the whole error

Code: [Select]
irc.freegamespot.net- *** LocOps -- Link denied for services.freegamespot.net(unknown@207.36.201.198) (Server is in link block but IP/host didn't match) [@207.36.201.198.54442]
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #11 on: July 14, 2006, 09:09:17 AM »

In your linkblock you say 127.0.0.1 yet in services.conf you are saying 207.etc .. make your mind up and use only one. I'd go with the 127.0.0.1 myself assuming they are on the same box.
Logged

netpants

  • Guest
(No subject)
« Reply #12 on: July 14, 2006, 09:10:46 AM »

Ok pasted them

my unreal is 127.0.0.1
my services is *@127.0.0.1

i think i am messing up my services

both services and unreal are on the same machine.

[Edited on 14-7-2006 by netpants]
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #13 on: July 14, 2006, 09:19:03 AM »

I need the paste url ...........
Logged

netpants

  • Guest
(No subject)
« Reply #14 on: July 14, 2006, 09:22:51 AM »

services   http://www.anope.org/paste2.php?id=94bb58a2  
unreal     http://www.anope.org/paste2.php?id=7baf890f

man i feel stupid...

[Edited on 14-7-2006 by netpants]
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #15 on: July 14, 2006, 09:24:12 AM »

Well, like i said in my post, .....yet in services.conf you are saying 207.etc .....

Your remoteserver is trying to link to irc.blahblahblah which is 207.blahblahblah.

Change that to 127.0.0.1
Logged

netpants

  • Guest
(No subject)
« Reply #16 on: July 14, 2006, 09:26:33 AM »

i dont have the 207. anywhere in there it has either been local host or 127.0.0.1
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #17 on: July 14, 2006, 09:36:13 AM »

ok, I'm obviously talking above you.

In your services.conf you have;

RemoteServer    irc.freegamespot.net 6601 "yourpass"

irc.freegamespot.net IS the 207 IP you are seeing in your logs.

Change it to 127.0.0.1
Logged

netpants

  • Guest
(No subject)
« Reply #18 on: July 14, 2006, 09:39:28 AM »

It works now I believe, Thanks you very much for your patience and persistance on trying to get me to see what you were talking about. Now just to figure out what to do from here :)
Logged

netpants

  • Guest
(No subject)
« Reply #19 on: July 14, 2006, 09:41:51 AM »

Is this what its supposed to say for eatch of the services

irc.freegamespot.net- *** Permanent Global Q:line added for Global on Fri Jul 14 08:38:24 2006 GMT (from services.freegamespot.net: Reserved for services)
-
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #20 on: July 14, 2006, 09:42:15 AM »

No problem.

You may find it quicker + easier to join our irc chan on irc.anope.org #anope as you'll get quicker resposnes.
Logged
Pages: [1]   Go Up