Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Strange Date Problem  (Read 3050 times)

0 Members and 1 Guest are viewing this topic.

marlbman

  • Guest
Strange Date Problem
« on: June 30, 2006, 11:20:08 PM »

I a running anope v1.6.4 on Unreal v3.2.4 on FreeBSD. The following is a list of the modules running on anope:
cs_getstatusonadd
hs_nodots
hs_request
m_connect_flood
ns_noticeunregistered
os_clientjoin
os_restrict
Seemingly every day for the past few days at around the same time every day (noon) nicks get dropped, which in turn causes the loss of channels, hosts, etc. When I look in my backups directory, there are suddenly backups with 20360207 in the name. Somehow services is getting the date as Feb 7th, 2036 and therefore obviously expires pretty much all the nicks that arent NOEXPIRE. I though that maybe my shell provider was having some problems with the date on his box, but nobody else on it is having the same problem. Anybody have this problem before? any hints that may lead me to find the cause would be appreciated.

Dan
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #1 on: June 30, 2006, 11:29:03 PM »

Thats an interesting one :)

Firstly, you are certain the system date on your box is not being reconfigured via cronjob at noon? (Sounds very precise).

Also, 1.6.4 does not officially support 3.2.4 but I doubt thats the problem if things have progressed this far ...

You might be worthwhile running services in debug mode and logging exactly whats happening so we can see it.
Logged
Pages: [1]   Go Up