Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: compiling problems on fedora core 5  (Read 4720 times)

0 Members and 1 Guest are viewing this topic.

darkocabro

  • Guest
compiling problems on fedora core 5
« on: June 30, 2006, 10:45:53 PM »

anope-1.6.4

All default configure options except that modules are on.

All done!  Now run "make" (or possibly "gmake") to compile Services.
See the INSTALL, README and FAQ files if you have any problems.
[irc@localhost anope-1.6.4]$ gmake
touch services.h
(cd lang ; gmake language.h)
gmake[1]: Entering directory `/home/irc/source/anope-1.6.4/lang'
Generating language.h... 1410 strings
gmake[1]: Leaving directory `/home/irc/source/anope-1.6.4/lang'
cp -p lang/language.h .
touch pseudo.h
sh version.sh
gcc  -O2 -Wall -g -c actions.c
In file included from services.h:1194,
                 from actions.c:15:
extern.h:164: error: expected identifier or â(â before â__extension__â
gmake: *** [actions.o] Error 1

Tried all different configure options and make distclean before each and still no luck. Error message doesn't tell me much..
Any ideas on this problem?
Thanks
Darko
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #1 on: June 30, 2006, 10:51:13 PM »

Hi,

Rob believes FC5 ships with GCC4 which 1.6.4 will probably have issues with. Can you confirm this by providing the output of gcc -v. You could probably yum install an older version of GCC and get away with it, or use 1.7.14
Logged

Davio

  • Guest
(No subject)
« Reply #2 on: July 01, 2006, 09:56:12 AM »

Got the same exact error on Suse 10.1.

The output of gcc -v is:
Code: [Select]
davio@home:~/files/anope-1.6.4> gcc -v
Using built-in specs.
Target: i586-suse-linux
Configured with: ../configure --enable-threads=posix --prefix=/usr --with-local-prefix=/usr/local --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib --libexecdir=/usr/lib --enable-languages=c,c++,objc,fortran,java,ada --enable-checking=release --with-gxx-include-dir=/usr/include/c++/4.1.0 --enable-ssp --disable-libssp --enable-java-awt=gtk --enable-gtk-cairo --disable-libjava-multilib --with-slibdir=/lib --with-system-zlib --enable-shared --enable-__cxa_atexit --enable-libstdcxx-allocator=new --without-system-libunwind --with-cpu=generic --host=i586-suse-linux
Thread model: posix
gcc version 4.1.0 (SUSE Linux)

So you suggest to using version 1.7.14?
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #3 on: July 01, 2006, 10:05:25 AM »

Yeah, 1.6.4 is probably having a bit of a bad time with gcc4. I'd try 1.7.14 (its on its way to stable anyway...) or you could install an older gcc but that kind of lacks purpose.
Logged

Davio

  • Guest
(No subject)
« Reply #4 on: July 02, 2006, 06:29:00 AM »

Thanks chaz. Downloaded 1.7.14 instead and installation went smoothly. Have it up and running now. :)
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #5 on: July 02, 2006, 08:44:43 AM »

Awesome.
Logged
Pages: [1]   Go Up