Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: 1 2 [3]   Go Down

Author Topic: services sets mode -ntr  (Read 58371 times)

0 Members and 2 Guests are viewing this topic.

T-rexke

  • Guest
(No subject)
« Reply #50 on: August 10, 2006, 12:39:28 PM »

can somebody give me the os_tyssync module for windows and unreal 3.2.5 version? thx :)
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #51 on: August 11, 2006, 10:29:52 AM »

Added you to msn to send you it.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #52 on: August 11, 2006, 10:32:17 AM »

Or not, as you don't need it anymore.
Logged

Sorrento

  • Guest
(No subject)
« Reply #53 on: August 20, 2006, 02:40:21 AM »

I'm still getting a really bad offset, by about
TStime=1156037737 time()=1156066418 TSoffset=-28679
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #54 on: August 20, 2006, 10:49:15 AM »

Your servers time could really do with synchronizing using an NTP client.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

hc2995

  • Guest
(No subject)
« Reply #55 on: August 20, 2006, 11:14:43 PM »

this used to happen to me if you HAVE a bot assigned to that channel then unassign it and re assign it to said channel. if you DONT then IDK whats wrong (if this helps)
Logged

STING

  • Guest
(No subject)
« Reply #56 on: August 21, 2006, 07:23:12 PM »

Here this problem occurs after upgrading to the latest Anope 1.7.15. (already had UnrealIRCD 3.2.5)
Re-assigning the bot and dropping&registering doesn't help.
The server and services are both on the same server - no other linked servers present.

When joining a registered channel with mode lock +rsR, where no people are in yet:

Quote

[20:24:56] * ChanServ sets mode: +srR
[20:24:56] * ChanServ changes topic to 'blabla (STING)'
[20:24:56] * services.xxxx.nl sets mode: -srR
[20:24:56] * services.xxxx.nl sets mode: -o STING


Joining a regular registered channel where no other people are in yet:

Quote

[20:36:33] * ChanServ sets mode: +r
[20:36:33] * ChanServ changes topic to 'blabla (STING)'
[20:36:33] * services.xxxx.nl sets mode: -r
[20:36:33] * services.xxxx sets mode: -o STING


[Edited on 21-8-2006 by STING]

[Edited on 21-8-2006 by STING]

[Edited on 21-8-2006 by STING]
Logged

SpaceDoG

  • Anope User
  • Offline Offline
  • Posts: 183
    • http://www.hypermutt.net
(No subject)
« Reply #57 on: August 21, 2006, 08:00:17 PM »

I think that's a timesync issue but I'm not sure.
Logged

STING

  • Guest
(No subject)
« Reply #58 on: August 21, 2006, 08:37:08 PM »

My apologies - I've used os_tssync to sync the times, it is in working order now.
Thanks
Logged

Pedja

  • Guest
(No subject)
« Reply #59 on: August 25, 2006, 07:58:29 AM »

I've loaded os_tssync, I used /operserv tssync. Here's what I get:

°° 08:53:20 °° * (irc.xxx.com): *** Notice -- TS Control - U:line set time to be 1156488714 (timediff: 0)
°° 08:53:20 °° * (irc.xxx.com): *** Global -- from OperServ: Cyber used TSSYNC to sync all server's TS (TS: 1156488714)

After that, I join channel as a founder, services root, superadmin - and I get no status. I must say that I don't get "services sets mode -ntr" error, but it seems there is still a problem.

Any suggestion how to fix it?
Logged

Tom65789

  • Anope User
  • Offline Offline
  • Posts: 343
    • www.t65789.co.uk
(No subject)
« Reply #60 on: August 25, 2006, 08:09:30 AM »

/msg NickServ set autoop on

i believe that should fix it

[Edited on 25-8-2006 by Tom65789]

Pedja

  • Guest
(No subject)
« Reply #61 on: August 25, 2006, 08:12:40 AM »

It works!

Thx m8 :)

[Edited on 25-8-2006 by Pedja]
Logged

mitsuman

  • Guest
(No subject)
« Reply #62 on: October 22, 2006, 09:35:28 PM »

Hello

where can i download the new services 1.7.17 that works. and with that commadon in it....

/msg NickServ set autoop on

why have the forgot to import that i the new services version.

or have the fix it
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #63 on: October 23, 2006, 12:11:47 PM »

Do you mean this link: http://sourceforge.net/project/showfiles.php?group_id=94081 ?

[Edited on 23-10-2006 by n00bie]
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.

mitsuman

  • Guest
(No subject)
« Reply #64 on: October 23, 2006, 01:42:24 PM »

Hello


i could see that the site was working and i could download fro mthere yesterday.

But have the fix the /msg set nickserv autoop on

this would be easyer for my members not to set that function every time the log on.. some user can use it once others need to put this in perform.
Logged

SNU

  • Anope User
  • Offline Offline
  • Posts: 158
    • http://www.firstclassirc.com
(No subject)
« Reply #65 on: December 08, 2006, 07:34:27 PM »

os_tssync is the best solution! Thanks trystan! Now I feel happy! (because im using a virtual server, so i cannot adjust the system-clock)
Logged

orga

  • Guest
(No subject)
« Reply #66 on: January 06, 2007, 07:52:53 PM »

For anope 1.7.18 & UnrealIRCD 3.2.6

[02:38] * Now talking in #support
[02:38] * ChanServ sets mode: +ntrcVCNG
[02:38] * services.xxx.net sets mode: -ntrcVCNG
[02:38] * services.xxx.net sets mode: -o orga

but I used tssync,It can fix it now.

Why? anope.. doesn't have auto TSSYNC when connected IRCD ???
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #67 on: January 06, 2007, 11:19:49 PM »

why would anope do that ?

the server admin is supposed to make sure the time on the box is correct, there s specialized software for that...

and tssync is just an ugly fix, it can cause servers to hang for a certain period...
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

orga

  • Guest
(No subject)
« Reply #68 on: January 07, 2007, 09:08:36 PM »

Ok... and how 2 set up it, I just basic user,I know how 2 fix this problem with module tssync.

" the server admin is supposed to make sure the time on the box is correct, there s specialized software for that... "

Does it have a Document.....
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #69 on: January 07, 2007, 09:49:22 PM »

yes: NTP (Network Time Protocol)
http://www.ntp.org/

you need root to be able to run it though...
So if you use a shell, you need to contact your host.
But if your host doesn't syncronize time on his box, i d seriously consider getting another host since this is something essential every administrator does... shouldn't be asked for
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

orga

  • Guest
(No subject)
« Reply #70 on: January 08, 2007, 05:44:19 AM »

Oh... Thank you very much.
Now my host run ntp and does not have problem wth timesync... :D
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #71 on: February 08, 2007, 12:35:41 PM »

Fistly appolagies for dragging up a month old thread.

Secondly i can explain exactly why you can see services.domain.tld setting modes -ntr.

First though i would like to point out that technically speaking it is actually Unreal that makes the mode change not Anope. But the cause of it is with the timestamp of the SJOIN used to join the BotServ bot to the channel.

According to Unreal's server protocol when it recieves an SJOIN where the timestamp is less then what it knows to be the timestamp for that channel it resets the modes for that channel and lists it as being the server that sent the SJOIN as setting the modes. This is the reason Anope doesnt re-set the modes because Anope is completly unaware of the mode change to begin with.

So basically this problem is caused by the time Anope uses being a few seconds different from the time Unreal is using.

This can be fixed within Anope by one of a few ways:
1. Because of the way SJOIN's are handled it would be sensible for Anope to include the channels modes in the SJOIN instead of leaveing the modes param blank (which is the cause of no modes being reset)
2. Anope could use a timestamp on the SJOIN it knows is definatly in the future so that the bot is joined to the channel but no modes are change since the BotServ bot is opped after anyway.
3. (This one i dont really think is a good idea but does work in my experiments) Unreal accepts the basic JOIN message from servers so Anope could simply use that instead.

Ideally 2. is the best option because it results in NO modes being reset. But 3 would have the same effect too.

As for what server admins can do in the mean time to resolve this, the simple answer is to make sure the server Anope is running on has an accurate clock by means of NTP or alternativly using/tsctl to ajust the offset on your servers to make sure Anope's timestamps are seen by the Unreal servers as in the future.


[Edited on 8-2-2007 by Jobe1986]
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

katsklaw

  • Guest
(No subject)
« Reply #72 on: February 08, 2007, 04:47:38 PM »

replies to numbers:

1> constantly changing modes because another server changed them can lead to the infamous "bot fight" widley seen take place between Chanserv and Eggdrops because they are both set to enforce modes and both think they are right. No thanks.

2> Future to whom? .. how is services to know what is "in the future" to the ircds if they have offset times? .. no thanks, lets stick to the facts.

3> would cause undue desyncs IMO not to mention that the ircd should use it's own timestamp on the SJOIN so the events are not responded to out of order due to some latency somewhere. No thanks.

"As for what server admins can do in the mean time to resolve this, the simple answer is to make sure the server Anope is running on has an accurate clock by means of NTP"

Now THAT is the correct answer and it has always been the correct answer for many many years. Plus NTP is simple to use and mostly automatic. It's also conveniently the solution with the fewest variables.

Some things are simply required to function properly, in this case NTP. If you don't use ntp, expect desyncs ... it's that simple. I find servers like mine that run ntp don't have this issue.

If you are hosted on  machine that you don't have root access to, tell the admin to run ntp .. it' something they should be doing anyway, especially if they sell shell hosting accounts. The best solution is not always the high tech or most complicated solution.
Logged

Jappy

  • Anope User
  • Offline Offline
  • Posts: 14
    • www.irc-blog.com
(No subject)
« Reply #73 on: May 02, 2007, 05:10:16 PM »

install ntpdate on your machine


ntpdate -s -u pool.ntp.org


and a dayly cron

30 1 * * * /usr/sbin/ntpdate -su pool.ntp.org
Logged

VisioN

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 82
    • myIRC Project Hosting IRC Network
(No subject)
« Reply #74 on: August 17, 2007, 09:25:49 PM »

Mod NOTE: Your solution will not fix this issue.

This thread has reached 3 full pages and it doesn't need to. When Services acts in this fashion, it's a timestamping issue, all possible solutions have been already discussed in full detail and there is no need to comment further. Please read this thread in it's entirety as your solutions WILL be in it.

Locking.

[Edited on 18-8-2007 by katsklaw]
Logged
______________________________
VisioN
Find me: irc.myirc.net | irc.anope.org
Contact me: vision@myirc.net
Pages: 1 2 [3]   Go Up