Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1] 2 3   Go Down

Author Topic: services sets mode -ntr  (Read 56363 times)

0 Members and 1 Guest are viewing this topic.

T-rexke

  • Guest
services sets mode -ntr
« on: June 09, 2006, 04:58:13 PM »

hi wth is this strange error i never had it before until to day :)

Code: [Select]
[17:40] * services.ChatPlekkiej.net sets mode: -ntr
does anybody know the answer?
Logged

T-rexke

  • Guest
(No subject)
« Reply #1 on: June 10, 2006, 01:23:56 PM »

does nobody know the anser?
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #2 on: June 10, 2006, 01:33:31 PM »

the channel was dropped ?.... there are enough possible reason why services would do that, with the info you provide it s impossible to speak of an error...
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #3 on: June 10, 2006, 05:22:24 PM »

If this is the same as the problem i had what's happening is he is entering an empty, registered channel, ChanServ is setting the modes, an assigned bot is entering the channel then the modes are unset apparently by the services server.

Then if you leave the channel and rejoin it the same happens again.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

RejiMC

  • Guest
(No subject)
« Reply #4 on: June 10, 2006, 08:15:33 PM »

This happens to me too.... but only in channels where there is a bot server bot assigned.
Logged

katsklaw

  • Guest
(No subject)
« Reply #5 on: June 10, 2006, 09:18:08 PM »

I can't duplicate this at all.

Code: [Select]

.:16:14:. * Now talking in #katsklaw
.:16:14:. * ChanServ sets mode: +nrt
.:16:14:. * ChanServ changes topic to ''
.:16:14:. * Joins: kats-bot (katsklaw@litter.box)
.:16:14:. * kats-bot sets mode: +o kats-bot


registered channel, kats-bot is a services bot ... I join the empty channel #katsklaw .. everything is normal.

What version of Anope?
What ircd?

what is the mlock listed in: /cs info #channel all
Logged

RejiMC

  • Guest
(No subject)
« Reply #6 on: June 11, 2006, 05:35:43 AM »

Unreal3.2.4
Anope-1.7.14 (1023)
 -ChanServ-       Mode lock: +nrt

If the first person joining is an services/net admin (need to check what all ranks it works for)  it works fine the problem happens only when a normal user join an empty channel where a bot server bot is assigned
Logged

T-rexke

  • Guest
(No subject)
« Reply #7 on: June 11, 2006, 09:03:55 AM »

this is wat he does when i join

Code: [Select]
[09:55] * Now talking in #chatplekkiej
[09:55] * ChanServ sets mode: +ntr
[09:55] * ChanServ changes topic to 'Hoofdroom van deze server | Voor Vragen Join #help | typ /motd voor de motd  [CP Beta online: http://www.chat-web.nl/site !] (T-rexke)'
[09:55] * services.ChatPlekkiej.net sets mode: -ntr
[09:55] * services.ChatPlekkiej.net sets mode: -o T-rexke
and right after that the service bot joins

[bewerken aan 11-6-2006 door T-rexke]
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #8 on: June 11, 2006, 12:18:29 PM »

Thats what i was getting. The only way i tried which worked to fix it was to move services to another server on my network. That was with restoring the previous databases as they were on the previous server so that would suggest it isnt a database problem.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

Dave Robson

  • Team
  • *
  • Offline Offline
  • Posts: 357
(No subject)
« Reply #9 on: June 11, 2006, 06:15:44 PM »

Im guessing your clocks are way differnt, and it's seeing the join before it thinks the channel was ever created, as such, it takes the modes away.

Sync your clocks.
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #10 on: June 11, 2006, 06:59:45 PM »

Saying that this only started for me i installed an NTP client to automatically sync the time on my server. As i understand the IRCd maintains its own clock based on the time of the system at startup but Anope uses the system clock throughout. So if the system clock was re-sync'ed that would mean there would be a difference between the 2 even if on the same computer.

[Edited on 11-6-2006 by Jobe1986]
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

T-rexke

  • Guest
(No subject)
« Reply #11 on: June 11, 2006, 09:55:01 PM »

hm now it sets the modes but if i hop the modes are gone again and if i hop a couple of times the modes are back until i hop again :S

[bewerken aan 11-6-2006 door T-rexke]
Logged

katsklaw

  • Guest
(No subject)
« Reply #12 on: June 13, 2006, 02:29:32 AM »

Since Unreal is the ircd there is a module out there called os_tssync that can help keep the clocks sync'ed. Nothing beats a good NTP client .. but for those that can't/don't run one .. the module is fairly useful. Just google for it.

[Edited on 13-6-2006 by katsklaw]
Logged

RejiMC

  • Guest
(No subject)
« Reply #13 on: June 13, 2006, 01:54:19 PM »

[15:44] -Server1.network.com- *** Server=Server1.network.com TStime=1150202695 time()=1150202695 TSoffset=0
-
[15:44] -Server2.network.com- *** Server=Server2.network.com TStime=1150202693 time()=1150202695 TSoffset=0
-
[15:44] -Server3.network.com- *** Server=Server3.network.com TStime=1150203009 time()=1150203011 TSoffset=0
-
[15:44] -Server4.network.com- *** Server=Server4.network.com TStime=1150202689 time()=1150202691 TSoffset=0
-
[15:44] -Server5.network.com- *** Server=Server5.network.com TStime=1150202680 time()=1150202681 TSoffset=0
-

Is this Ok?
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #14 on: June 14, 2006, 08:59:49 PM »

can it be because of U:Lines ??
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.

T-rexke

  • Guest
(No subject)
« Reply #15 on: June 14, 2006, 09:05:19 PM »

i already got the answer it was something with the time :)
Logged

Davio

  • Guest
(No subject)
« Reply #16 on: July 03, 2006, 01:37:36 AM »

I am having the exact same problem with Anope 1.7.14 and UnrealIRCd 3.2.5. I am using Suse 10.1.

I had compiled and installed the os_tssync module from here http://www.nomadinc.net/mymods/files/os_tssync.c and loaded it using operserv on the irc server.

After running /operserv os_tssync, got the message that the servers were now synced, but after the sync the server was now unresponsive. No commands I entered did anything. Seems like the server freezed.

Had to kill the ircd daemon from the process table.

Is there any other way to sync the servers? Since this problem seems to be a time issue.

I know Unreal also has /tsctl command but I'm not sure how it works to sync the server times.

/tsctl ALLTIME produces the following:
Code: [Select]
*** Server=caribyard.homeip.net TStime=1151886920 time()=1151883551 TSoffset=3369Dunno if that helps.
Logged

Trystan Scott Lee

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 343
(No subject)
« Reply #17 on: July 03, 2006, 01:54:14 AM »

You are so far out of sync that the ircd froze, this is a known Unreal issue that if the clock is to far out that it will hold and wait for the time to catch up

Try syncing the computers clock up first then then worry about the ircds being within seconds.
Logged
my God my tourniquet, return to me salvation

Davio

  • Guest
(No subject)
« Reply #18 on: July 03, 2006, 02:15:06 AM »

How do I sync the computers clock?

EDIT: Nevermind. I changed my time zone on my system clock, restarted the server and it now shows
Code: [Select]
*** Server=caribyard.homeip.net TStime=1151890117 time()=1151890348 TSoffset=-231That's much better than before.

The problem with the services server removing the channel modes is now gone. whew.

Thanks Trystan

[Edited on 3-7-2006 by Davio]
Logged

TRAiNER4

  • Guest
(No subject)
« Reply #19 on: July 04, 2006, 05:02:48 PM »

well in Unreal3.2.5, they now have a timesync feature... You can set that up on all servers, then maybe the times will keep in sync.
Logged

Ryoga

  • Guest
(No subject)
« Reply #20 on: July 07, 2006, 11:26:48 PM »

I have a similar Problem. Always, when my cusins server brakes away from the network and someone joins an empty but registered channel, this happens:

Quote
[00:12] * Attempting to rejoin channel #test
[00:12] * Rejoined channel #test
[00:12] * ryogairc.de sets mode: +pnt
[00:12] * ChanServ sets mode: +rlL 2 #home
[00:12] * ChanServ changes topic to '<font color="red">Offizielle Homepage von RyogaIRC - <a href="http://ryogairc.de/">http://ryogairc.de/</a></font> (Ryoga)'
[00:12] * services.ryogairc.de sets mode: -pntrlL #home
[00:12] * services.ryogairc.de sets mode: -o Ryoga
[00:12] * Robot (botserv@bots.ryogairc.de) joins
[00:12] * Robot sets mode: +ao Robot Robot
[00:12] * Robot sets mode: +q Ryoga


Has anyone an idea what causes this and how to fix it? The other ircd runs on a PC so it can't be online 24/7
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #21 on: July 07, 2006, 11:57:46 PM »

It is caused by a time synchronization problem where the Services package and the IRCd are seeing different times. I think this may be because Anope uses the system clock where as some IRCd's such as unreal run their own internal clock. So if the system clock changes the IRCd clock wont and so will cause a time difference.

Just my theory.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

Ryoga

  • Guest
(No subject)
« Reply #22 on: July 08, 2006, 12:11:36 AM »

/tsctl svstime works to fix it temporarily, as well as restarting the services. but always when a server connects or leaves, the problem comes up again. :'(

I wonder why this happens. Why are the clocks not synced, after a server connects/leaves?

[Edit:]

I got the problem again now, after this line appeared:


Quote
[02:02] -ryogairc.de- *** Notice -- Time running backwards! 1152316950 - 1152316951 < 0



[Bearbeitet am 8. 7. 06 von Ryoga]
Logged

Ryoga

  • Guest
(No subject)
« Reply #23 on: July 08, 2006, 09:10:38 AM »

Quote
Originally posted by Rob
Im guessing your clocks are way differnt, and it's seeing the join before it thinks the channel was ever created, as such, it takes the modes away.

Sync your clocks.


I checked again and mentioned, that it happens always when a server connects/disconnects, but also if not. my UnrealIRCd and the services are on the same machine, so how can the clocks of them be "way diferent" already 3 seconds after the services were stared or /tssctl svstime was used? sometimes, nothing helps to fix it at all, it just happens again and again.
Actually, unassigning Botserv helps for now but that's not really a solution :(

Chanserv sets the modes, then services server unsets them, afterwards botserv-bot joins... so it looks to me like the services Server thinks the modes were set before the channel was created becaus they were set before botserv joins. what clocks to syncronice at all? the ones of chanserv and botserv or what?

[Bearbeitet am 8. 7. 06 von Ryoga]
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #24 on: July 08, 2006, 11:38:34 AM »

A problem i found that may cause this is when the server that services is connected to connects to another server. I find it is better if another server connects to that server instead treating it as a hub even if the only servers connected to it are services and a link to the main part of the network.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/
Pages: [1] 2 3   Go Up