Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Problems with services anope 2.0.7  (Read 498 times)

0 Members and 1 Guest are viewing this topic.

migue

  • Anope User
  • Offline Offline
  • Posts: 4
Problems with services anope 2.0.7
« on: May 18, 2020, 05:42:40 PM »

Hi guys,

I install anope 2.0.7 on UNreal5.0.4.

And the problems is when i register a NICKNAME or a CHANNEL it doesnt put mode +r.

When Whois:

 neo  foofighter@NetAdmin.elsitio.com.py [Paraguay] * foofighterss
 +info     : neo is using modes +iowsxzHtW +kcfvGqSsob
 +info     : neo is connecting from *@bou73-1-78-229-192-235.fbx.proxad.net 78.229.192.235
 Canales  : @#services
 Servidor : irc.elsitio.com.py elsitio.com.py - Tu punto de encuentro
 IRCop    : is an IRC Operator (miguerk) [netadmin]
[18:30] neo is using a Secure Connection
[18:30] neo is using an IP with a reputation score of 35
[18:30] neo is a Network Administrator                           --------------------------SHOULD BE HERE when registered and identified =  neo is logged in as Neo
 Login      : 4mins 41secs  idle : 2mins 28secs


In my whois i dont see this: neo is logged in as Neo -

When i register a #channel, chanserv dont put +r on channel the registered channel modes.

If someone has some tips. Touching this like 2 day already cant find a solution.


Thanks, sorry for my english.
« Last Edit: May 18, 2020, 05:52:40 PM by migue »
Logged

Lord255

  • Anope User
  • Offline Offline
  • Posts: 71
Re: Problems with services anope 2.0.7
« Reply #1 on: May 18, 2020, 06:30:28 PM »

hi.
did you really logged in with nickserv?
i'm not sure.

although one things which can mess up rights: uline
have you set your services to uline in unreal's conf?
see docu: https://www.unrealircd.org/docs/ULines_block

Logged

migue

  • Anope User
  • Offline Offline
  • Posts: 4
Re: Problems with services anope 2.0.7
« Reply #2 on: May 18, 2020, 07:00:11 PM »

Ohh nice now is working yeah was wrong line. Perhaps now commands aliases like /ns /cs etc, when i tipe "/ns help" nickserv doesnt answer. But if i put only "/ns" server replies [19:59] No text to send.

« Last Edit: May 18, 2020, 07:07:37 PM by migue »
Logged

Lord255

  • Anope User
  • Offline Offline
  • Posts: 71
Re: Problems with services anope 2.0.7
« Reply #3 on: May 18, 2020, 08:54:27 PM »

idk.. might be some alias issue? have you load anope's alias file?
https://github.com/unrealircd/unrealircd/blob/30acfcc8c56fe52142ceacbc4e3e89ee0af5b3ab/doc/conf/examples/example.conf#L284-L290
did you change it? or removed it? idk. works fine out of the box.
Logged

migue

  • Anope User
  • Offline Offline
  • Posts: 4
Re: Problems with services anope 2.0.7
« Reply #4 on: May 19, 2020, 03:48:52 AM »

Yes it is set up, i really dont understand why.. Before i fix U-LINES it was working.
Logged

Lord255

  • Anope User
  • Offline Offline
  • Posts: 71
Re: Problems with services anope 2.0.7
« Reply #5 on: May 19, 2020, 07:20:41 AM »

what's happening if you type /msg nickserv help, instead of /ns help ?
Logged

migue

  • Anope User
  • Offline Offline
  • Posts: 4
Re: Problems with services anope 2.0.7
« Reply #6 on: May 19, 2020, 04:12:24 PM »

Hi, It works normally if i use /msg nickserverv chanserv hostserv etc. But if i use /ns help or whatever command nothing happens. but if i only write /cs /ns /hs etc- In status server answer "no text to send"
Logged

Lord255

  • Anope User
  • Offline Offline
  • Posts: 71
Re: Problems with services anope 2.0.7
« Reply #7 on: May 19, 2020, 04:40:51 PM »

as per as i can tell, there is something wrong with your aliseses.
if /msg nickserv help works but /ns help not, then something is fcked up on aliases side.
Logged

DJFelipe

  • Anope User
  • Offline Offline
  • Posts: 4
Re: Problems with services anope 2.0.7
« Reply #8 on: June 02, 2020, 05:42:59 PM »

You need to define it on your UnrealIRCd...

unrealircd.conf
Code: [Select]
include "aliases/anope.conf";
That enables the 'short' commands for /ns /cs /hs /ms /os


Also +r is missing on your usermodes which says 'your nick is registered and you are authentificated to the services'
« Last Edit: June 02, 2020, 05:51:24 PM by DJFelipe »
Logged
Pages: [1]   Go Up