Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Unable to connect via uplink to InspIRCD  (Read 437 times)

0 Members and 1 Guest are viewing this topic.

Craig Fairhurst

  • Anope User
  • Offline Offline
  • Posts: 28
Unable to connect via uplink to InspIRCD
« on: March 17, 2019, 10:48:49 PM »

Hi

This is my services.conf https://pastebin.com/EHZ1MwvA

And here is my links.conf:
Code: [Select]
<link name="services.chatserve.website"
      ipaddr="127.0.0.1"
      port="7000"
      sid="3AX"
      allowmask="127.0.0.0/8"
      sendpass="*******"
      recvpass="*******">

<uline server="services.chatserve.website" silent="yes">

If somebody could point out where I am going wrong that would be great.

Many thanks

Craig Fairhurst

  • Anope User
  • Offline Offline
  • Posts: 28
Re: Unable to connect via uplink to InspIRCD
« Reply #1 on: March 21, 2019, 07:53:18 PM »

Hi

I've not had any further luck with this; could it be an openssl issue? Not sure, going to try on a different server now.

Kind regards

CrazyCat

  • Anope User
  • Offline Offline
  • Posts: 176
    • French Eggdrop community
Re: Unable to connect via uplink to InspIRCD
« Reply #2 on: March 22, 2019, 07:37:25 AM »

First: re-comment the server config example (lines 131 to 138 of your config file), it's an example for your ircd, not a configuration part of anope.

If it doesn't work after that, run it with the --debug parameter (cf https://wiki.anope.org/index.php/2.0/README#Command_Line_Options)
« Last Edit: March 22, 2019, 07:41:11 AM by CrazyCat »
Logged

Craig Fairhurst

  • Anope User
  • Offline Offline
  • Posts: 28
Re: Unable to connect via uplink to InspIRCD
« Reply #3 on: March 23, 2019, 01:07:24 PM »

It would appear I had not gone about installing the SSL library. A complete start-from-scratch approach helped a lot here.

Thanks all.
Pages: [1]   Go Up