Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Trouble linking Anope Services to UnrealIrcd4  (Read 537 times)

0 Members and 1 Guest are viewing this topic.

Mor

  • Anope User
  • Offline Offline
  • Posts: 5
Trouble linking Anope Services to UnrealIrcd4
« on: February 22, 2018, 12:01:22 PM »

Hi all,

I'm having trouble connecting Anope Services to my (running) UnrealIrcd4 server.

I'm pretty sure all of my configurations are ok, but I've run: ./services -debug -nofork

And found from the output two issues which I'm not sure if are very serious or not:

[Feb 21 21:46:43.300828 2018] Debug: Error while loading os_oline: Your IRCd does not support OMODE.
[Feb 21 21:46:43.305152 2018] Debug: Can not write to PID file data/services.pid

I tried rehashing my UnrealIrcd4 server and waiting a while. Still no services :(

Can you please tell me if something with my config files seems off?

My configuration files:

unrealircd.conf:

Code: [Select]
/* Anope Services port 7000 */
listen {
        ip *;
        port 7000;
};

/* Link to Anope Services */
link services.localhost.net {
        incoming {
                mask *;
        };
        password "xxxx";
        class servers;
};

ulines {
        services.localhost.net;
};


Services.conf:

Code: [Select]
define
{
        name = "services.host"
        value = "services.localhost.net"
}

uplink
{
        host = "127.0.0.1"
        ipv6 = no
        ssl = no
        port = 7000
        password = "xxxx"
}

serverinfo
{
        name = "services.localhost.net"
        description = "Services for IRC Networks"
        #localhost = "nowhere."
        #id = "00A"
        pid = "data/services.pid"
        motd = "conf/services.motd"
}

module
{
        name = "unreal4"
        use_server_side_mlock = yes
        use_server_side_topiclock = yes
}
« Last Edit: February 22, 2018, 12:07:15 PM by Mor »
Logged

genius3000

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 29
Re: Trouble linking Anope Services to UnrealIrcd4
« Reply #1 on: February 22, 2018, 12:43:04 PM »

Quote
[Feb 21 21:46:43.300828 2018] Debug: Error while loading os_oline: Your IRCd does not support OMODE.
[Feb 21 21:46:43.305152 2018] Debug: Can not write to PID file data/services.pid

You can ignore the first, I believe OMODE is an Unreal3.2 thing.
The second error looks like the real error here. Looks like Anope cannot write to data/services.pid and is shutting down at that. Does the user Anope runs under have permissions to write to it's data directory? Basically what user are you running Anope as and what's the output of 'ls -al' from the Anope base directory (usually .../services/).
Logged
-genius3000

Mor

  • Anope User
  • Offline Offline
  • Posts: 5
Re: Trouble linking Anope Services to UnrealIrcd4
« Reply #2 on: February 22, 2018, 02:25:42 PM »

You can ignore the first, I believe OMODE is an Unreal3.2 thing.
The second error looks like the real error here. Looks like Anope cannot write to data/services.pid and is shutting down at that. Does the user Anope runs under have permissions to write to it's data directory? Basically what user are you running Anope as and what's the output of 'ls -al' from the Anope base directory (usually .../services/).

Thanks a lot! User permissions was indeed my trouble.
Now I have a small other issue, since it seems the services are up and linked:

Code: [Select]
[unrealircd@ip-172-31-25-53 bin]$ ./services
Anope 2.0.6, build #6, compiled 12:29:17 Feb 21 2018
Using configuration file conf/services.conf
Attempting to connect to uplink #1 127.0.0.1 (127.0.0.1), port 7000
Successfully connected to uplink #1 127.0.0.1:7000
Successfully linked, launching into background...

I also rehashed my server.

But when I "/nickserv help", "/chanserv help", etc. , there is no response.

Any idea what could be the problem?
Logged

genius3000

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 29
Re: Trouble linking Anope Services to UnrealIrcd4
« Reply #3 on: February 22, 2018, 03:45:35 PM »

That would be with the IRCd config (aliases). My guess would be the 'set->services-server' value as seen here: https://github.com/unrealircd/unrealircd/blob/unreal40/doc/conf/examples/example.conf#L385
Logged
-genius3000

Mor

  • Anope User
  • Offline Offline
  • Posts: 5
Re: Trouble linking Anope Services to UnrealIrcd4
« Reply #4 on: February 22, 2018, 09:55:12 PM »

That would be with the IRCd config (aliases). My guess would be the 'set->services-server' value as seen here: https://github.com/unrealircd/unrealircd/blob/unreal40/doc/conf/examples/example.conf#L385

Right you are my friend!! Thanks you very much :) Couldn't have found it without your help.  :)
Logged
Pages: [1]   Go Up