Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Not being given mode +q after the channel registered  (Read 625 times)

0 Members and 1 Guest are viewing this topic.

Amy Scarlett

  • Anope User
  • Offline Offline
  • Gender: Female
  • Posts: 2
    • ChiruNET
Not being given mode +q after the channel registered
« on: October 19, 2017, 05:38:54 PM »

Hmmmm... I'm using latest stable version (2.0.5) and it doesn't want to work properly...

+q isn't assigned to me when I have definitely registered the #ChiruNET channel on my network. Not entirely sure why - I am identified to NickServ, OperServ and /oper command on the network. Where there should be an ~ is an @ next to my nick.

Could anyone be of assistance, thanks! ^^
Logged

genius3000

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 28
Re: Not being given mode +q after the channel registered
« Reply #1 on: October 19, 2017, 09:40:43 PM »

My first question would be what IRCd and does it support +q (owner)?
Assuming that it does:
1) Does ChanServ INFO #ChiruNET show you as founder?
2) What happens when you try ChanServ OWNER #ChiruNet ?
If 1) yes and 2) it gives you +q then
3) Are you on the access list as AOP? ChanServ ACCESS #ChiruNet LIST

If ChanServ is currently giving you +o (op) upon joining then it's not an AutoJoin setting, so hopefully the above can get this figured.
Logged
-genius3000

Amy Scarlett

  • Anope User
  • Offline Offline
  • Gender: Female
  • Posts: 2
    • ChiruNET
Re: Not being given mode +q after the channel registered
« Reply #2 on: October 20, 2017, 07:13:57 AM »

Ah, I figured out why myself: I forgot to load m_chanprotect.so in modules.conf (I am using InspIRCd).
Logged

genius3000

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 28
Re: Not being given mode +q after the channel registered
« Reply #3 on: October 20, 2017, 07:20:14 AM »

Ah, I figured out why myself: I forgot to load m_chanprotect.so in modules.conf (I am using InspIRCd).
A nice simple fix, gotta like those. I will point out though that m_chanprotect (while perfectly fine to use) is deprecated in favor of m_customprefix. The example modules.conf has defaults available for founder, admin, and halfop with m_customprefix (unload m_halfop as well).
Logged
-genius3000
Pages: [1]   Go Up