Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: hs_request not sending memos  (Read 6198 times)

0 Members and 1 Guest are viewing this topic.

Ankara

  • Guest
hs_request not sending memos
« on: June 07, 2006, 06:52:24 AM »

I am having a problem getting hostserv to send memos
I checked my config file:
HSRequestMemoUser
HSRequestMemoOper
are uncommented.
I didnt even notice til someone msg'd me asking
when their request would be dealt with
(other than the memo thing, the module works)
anope1.74 + Unreal 3.2.4 (debian)
other than that no other problems or indications
services has been running without a hitch since it was
released. (in fact it's been running without a hitch in various
versions for two years. :D )
thanks for any ideas.

Ankara
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #1 on: June 07, 2006, 10:05:23 AM »

Did you restart after enabling those options?
Logged

Ankara

  • Guest
(No subject)
« Reply #2 on: June 08, 2006, 02:37:34 AM »

Yeah, and I just did again now to make sure..
nothing.

(btw memoserv is working fine, can
send and receive all over the place)

[Edited on 8-6-2006 by Ankara]
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #3 on: June 08, 2006, 11:01:27 AM »

Run anope in debug mode and try it then, see what its up to.
Logged

Ankara

  • Guest
(No subject)
« Reply #4 on: June 09, 2006, 01:44:56 AM »

Interestingly enough,
I see this in debug mode:

Code: [Select]
[Jun 08 13:15:22.323497 2006] debug: [hs_request] Set config vars: MemoUser=0 MemoOper=0 MemoSetters=0 DBName='hs_request.db'

but my services.conf says this:


Code: [Select]
HSRequestMemoUser

HSRequestMemoOper

#HSRequestMemoSetters



I assume these just needed to be uncommented.
should I be setting them to =1?
Logged

katsklaw

  • Guest
(No subject)
« Reply #5 on: June 09, 2006, 02:16:30 AM »

uncommenting them should do the trick. Please insure that you have edited the correct copy of services.conf .. and not accidently edited the example.conf or the wrong copy of services.conf
Logged

Ankara

  • Guest
(No subject)
« Reply #6 on: June 09, 2006, 05:08:24 AM »

yeah it's working perfectly *except* for the hs_request memos
and the proper config is in use
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #7 on: June 09, 2006, 08:52:11 PM »

this is because of a little bug i think... try putting a space behind HSRequestMemoUser and HSRequestMemoOper

i have noticed this particular problem before with my own modules. if there is no space behind the variable name, and it is a PARAM_SET, it sets the variable to 0 instead of 1. i make a habbit of always putting a 1 behind them, just to make sure it ll recognise the variable.

i do not know whether this particular behavious is normal or whether it s just something that was overlooked. would have to ask a dev about that.

this is what i use in my modified version of hs_request...
Code: [Select]
# HSRequestMemoUser [OPTIONAL]
# Module: hs_request
#
# Set this if you want users to receive a memo after their vhost has been
# accepted/rejected.
#
#HSRequestMemoUser 1

# HSRequestMemoOper [OPTIONAL]
# Module: hs_request
#
# Set this if you want your ircops (opers and admins) to receive a memo
# when a new vhost is requested (not recommended on large networks).
#
#HSRequestMemoOper 1

# HSRequestMemoSetters [OPTIONAL]
# Module: hs_request
#
# Set this if you want the hostsetters to receive a memo when a new vhost
# is requested (not recommended on large networks).
#
#HSRequestMemoSetters 1

[Edited on 9-6-2006 by Viper]
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

Ankara

  • Guest
(No subject)
« Reply #8 on: June 10, 2006, 06:07:42 AM »

Wow that is so odd....

Ok putting a space in there, dint do the trick,
however, putting  a 1 in after each variable
made it work.
I noticed in the uncompiled module there is a config option
and they are all set to 0
Perhaps this is why.
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #9 on: June 10, 2006, 09:38:13 AM »

those are the default values, however if it is defined in the config, it should take those, and both a 0 and a 1 will probably be seen as a 1, for some reason it just don't read it without a space or in your case also a number or so. it should though, it s only supposed to look whether they are defined or not... weird
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)
Pages: [1]   Go Up