Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: link UnrealIRCd 4.0.7 and anope 2.0.4 problem  (Read 3625 times)

0 Members and 1 Guest are viewing this topic.

momai

  • Anope User
  • Offline Offline
  • Posts: 1
link UnrealIRCd 4.0.7 and anope 2.0.4 problem
« on: January 02, 2017, 09:53:43 AM »

The problem with the connection.
UnrealIRCd 4.0.7
Anope 2.0.4


I tried this:

Config anope

Code: [Select]
/*
 * [REQUIRED] IRCd Config
 *
 * This section is used to set up Anope to connect to your IRC network.
 * This section can be included multiple times, and Anope will attempt to
 * connect to each server until it finally connects.
 *
 * Each uplink IRCd should have a corresponding configuration to allow Services
 * to link to it.
 *
 * An example configuration for InspIRCd that is compatible with the below uplink
 * and serverinfo configuration would look like:
 *
 *     <link name="services.host.org"
 *           ipaddr="127.0.0.1"
 *           port="5555"
 *           sendpass="1234"
 *           recvpass="1234">
 *     <uline server="services.host.org" silent="yes">
 *     <bind address="127.0.0.1" port="5555" type="servers">
 *
 * An example configuration for UnrealIRCd that is compatible with the below uplink
 * and serverinfo configuration would look like:

    link services.host.org
     {
          username *;
          hostname *;
          bind-ip "127.0.0.1";
          port 5555;
          hub *;
          password-connect "1234";
          password-receive "1234";
          class servers;
     };
    ulines { services.host.org; };
     listen 127.0.0.1:5555;

uplink
{
/*
* The IP or hostname of the IRC server you wish to connect Services to.
* Usually, you will want to connect Services over 127.0.0.1 (aka localhost).
*
* NOTE: On some shell providers, this will not be an option.
  */
host = "127.0.0.1"
/*
* Enable if Services should connect using IPv6.
*/
ipv6 = no

/*
* Enable if Services should connect using SSL.
* You must have an SSL module loaded for this to work.
*/
ssl = no

/*
* The port to connect to.
* The IRCd *MUST* be configured to listen on this port, and to accept
* server connections.
*
* Refer to your IRCd documentation for how this is to be done.
*/
port = 5555

/*
* The password to send to the IRC server for authentication.
* This must match the link block on your IRCd.
*
* Refer to your IRCd documentation for more information on link blocks.
*/
password = "1234"
}

Config unreal


Code: [Select]
###############################################################
listen {
ip *;
port 6667;
options { clientsonly; };
};
# # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # #
listen {
ip *;
port 5555;
options { serversonly; };
};
###############################################################
ulines { services.host.org; stats.host.org; };
###############################################################
link services.host.org {
incoming {
mask 127.0.0.1;
};
outgoing {
bind-ip *;
hostname 127.0.0.1;
port 5555;
options { };
};
password "1234";
class servers;
};
###############################################################
link stats.host.org {
incoming {
mask 127.0.0.1;
};
outgoing {
bind-ip *;
hostname 127.0.0.1;
port 5555;
options { };
};
password "1234";
class servers;
};


When anope start swearing on uplink lines


Tried this configuration anope (unrea.confl did not change)

Code: [Select]
/*
*   link services.host.org
 *    {
 *         username *;
 *         hostname *;
 *         bind-ip "127.0.0.1";
 *         port 5555;
 *         hub *;
 *         password-connect "ergses";
 *         password-receive "ergses";
 *         class servers;
 *    };
 *   ulines { services.host.org; };
 *    listen 127.0.0.1:5555;
*/
uplink
{
/*
* The IP or hostname of the IRC server you wish to connect Services to.
* Usually, you will want to connect Services over 127.0.0.1 (aka localhost).
*
* NOTE: On some shell providers, this will not be an option.
  */
host = "127.0.0.1"
/*
* Enable if Services should connect using IPv6.
*/
ipv6 = no

/*
* Enable if Services should connect using SSL.
* You must have an SSL module loaded for this to work.
*/
ssl = no

/*
* The port to connect to.
* The IRCd *MUST* be configured to listen on this port, and to accept
* server connections.
*
* Refer to your IRCd documentation for how this is to be done.
*/
port = 5555

/*
* The password to send to the IRC server for authentication.
* This must match the link block on your IRCd.
*
* Refer to your IRCd documentation for more information on link blocks.
*/
password = "1234"
}



When you start getting error anope

Quote
Attempting to connect to uplink #1 127.0.0.1 (127.0.0.1), port 5555
Successfully connected to uplink #1 127.0.0.1:5555
ERROR: Missing password
ERROR: Closing Link: [127.0.0.1] (Missing password)


Password correct.

I tried to run as follows:

Code: [Select]
    link services.host.org
     {
          username *;
          hostname *;
          bind-ip "127.0.0.1";
          port 5555;
          hub *;
          password-connect "1234";
          password-receive "1234";
          class servers;
     };
    ulines { services.host.org; };
     listen 127.0.0.1:5555;

uplink
{
/*
* The IP or hostname of the IRC server you wish to connect Services to.
* Usually, you will want to connect Services over 127.0.0.1 (aka localhost).
*
* NOTE: On some shell providers, this will not be an option.
  */
host = "127.0.0.1"
/*
* Enable if Services should connect using IPv6.
*/
ipv6 = no

/*
* Enable if Services should connect using SSL.
* You must have an SSL module loaded for this to work.
*/
ssl = no

/*
* The port to connect to.
* The IRCd *MUST* be configured to listen on this port, and to accept
* server connections.
*
* Refer to your IRCd documentation for how this is to be done.
*/
port = 5555

/*
* The password to send to the IRC server for authentication.
* This must match the link block on your IRCd.
*
* Refer to your IRCd documentation for more information on link blocks.
*/
password = "1234"
}

I get an error at startup
Quote
Config item outside of section (or stray '=')
on line host = "127.0.0.1"

What am I doing wrong? Please help.
Logged

genius3000

  • Anope User
  • Offline Offline
  • Posts: 34
Re: link UnrealIRCd 4.0.7 and anope 2.0.4 problem
« Reply #1 on: January 07, 2017, 06:25:50 PM »

Your Anope config snippet changes a few times in regards to the comments and commented out example of ircd link block. Verify you are properly closing out a multi-line comment:
Quote
/*
is the start of a multi-line comment
it needs an end, like this
 */

Other than that, does UnrealIRCd allow 'password' instead of the -connect and -receive tags?
Logged
-genius3000
Pages: [1]   Go Up