Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: unexpected word: services.conf: 926  (Read 10032 times)

0 Members and 1 Guest are viewing this topic.

John Riley

  • Anope User
  • Offline Offline
  • Posts: 19
unexpected word: services.conf: 926
« on: May 07, 2016, 03:05:55 PM »

I've recently upgraded from Anope 1.8.9 to Anope 2.0.3 because Anope 1.8.9 would crash instantly upon starting and never connect. 
I have made sure I've told Anope to use the Databases on the first start, but Anope 2.0.3 won't start because of this error...
Unexpected Word: services.conf: 926
I'm using Windows 7 Professional 32Bit for my server machine as I also run a DOS BBS on a Telnet server on the system.

I'll post the segment of my services.conf where line 926 is located.

#oper
{
   /* The nickname of this services oper */
   name = "SLASHER"

   /* The opertype this person will have */
   type = "Services Root"

   /* If set, the user must be an oper on the IRCd to gain their Services
    * oper privileges.
    */
   require_oper = yes

   /* An optional password. If defined the user must login using "/msg OperServ LOGIN" first */
   password = "changedforhelpreasons"

   /* An optional SSL fingerprint. If defined, it's required to be able to use this opertype. */
   #certfp = "ed3383b3f7d74e89433ddaa4a6e5b2d7"

   /* An optional list of user@host masks. If defined the user must be connected from one of them */
   #host = "*@*.anope.org ident@*"

   /* An optional vHost to set on users who identify for this oper block.
    * This will override HostServ vHosts, and may not be available on all IRCds
    */
   #vhost = "oper.mynet"
}

#oper
{
   name = "SLASHBot"
   type = "Services Administrator"
}

#oper
{                                          <------  This is Line 926!
   name = "MacinSLASH"
   type = "Helper"
}
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: unexpected word: services.conf: 926
« Reply #1 on: May 07, 2016, 03:07:18 PM »

Quote
#oper
{
   /* The nickname of this services oper */
   name = "SLASHER"

Should be

Quote
oper
{
   /* The nickname of this services oper */
   name = "SLASHER"

and so on and so forth.
Logged

John Riley

  • Anope User
  • Offline Offline
  • Posts: 19
Re: unexpected word: services.conf: 926
« Reply #2 on: May 07, 2016, 03:53:34 PM »

Thanks for the quick reply.  I had to step out of the house for a bit, but when I got home I changed the #oper to just oper, and I'm still getting the error.

Not sure why either.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: unexpected word: services.conf: 926
« Reply #3 on: May 07, 2016, 03:55:24 PM »

I'm going to need to see more information.

Pastebin the whole config at pastebin.anope.org (tick the protect button) and paste a new log entry with a recent timestamp showing the error.
Logged

John Riley

  • Anope User
  • Offline Offline
  • Posts: 19
Re: unexpected word: services.conf: 926
« Reply #4 on: May 07, 2016, 04:12:37 PM »

Okay, I added it to the Pastebin.  Paste ID: 379b0915c0

I included the error screen, my Anope 2.0.3 services.conf and just to make sure everything lined up and can use my original databases on the first boot I added my original Anope 1.8.9 config file.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: unexpected word: services.conf: 926
« Reply #5 on: May 07, 2016, 04:15:22 PM »

Humour me for a moment, if this doesn't work I'll run your config up and find the error.

Uncomment (remove #) from the paste line 932, and 938 (your lines starting #oper)

Logged

John Riley

  • Anope User
  • Offline Offline
  • Posts: 19
Re: unexpected word: services.conf: 926
« Reply #6 on: May 07, 2016, 04:28:19 PM »

Yeah, still didn't work.  I fixed a few issues where I saw that Anope wouldn't use my original databases from Anope 1.8.9 unless I removed the #, corrected those and reposted my services.conf.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: unexpected word: services.conf: 926
« Reply #7 on: May 07, 2016, 04:29:35 PM »

Give me a few mins, I'll run up a copy with your config.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: unexpected word: services.conf: 926
« Reply #8 on: May 07, 2016, 04:51:07 PM »

Found it, you've nuked the start of the comment block

Quote
#oper
{
   name = "SLASHBot"
   type = "Services Administrator"
}

#oper
{
   name = "MacinSLASH"
   type = "Helper"
}


 * [OPTIONAL] Mail Config
 *
 * This section contains settings related to the use of e-mail from Services.
 * If the usemail directive is set to yes, unless specified otherwise, all other
 * directives are required.
 *
 * NOTE: Users can find the IP of the machine services is running on by examining
 * mail headers. If you do not want your IP known, you should set up a mail relay
 * to strip the relevant headers.
 */
mail
{


Before the * [OPTIONAL]  you should have a / to indicate a comment block
Logged

John Riley

  • Anope User
  • Offline Offline
  • Posts: 19
Re: unexpected word: services.conf: 926
« Reply #9 on: May 07, 2016, 04:54:10 PM »

So I should have this?

oper
{
   name = "SLASHBot"
   type = "Services Administrator"
}

oper
{
   name = "MacinSLASH"
   type = "Helper"
}

/
 * [OPTIONAL] Mail Config
 *
 * This section contains settings related to the use of e-mail from Services.
 * If the usemail directive is set to yes, unless specified otherwise, all other
 * directives are required.
 *
 * NOTE: Users can find the IP of the machine services is running on by examining
 * mail headers. If you do not want your IP known, you should set up a mail relay
 * to strip the relevant headers.
 */
mail
{
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: unexpected word: services.conf: 926
« Reply #10 on: May 07, 2016, 04:56:36 PM »

no this:


oper
{
   name = "SLASHBot"
   type = "Services Administrator"
}

oper
{
   name = "MacinSLASH"
   type = "Helper"
}

/* [OPTIONAL] Mail Config
 *
 * This section contains settings related to the use of e-mail from Services.
 * If the usemail directive is set to yes, unless specified otherwise, all other
 * directives are required.
 *
 * NOTE: Users can find the IP of the machine services is running on by examining
 * mail headers. If you do not want your IP known, you should set up a mail relay
 * to strip the relevant headers.
 */
mail
{
Logged

John Riley

  • Anope User
  • Offline Offline
  • Posts: 19
Re: unexpected word: services.conf: 926
« Reply #11 on: May 07, 2016, 05:02:21 PM »

Okay, I will try that.  Give a couple minutes.  I'll will come back and post results.
Logged

John Riley

  • Anope User
  • Offline Offline
  • Posts: 19
Re: unexpected word: services.conf: 926
« Reply #12 on: May 07, 2016, 05:15:12 PM »

I'm getting the same error.  Are you getting my config file to run in your test setup?

no this:


oper
{
   name = "SLASHBot"
   type = "Services Administrator"
}

oper
{
   name = "MacinSLASH"
   type = "Helper"
}

/* [OPTIONAL] Mail Config
 *
 * This section contains settings related to the use of e-mail from Services.
 * If the usemail directive is set to yes, unless specified otherwise, all other
 * directives are required.
 *
 * NOTE: Users can find the IP of the machine services is running on by examining
 * mail headers. If you do not want your IP known, you should set up a mail relay
 * to strip the relevant headers.
 */
mail
{
Logged

Vitor

  • Anope User
  • Offline Offline
  • Posts: 2
Re: unexpected word: services.conf: 926
« Reply #13 on: May 07, 2016, 05:23:44 PM »

try the following:
oper
{
   name = "SLASHBot"
   type = "Services Administrator"
}

oper
{
   name = "MacinSLASH"
   type = "Helper"
}

/*
* [OPTIONAL] Mail Config
 *
 * This section contains settings related to the use of e-mail from Services.
 * If the usemail directive is set to yes, unless specified otherwise, all other
 * directives are required.
 *
 * NOTE: Users can find the IP of the machine services is running on by examining
 * mail headers. If you do not want your IP known, you should set up a mail relay
 * to strip the relevant headers.
 */
mail
{
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: unexpected word: services.conf: 926
« Reply #14 on: May 07, 2016, 05:24:11 PM »

It gets as far as complaining about your other configs yes.

[May 07 12:23:10.031998 2016] Debug: File botserv.rileypcmd.conf could not be opened.


Pastebin what config you have right now, I will check again.
Logged

John Riley

  • Anope User
  • Offline Offline
  • Posts: 19
Re: unexpected word: services.conf: 926
« Reply #15 on: May 07, 2016, 05:31:24 PM »

I updated PasteBin with current changes to config.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: unexpected word: services.conf: 926
« Reply #16 on: May 07, 2016, 05:39:03 PM »

I don't see your changes, the last modified time on the paste was ages ago.

Try again.
Logged

John Riley

  • Anope User
  • Offline Offline
  • Posts: 19
Re: unexpected word: services.conf: 926
« Reply #17 on: May 07, 2016, 05:43:31 PM »

Here you go.  I think it gave me another PasteBin ID.

Paste ID: 60b3ff8161
Submitted by: Anonymous
Date: 07/05/16 16:42:22
Views: 1
This paste is protected.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: unexpected word: services.conf: 926
« Reply #18 on: May 07, 2016, 05:50:21 PM »

Phew you've used a bad editor or some horrible find/replace at some point.

Anyway, look at lines 1026, 1013, and 1000 - compare those to example.conf

                                Please type \" /msg NickServ CONFIRM %c \" to complete registration.

You don't have the " escaped with \

Once you fix those you'll get to an error:

[May 07 12:49:16.964411 2016] Debug: File botserv.rileypcmd.conf could not be opened.


which of course I don't have.

Hopefully it'll work.
Logged

John Riley

  • Anope User
  • Offline Offline
  • Posts: 19
Re: unexpected word: services.conf: 926
« Reply #19 on: May 07, 2016, 06:26:46 PM »

Not sure why the / isn't showing up in the PasteBin, but they're in my services.conf.  As far as my editor, I've always used gedit.
Logged

John Riley

  • Anope User
  • Offline Offline
  • Posts: 19
Re: unexpected word: services.conf: 926
« Reply #20 on: May 07, 2016, 06:47:55 PM »

Charles, thank you!  It is working....  Apparently I was updating the services.conf in c:\user\public\docoments and not the one in c:\program files\anope\conf...

Once I copied it over to the correct location with the correct updates, it started working.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: unexpected word: services.conf: 926
« Reply #21 on: May 07, 2016, 07:11:06 PM »

:)
Logged
Pages: [1]   Go Up