Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  


Pages: [1]   Go Down

Author Topic: Statserv seems to do nothing  (Read 2896 times)

0 Members and 1 Guest are viewing this topic.


  • Anope User
  • Offline Offline
  • Posts: 182
    • French Eggdrop community
Statserv seems to do nothing
« on: January 10, 2016, 06:49:08 PM »

Hello there,

I'm trying to use anope 2.0.2 in replacement of anope 1.8 + denora.

Everything works, all tables have been created, I can see StatServ in my log channel, but the chanstats, ison, maxusers and user tables stay empty.
The m_mysql.cpp and stats modules are enabled.

Did I forget a step ?


  • Anope User
  • Offline Offline
  • Posts: 182
    • French Eggdrop community
Re: Statserv seems to do nothing
« Reply #1 on: January 12, 2016, 01:12:52 PM »

Small addition:

Code: [Select]
OperServ( : Module: unreal[2.0.2][Protocol,Vendor]
OperServ( : Module: db_flatfile[2.0.2][Database,Vendor]
OperServ( : Module: enc_md5[2.0.2][Encryption,Vendor]
OperServ( : Module: m_dns[2.0.2][Extra,Vendor]
OperServ( : Module: m_dnsbl[2.0.2][Extra,Vendor]
OperServ( : Module: m_mysql[2.0.2][Extra,Vendor]
OperServ( : Module: m_regex_pcre[2.0.2][Extra,Vendor]
OperServ( : Module: m_chanstats[2.0.2][Extra,Vendor]
OperServ( : Module: irc2sql[2.0.2][Extra,Vendor]
OperServ( : Module: db_sql[2.0.2][Database,Vendor]
OperServ( : Module: m_sql_log[2.0.2][Extra,Vendor]
OperServ( : 11 modules loaded.

I've done:

Code: [Select]
/cs set chanstats #channel on
/ns set chanstats on
Then, I've said some stuff in the channel (yesterday and today), but more than 24h after having enable the stats:
MSG(chanserv): stats #channel
ChanServ ( No stats for CrazyCat.

What can I forget or doing bad ?

Resolved : DukePyrolator said me to start anope with the --debug=2 option, and I saw it was a trouble with MySQL:
Code: [Select]
[Jan 12 14:44:57.001368 2016] Chanstats: Error executing query CALL svc_chanstats_proc_update('#zeolia', 'CrazyCat', 1, '4', '1', '0', '0', '0', '0', '0', '0', '0', '0');: Thread stack overrun: 6800 bytes used of a 131072 byte stack, and 128000 bytes needed. Use 'mysqld --thread_stack=#' to specify a bigger stack.I'd changed the thread_stack value in /etc/mysql/my.cnf and it works !
« Last Edit: January 12, 2016, 02:02:04 PM by CrazyCat »
Pages: [1]   Go Up