Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: cannot link anope 2.0.1 and Unreal 3.2.10.4  (Read 10061 times)

0 Members and 1 Guest are viewing this topic.

Cheryl Darden

  • Anope User
  • Offline Offline
  • Posts: 26
cannot link anope 2.0.1 and Unreal 3.2.10.4
« on: February 02, 2015, 04:56:42 AM »

Help! cannot link anope to server at all! i keep getting same error no matter how i edit the services.conf.

Feb 01 19:29:07.081446 2015] Debug: Attempting to connect to uplink #1 69.***.***.** (69.162.163.21), port 6667
[Feb 01 19:29:07.081663 2015] Debug: Successfully connected to uplink #1 69.***.***.** :6667
[Feb 01 19:29:07.081969 2015] Debug: Sent: :services.edgeradio.net PROTOCTL NICKv2 VHP UMODE2 NICKIP SJOIN SJOIN2 SJ3 NOQUIT TKLEXT ESVID MLOCK VL VL
[Feb 01 19:29:07.082105 2015] Debug: Sent: :services.edgeradio.net PASS :****
[Feb 01 19:29:07.082176 2015] Debug: Sent: :services.edgeradio.net SERVER services.edgeradio.net 0 :U0-*-services.edgeradio.net Services for IRC Networks
[Feb 01 19:29:07.100915 2015] Debug: Received: :69.***.***.** NOTICE AUTH :*** Looking up your hostname...
[Feb 01 19:29:07.117044 2015] Debug: unexpected non-user source 69.***.***.**  for NOTICE
[Feb 01 19:29:07.117103 2015] Debug: Received: :69.***.***.**  NOTICE AUTH :*** Couldn't resolve your hostname; using your IP address instead
[Feb 01 19:29:07.117151 2015] Debug: unexpected non-user source 69.***.***.**  for NOTICE
[Feb 01 19:29:07.117207 2015] Debug: Received: ERROR :Link denied (No matching link configuration) [@0:0:0:0:0:ffff:69.***.***.** .52060]
[Feb 01 19:29:07.117248 2015] Debug: ERROR: Link denied (No matching link config
uration) [@0:0:0:0:0:ffff:69.***.***.** .52060]
[Feb 01 19:29:07.117277 2015] Debug: Received: ERROR :Closing Link: [69.***.***.** ] (Link denied (No matching link configuration))
[Feb 01 19:29:07.117309 2015] Debug: ERROR: Closing Link: [69.***.***.** ] (Link denied (No matching link configuration))
[Feb 01 19:29:07.130604 2015] Debug: Received ERROR from uplink: Closing Link: [69.***.***.** ] (Link denied (No matching link configuration))

*     link services.edgeradio.net
 *     {
 *          username puresounds;
 *          hostname 69.***.***.**;
 *          bind-ip  69.***.***.**;
 *          port 6667;
 *          hub *;
 *          password-connect "mypasshere";
 *          password-receive "mypasshere";
 *          class servers;
 *     };
 *     ulines { services.edgeradio.net; };
 *     listen 69.***.***.**:6667;
 */   

uplink
{
   /*
    * The IP or hostname of the IRC server you wish to connect Services to.
    * Usually, you will want to connect Services over 127.0.0.1 (aka localhost).
    *
    * NOTE: On some shell providers, this will not be an option.
    */
   host = "69.***.***.**"

   /*
    * Enable if Services should connect using IPv6.
    */
   ipv6 = no

   /*
    * Enable if Services should connect using SSL.
    * You must have an SSL module loaded for this to work.
    */
   ssl = no

   /*
    * The port to connect to.
    * The IRCd *MUST* be configured to listen on this port, and to accept
    * server connections.
    *
    * Refer to your IRCd documentation for how this is to be done.
    */
   port = 6667

   /*
    * The password to send to the IRC server for authentication.
    * This must match the link block on your IRCd.
    *
    * Refer to your IRCd documentation for more information on link blocks.
    */
   password = "mypasswordhere"

*/


link          services.edgeradio.net
{
   username   puresounds;
   hostname    69.***.***.**;
   bind-ip    69.***.***.**;
   port       6667;
        hub             *;
   password-connect "mypasshere";
   password-receive "mypasshere";
   class           servers;

};
/*
 *
 * NEW: ulines {}
 * OLD: U:Line
 * U-lines give servers more power/commands, this should ONLY be set
 * for services/stats servers and NEVER for normal UnrealIRCd servers!
 * Syntax is as follows:
 * ulines {
 *   (server to uline);
 *   (server to uline);
 *  [etc]
 * };
*/
ulines {
   services.edgeradio.net;
   stats.edgeradio.net;
};
}
also been about 6 yrs since i've done this so bear with me lol :)
Logged

wilco

  • Anope User
  • Offline Offline
  • Posts: 12
Re: cannot link anope 2.0.1 and Unreal 3.2.10.4
« Reply #1 on: February 02, 2015, 07:24:46 AM »

use correct ircd protocol
Logged

wilco

  • Anope User
  • Offline Offline
  • Posts: 12
Re: cannot link anope 2.0.1 and Unreal 3.2.10.4
« Reply #2 on: February 02, 2015, 07:29:34 AM »

/*
 * [REQUIRED] Protocol module
 *
 * This directive tells Anope which IRCd Protocol to speak when connecting.
 * You MUST modify this to match the IRCd you run.
 *
 * Supported:
 *  - bahamut
 *  - charybdis
 *  - hybrid
 *  - inspircd12
 *  - inspircd20
 *  - ngircd
 *  - plexus
 *  - ratbox
 *  - unreal
 */
module
{
   name = "inspircd20"

use    name = "unreal"

 instead of    name = "inspircd20"

also use another port dont use 6667 use 7000 or something
Logged

Cheryl Darden

  • Anope User
  • Offline Offline
  • Posts: 26
Re: cannot link anope 2.0.1 and Unreal 3.2.10.4
« Reply #3 on: February 02, 2015, 10:14:54 PM »

tried 7000 and the operation timed out this time :/ so try another port im guessing.
Logged

Cheryl Darden

  • Anope User
  • Offline Offline
  • Posts: 26
Re: cannot link anope 2.0.1 and Unreal 3.2.10.4
« Reply #4 on: February 02, 2015, 11:55:31 PM »

it has the name unreal and i've tried every port i can think of. so im still stuck. all other ports time out and 6667 wont connect.
Logged

Cheryl Darden

  • Anope User
  • Offline Offline
  • Posts: 26
Re: cannot link anope 2.0.1 and Unreal 3.2.10.4
« Reply #5 on: February 04, 2015, 01:13:18 AM »

can't anyone give me any ideas? please :)
Logged

Cheryl Darden

  • Anope User
  • Offline Offline
  • Posts: 26
Re: cannot link anope 2.0.1 and Unreal 3.2.10.4
« Reply #6 on: February 05, 2015, 09:34:56 PM »

what is unexpected non-user source mean also? im still stuck and services won't connect. :/ i've tried everything i can think of.
Logged

Taylor

  • Contributor
  • *
  • Offline Offline
  • Posts: 100
Re: cannot link anope 2.0.1 and Unreal 3.2.10.4
« Reply #7 on: February 05, 2015, 09:46:32 PM »

Help! cannot link anope to server at all! i keep getting same error no matter how i edit the services.conf.

Feb 01 19:29:07.081446 2015] Debug: Attempting to connect to uplink #1 69.***.***.** (69.162.163.21), port 6667
[Feb 01 19:29:07.081663 2015] Debug: Successfully connected to uplink #1 69.***.***.** :6667
[Feb 01 19:29:07.081969 2015] Debug: Sent: :services.edgeradio.net PROTOCTL NICKv2 VHP UMODE2 NICKIP SJOIN SJOIN2 SJ3 NOQUIT TKLEXT ESVID MLOCK VL VL
[Feb 01 19:29:07.082105 2015] Debug: Sent: :services.edgeradio.net PASS :****
[Feb 01 19:29:07.082176 2015] Debug: Sent: :services.edgeradio.net SERVER services.edgeradio.net 0 :U0-*-services.edgeradio.net Services for IRC Networks
[Feb 01 19:29:07.100915 2015] Debug: Received: :69.***.***.** NOTICE AUTH :*** Looking up your hostname...
[Feb 01 19:29:07.117044 2015] Debug: unexpected non-user source 69.***.***.**  for NOTICE
[Feb 01 19:29:07.117103 2015] Debug: Received: :69.***.***.**  NOTICE AUTH :*** Couldn't resolve your hostname; using your IP address instead
[Feb 01 19:29:07.117151 2015] Debug: unexpected non-user source 69.***.***.**  for NOTICE
[Feb 01 19:29:07.117207 2015] Debug: Received: ERROR :Link denied (No matching link configuration) [@0:0:0:0:0:ffff:69.***.***.** .52060]
[Feb 01 19:29:07.117248 2015] Debug: ERROR: Link denied (No matching link config
uration) [@0:0:0:0:0:ffff:69.***.***.** .52060]
[Feb 01 19:29:07.117277 2015] Debug: Received: ERROR :Closing Link: [69.***.***.** ] (Link denied (No matching link configuration))
[Feb 01 19:29:07.117309 2015] Debug: ERROR: Closing Link: [69.***.***.** ] (Link denied (No matching link configuration))
[Feb 01 19:29:07.130604 2015] Debug: Received ERROR from uplink: Closing Link: [69.***.***.** ] (Link denied (No matching link configuration))

*     link services.edgeradio.net
 *     {
 *          username puresounds;
 *          hostname 69.***.***.**;
 *          bind-ip  69.***.***.**;
 *          port 6667;
 *          hub *;
 *          password-connect "mypasshere";
 *          password-receive "mypasshere";
 *          class servers;
 *     };
 *     ulines { services.edgeradio.net; };
 *     listen 69.***.***.**:6667;
 */   

uplink
{
   /*
    * The IP or hostname of the IRC server you wish to connect Services to.
    * Usually, you will want to connect Services over 127.0.0.1 (aka localhost).
    *
    * NOTE: On some shell providers, this will not be an option.
    */
   host = "69.***.***.**"

   /*
    * Enable if Services should connect using IPv6.
    */
   ipv6 = no

   /*
    * Enable if Services should connect using SSL.
    * You must have an SSL module loaded for this to work.
    */
   ssl = no

   /*
    * The port to connect to.
    * The IRCd *MUST* be configured to listen on this port, and to accept
    * server connections.
    *
    * Refer to your IRCd documentation for how this is to be done.
    */
   port = 6667

   /*
    * The password to send to the IRC server for authentication.
    * This must match the link block on your IRCd.
    *
    * Refer to your IRCd documentation for more information on link blocks.
    */
   password = "mypasswordhere"

*/


link          services.edgeradio.net
{
   username   puresounds;
   hostname    69.***.***.**;
   bind-ip    69.***.***.**;
   port       6667;
        hub             *;
   password-connect "mypasshere";
   password-receive "mypasshere";
   class           servers;

};
/*
 *
 * NEW: ulines {}
 * OLD: U:Line
 * U-lines give servers more power/commands, this should ONLY be set
 * for services/stats servers and NEVER for normal UnrealIRCd servers!
 * Syntax is as follows:
 * ulines {
 *   (server to uline);
 *   (server to uline);
 *  [etc]
 * };
*/
ulines {
   services.edgeradio.net;
   stats.edgeradio.net;
};
}
also been about 6 yrs since i've done this so bear with me lol :)

This looked all correct, I think you have the link block for unrealircd.conf in services.conf  you need to have it in unrealircd.conf and it should work. (Thats what the error was saying, there is no link block for anope in unrealircd.conf)
Logged
Cronus
irc.cncirc.net
http://CnCIRC.net

Cheryl Darden

  • Anope User
  • Offline Offline
  • Posts: 26
Re: cannot link anope 2.0.1 and Unreal 3.2.10.4
« Reply #8 on: February 05, 2015, 10:30:25 PM »

oh those are 2 different conf's. top one is services then bottom one is unrealircd. i have 2 link blocks. one in services and one in unreal. if i use port 6667 it says that up there unexpected non-user source link denied no matching link configuration. if i use a different port like 7000 or something i get operation timed out. it won't connect at all. it's all weird to me. i've opened ports in router. i just am so confused. thanks for looking at this for me.
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: cannot link anope 2.0.1 and Unreal 3.2.10.4
« Reply #9 on: February 06, 2015, 05:43:26 AM »

in the link block for services on unrealircd.conf change:

1. The username to *; and not puresounds;
2. The bind-ip address is the IP address of the unreal ircd and in many cases is not needed. it too can be set to *;
3. Make sure that the hostname is set to the IP that services is connecting from.

After making changes and saving the document in the correct directory  /rehash on IRC. Then issue /stats U (yes, UPPER case U) and make sure it lists services there and the services entry is case sensitive so make sure it's exact.
Logged

Cheryl Darden

  • Anope User
  • Offline Offline
  • Posts: 26
Re: cannot link anope 2.0.1 and Unreal 3.2.10.4
« Reply #10 on: February 06, 2015, 05:31:23 PM »

i can't link it still and i can't do stats U due to i dont have the oper privileges due to me not having services on my server. :/ is there anyway i can just post my whole unrealircd and services.conf to one of you and you look at them and just tell me where i'm going wrong? ive been working on this for about 2 weeks and nothing yet. i just dont see it. i know ive missed something somewhere.
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: cannot link anope 2.0.1 and Unreal 3.2.10.4
« Reply #11 on: February 06, 2015, 08:48:52 PM »

i can't link it still and i can't do stats U due to i dont have the oper privileges due to me not having services on my server. :/ is there anyway i can just post my whole unrealircd and services.conf to one of you and you look at them and just tell me where i'm going wrong? ive been working on this for about 2 weeks and nothing yet. i just dont see it. i know ive missed something somewhere.

oper access is assigned in the unrealircd.conf and has nothing to do with services at all.
Logged

Taylor

  • Contributor
  • *
  • Offline Offline
  • Posts: 100
Re: cannot link anope 2.0.1 and Unreal 3.2.10.4
« Reply #12 on: February 06, 2015, 09:48:07 PM »

You can come on irc.anope.org and join #anope for help, if im around i can look at it, but there are plenty of people that can assist you.
Logged
Cronus
irc.cncirc.net
http://CnCIRC.net

Cheryl Darden

  • Anope User
  • Offline Offline
  • Posts: 26
Re: cannot link anope 2.0.1 and Unreal 3.2.10.4
« Reply #13 on: February 08, 2015, 12:43:51 PM »

You can come on irc.anope.org and join #anope for help, if im around i can look at it, but there are plenty of people that can assist you.
ok great Taylor!! Thanks for that info!! I'll join that room later on this morning when more ppl are awake. Thanks everyone for all your help. I'm just so rusty with all this, i'm just a noob again. lol i have no shame in that either. i'm sorry for bothering ya'll tho. but i really appreciate all ya'll do :) thanks again.
Logged

Cheryl Darden

  • Anope User
  • Offline Offline
  • Posts: 26
Re: cannot link anope 2.0.1 and Unreal 3.2.10.4
« Reply #14 on: February 08, 2015, 03:08:23 PM »

omg! i cant believe it, i'm linked!! lol well see I had a friend helping me at first and he was the one who set up my unrealircd. i just found out I had 2 unrealircd.conf's and well i was using the wrong one :/ dumb me LOL! i dunno why i had 2. Sorry for the inconvience i put ya'll thru!! but THANKS a ton for all of ya'lls help! im forever greatful :D
Logged
Pages: [1]   Go Up