Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: ERROR: Missing password  (Read 3582 times)

0 Members and 1 Guest are viewing this topic.

Craig Fairhurst

  • Anope User
  • Offline Offline
  • Posts: 28
ERROR: Missing password
« on: November 09, 2014, 09:44:24 PM »

Hi

When I try and start anope IRC services I get the following:
Code: [Select]
$ ./bin/services
Anope 2.0.1, build #3, compiled 15:59:29 Nov  9 2014
Using configuration file conf/services.conf
Attempting to connect to uplink #1 127.0.0.1 (127.0.0.1), port 7000
Successfully connected to uplink #1 127.0.0.1:7000
ERROR: Missing password
ERROR: Closing Link: [127.0.0.1] (Missing password)

Here is my uplink code block:
Code: [Select]
uplink
{
        /*
         * The IP or hostname of the IRC server you wish to connect Services to.
         * Usually, you will want to connect Services over 127.0.0.1 (aka localhost).
         *
         * NOTE: On some shell providers, this will not be an option.
         */
        host = "127.0.0.1"

        /*
         * Enable if Services should connect using IPv6.
         */
        ipv6 = no

        /*
         * Enable if Services should connect using SSL.
         * You must have an SSL module loaded for this to work.
         */
        ssl = no

        /*
         * The port to connect to.
         * The IRCd *MUST* be configured to listen on this port, and to accept
         * server connections.
         *
         * Refer to your IRCd documentation for how this is to be done.
         */
        port = 7000

        /*
         * The password to send to the IRC server for authentication.
         * This must match the link block on your IRCd.
         *
         * Refer to your IRCd documentation for more information on link blocks.
         */
        password = "test"
}

Here is my unrealircd.conf:
Code: [Select]
link            services.glx-alliance.com
{
        username        *;
        hostname        127.0.0.1;
        bind-ip         *;
        port            7000;
        hub             *;
        password-connect "test";
        password-receive "test";
        class           default;
};

I've double and triple checked that I am editing the correct configuration files, so it can't be a case of mistaken identity within the filesystem.

Kind regards

Jens Voss

  • Team
  • *
  • Offline Offline
  • Posts: 123
Re: ERROR: Missing password
« Reply #1 on: November 09, 2014, 09:50:52 PM »

Make sure you are using the right protocol module.
In the example.conf the default is "inspircd20", not "unreal".
Logged

Craig Fairhurst

  • Anope User
  • Offline Offline
  • Posts: 28
Re: ERROR: Missing password
« Reply #2 on: November 09, 2014, 09:52:39 PM »

OK, I changed that setting and now i get
Code: [Select]
[glx@europa network-services]$ ./bin/services
Anope 2.0.1, build #3, compiled 15:59:29 Nov  9 2014
Using configuration file conf/services.conf
Attempting to connect to uplink #1 127.0.0.1 (127.0.0.1), port 7000
Successfully connected to uplink #1 127.0.0.1:7000
ERROR: Link denied (No matching link configuration) [@127.0.0.1.45212]
ERROR: Closing Link: [127.0.0.1] (Link denied (No matching link configuration))

Craig Fairhurst

  • Anope User
  • Offline Offline
  • Posts: 28
Re: ERROR: Missing password
« Reply #3 on: November 09, 2014, 10:07:15 PM »

I can't seem to find an example configuration file for this type of connection. I assume this is an Anope problem?

Kind regards

Craig Fairhurst

  • Anope User
  • Offline Offline
  • Posts: 28
Re: ERROR: Missing password
« Reply #4 on: November 09, 2014, 10:27:02 PM »

I'll create a new thread. Thanks all.
Pages: [1]   Go Up