Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: BotServ wont let me ADD bots  (Read 7109 times)

0 Members and 1 Guest are viewing this topic.

Juan c

  • Anope User
  • Offline Offline
  • Posts: 7
BotServ wont let me ADD bots
« on: October 06, 2014, 07:50:13 PM »

Ok I want to add some bots so I

Code: [Select]
/open Dragnovich <mypass>
[13:27:57] You are now an IRC Operator

Then I issue this
Code: [Select]
/msg BotServ BOT ADD MyBot MyIrcBot myserver.mx MyServer
[13:24:39] [NOTICE BotServ]: Acceso denegado.

What Im doing wrong?? >:(

this what I have in the unreal.conf
Code: [Select]
oper Dragnovich {
        class           clients;
        from {
                userhost *@*;
        };
        password "<mypass>";
        flags
        {
                netadmin;
                can_zline;
                can_gzline;
                can_gkline;
                global;
        };
};

It seems that BotServ is working correctly:
Code: [Select]
[13:48:03] [MSG -> BotServ]: BOTLIST
[13:48:03] [NOTICE BotServ]: Lista de bots:
[13:48:03] [NOTICE BotServ]: Nick      Máscara
[13:48:03] [NOTICE BotServ]: BotServ   services@services.myserver.mx
[13:48:03] [NOTICE BotServ]: ChanServ  services@services.myserver.mx
[13:48:03] [NOTICE BotServ]: Global    services@services.myserver.mx
[13:48:03] [NOTICE BotServ]: NickServ  services@services.myserver.mx
[13:48:03] [NOTICE BotServ]: OperServ  services@services.myserver.mx
[13:48:03] [NOTICE BotServ]: 5 bots disponibles.

Please help...
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: BotServ wont let me ADD bots
« Reply #1 on: October 06, 2014, 07:52:26 PM »

It's got nothing to do with unreal's config.

You lack services permissions it seems.

Have you registered/identified to a nickname you've added as a Services Root?

(if you don't know what that means, pastebin the whole services.conf)
Logged

Juan c

  • Anope User
  • Offline Offline
  • Posts: 7
Re: BotServ wont let me ADD bots
« Reply #2 on: October 06, 2014, 08:25:40 PM »

Code: [Select]
define
{
        name = "services.host"
        value = "services.MyServer.mx"
}

uplink
{
        host = "MyServer.mx"
        ipv6 = no
        ssl = no
        port = 6667
        password = "<MyPass>"
}
serverinfo
{
        name = "services.MyServer.mx"
        description = "MyServerMX"
        pid = "data/services.pid"
        motd = "conf/services.motd"
}
module
{
        name = "unreal"
        use_server_side_mlock = yes
        use_server_side_topiclock = yes
}
networkinfo
{
        networkname = "MyServerMX"
        nicklen = 31
        userlen = 10
        hostlen = 64
        chanlen = 32
        modelistsize = 100
        vhost_chars = "abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789.-"
        allow_undotted_vhosts = false
        disallow_start_or_end = ".-"
}
options
{
        user = "ircadmin"
        group = "ircadmin"
        casemap = "ascii"
        seed = 928347998
        strictpasswords = yes
        badpasslimit = 5
        badpasstimeout = 1h
        updatetimeout = 5m
        expiretimeout = 30m
        readtimeout = 5s
        warningtimeout = 4h
        timeoutcheck = 3s
        #useprivmsg = yes
        #usestrictprivmsg = yes
        #hidestatso = yes
        #ulineservers = "stats.your.network"
        retrywait = 60s
        hideprivilegedcommands = yes
        hideregisteredcommands = yes
        regexengine = "regex/pcre"
        languages = "es_ES.UTF-8"
        defaultlanguage = "es_ES.UTF-8"
        #defaultlanguage = "en"
}
include
{
        type = "file"
        name = "botserv.conf"
}

include
{
        type = "file"
        name = "chanserv.conf"
}

include
{
        type = "file"
        name = "global.conf"
}

#include
{
        type = "file"
        name = "hostserv.conf"
}

#include
{
        type = "file"
        name = "memoserv.conf"
}

include
{
        type = "file"
        name = "nickserv.conf"
}

include
{
        type = "file"
        name = "operserv.conf"
}

log
{
        target = "loggin.log"
        #target = "services.log #services"
        #source = ""
        bot = "Global"
        logage = 7
        admin = "*"
        override = "chanserv/* nickserv/* memoserv/set ~botserv/set botserv/*"
        commands = "~operserv/* *"
        servers = "*"
        #channels = "~mode *"
        users = "connect disconnect nick"
        other = "*"
        rawio = no
        debug = no
}

log
{
        target = "globops"
        admin = "global/* operserv/mode operserv/kick operserv/akill operserv/s*line operserv/noop operserv/jupe operserv/oline operserv/set operserv/svsnick operserv/svsjoin operserv/svspart nickserv/getpass */drop"
        servers = "squit"
        users = "oper"
        other = "expire/* bados akill/*"
}

opertype
{
        name = "Helper"
        commands = "hostserv/*"
}

opertype
{
        name = "Services Operator"
        inherits = "Helper, Another Helper"
        commands = "chanserv/list chanserv/suspend chanserv/topic memoserv/staff nickserv/list nickserv/suspend operserv/mode operserv/chankill operserv/akill operserv/session operserv/modinfo operserv/sqline operserv/oper operserv/kick operserv/ignore operserv/snline"
        privs = "chanserv/auspex chanserv/no-register-limit memoserv/* nickserv/auspex nickserv/confirm"
        modes = "+o"
}

opertype
{
        name = "Services Administrator"
        inherits = "Services Operator"
        commands = "chanserv/access/list chanserv/drop chanserv/getkey chanserv/saset/noexpire memoserv/sendall nickserv/saset/* nickserv/getemail operserv/news operserv/jupe operserv/svs operserv/stats operserv/oline operserv/noop operserv/forbid global/*"
        privs = "*"
}

opertype
{
        name = "Services Root"
        commands = "*"
        privs = "*"
}

module
{
        name = "db_flatfile"
        database = "anope.db"
        keepbackups = 3
        fork = no
}

module
{
        #name = "db_sql"
        name = "db_sql_live"
        engine = "mysql/main"
        prefix = "anope_db_"
        import = false
}

module { name = "enc_none" }
#module { name = "enc_md5" }

include
{
        type = "file"
        name = "modules.conf"
}

Also MySQL integration dont work
« Last Edit: October 06, 2014, 08:29:30 PM by Juan c »
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: BotServ wont let me ADD bots
« Reply #3 on: October 06, 2014, 08:33:12 PM »

OK, so I don't see anything in there about you telling services who you are to get permissions.

MySQL does work, you're just doing it wrong.

Lets fix the basic problem first ... go look in the example configurations for how you configure yourself as a services root.
Logged

Juan c

  • Anope User
  • Offline Offline
  • Posts: 7
Re: BotServ wont let me ADD bots
« Reply #4 on: October 06, 2014, 08:52:34 PM »

Ok I added, just after the services root definition...
Code: [Select]
opertype
{
        name = "Services Root"
        commands = "*"
        privs = "*"
}

oper
{
        name = "Dragnovich"
        type = "Services Root"
        require_oper = yes
        password = "<MyPass>"
}

Still dont work...
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: BotServ wont let me ADD bots
« Reply #5 on: October 06, 2014, 09:15:42 PM »

Hello,

It would be useful if you provided helpful information more than 'Still don't work...'

Pasting your config sections is great, but you don't actually say what you did ...

1) Make config changes
2) Reloaded services to pick up changes
3) As you defined a password on the operblock in services you will need to /os login yourpassword


Logged

Juan c

  • Anope User
  • Offline Offline
  • Posts: 7
Re: BotServ wont let me ADD bots
« Reply #6 on: October 06, 2014, 10:18:41 PM »

yes I added the changes to the services conf file restarted
and then I logged as op

Code: [Select]
/open Dragnovich <mypass>
You are now an IRC Operator

And re run the:
Code: [Select]
/msg BotServ BOT ADD MyBot MyIrcBot myserver.mx MyServer
[NOTICE BotServ]: Acceso denegado.

Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: BotServ wont let me ADD bots
« Reply #7 on: October 07, 2014, 05:00:45 AM »

please paste the output of /os oper list
Logged

Juan c

  • Anope User
  • Offline Offline
  • Posts: 7
Re: BotServ wont let me ADD bots
« Reply #8 on: October 07, 2014, 07:08:27 PM »

In fact that command marks error:

Code: [Select]
/oper Dragnovich <mypass>
You are now an IRC Operator

Code: [Select]
/os oper list
Unknown command "os"

Im assumming that os is a shortcode for OperServ so I sended...

Code: [Select]
/msg OperServ oper list
[MSG -> OperServ]: oper list
[NOTICE OperServ]: Acceso denegado.

After a little think... I understand the command you send me before... and now it is working ok ...

This is the solution to the problem:

  • The definition for operator "Dragnovich" was missing in the services.conf
  • I was using the command /oper Dragnovich <password> to login
  • AND THEN I need to log in the OperServ -->   /msg OperServ LOGIN <password>
  • And after that I can add the bot

That's all

Ok can you help me with the MySQL problem?? this is the topic ... I created before... and no one answered it :(
https://forum.anope.org/index.php?topic=4195.0
Logged
Pages: [1]   Go Up