Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Anope 2.0.1 / Unreal 3.2.10.4 :: Uplink problem  (Read 4854 times)

0 Members and 1 Guest are viewing this topic.

Mark

  • Anope User
  • Offline Offline
  • Posts: 6
Anope 2.0.1 / Unreal 3.2.10.4 :: Uplink problem
« on: July 30, 2014, 06:13:05 AM »

I'm having a problem getting Anope 2.0.1 to link to Unreal 3.2.10.4 on the same machine. I upgraded from Anope 1.8.8 and attempted to link 2.0.1 to Unreal 3.2.10.1, but it did the same thing it is doing now with 2.0.1 and Unreal 3.2.10.4.
Everytime it attempts to connect I get this:
Unable to connect to uplink #1 (127.0.0.1:7000): Unable to bind to address: The system detected an invalid pointer address in attempting to use a pointer argument in a call.

It's not very helpful to figure out what went wrong and "using your old config as a reference" was a complete waste of time. There are new configuration options that weren't there, such as: userlen, hostlen, and chanlen, which were left as default since nothing in unreal has anything in the configuration talking about the length of those options. Yet, the configuration says "Set this to the maximum allowed object length on your network. Be sure to set this correctly, as setting this wrong can result in Services being disconnected from the network."

Upgrading to Anope 2.0.1 is such a damn nightmare when you check, double, check and then check it a third time and it doesn't work worth crap. So what do you need to look at to fix the uplink bullcrap so I can move on.

I never had any problems with Anope 1.8.8, so having to visit the forum just to get support for upgrading to Anope 2.0.1 is saying something about how complicated it is just to upgrade than it is to start all over and needs better documentation.
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: Anope 2.0.1 / Unreal 3.2.10.4 :: Uplink problem
« Reply #1 on: July 30, 2014, 06:17:38 AM »

Remove the localhost config setting from your serverinfo{} block.
Logged

Mark

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Anope 2.0.1 / Unreal 3.2.10.4 :: Uplink problem
« Reply #2 on: July 30, 2014, 06:42:58 AM »

So localhost in serverinfo{} is when an IRCd like Unreal is on a completely different machine?

Probably would have been better to just say "Only enable this if your IRCd is on a different machine than Anope" in the configuration file.
Logged

Taylor

  • Contributor
  • *
  • Offline Offline
  • Posts: 100
Re: Anope 2.0.1 / Unreal 3.2.10.4 :: Uplink problem
« Reply #3 on: July 30, 2014, 06:51:11 AM »

Directly from example.conf 

Read its comments completely, also notice its commented by default.  Also note if you read what it says, its not just for connecting to other "machines"


   /*
    * The local address that Services will bind to before connecting to the remote
    * server. This may be useful for multihomed hosts. If omitted, Services will let
    * the Operating System choose the local address. This directive is optional.
    *
    * If you don't know what this means or don't need to use it, just leave this
    * directive commented out.

    */
   #localhost = "nowhere."
« Last Edit: July 30, 2014, 06:53:19 AM by Taylor »
Logged
Cronus
irc.cncirc.net
http://CnCIRC.net

Mark

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Anope 2.0.1 / Unreal 3.2.10.4 :: Uplink problem
« Reply #4 on: July 30, 2014, 07:21:14 AM »

Oh sorry for interpreting "multihomed hosts" as multiple computers on the same network.
Logged
Pages: [1]   Go Up