Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: [SOLVED][2.0.1][mysql]Anope database won't fill  (Read 6542 times)

0 Members and 1 Guest are viewing this topic.

tiphergane

  • Anope User
  • Offline Offline
  • Posts: 3
[SOLVED][2.0.1][mysql]Anope database won't fill
« on: July 05, 2014, 08:11:26 PM »

Hello all,

I've try to install anope with mysql support, everything works fine in db_flatfile but I can't send the anope.db into my anope remote database.

Code: [Select]
module
{
        #name = "db_sql"
        name = "db_sql_live"

        /*
         * The SQL service db_sql(_live) should use, these are configured in modules.conf.
         * For MySQL, this should probably be mysql/main.
         */
        engine = "mysql/main"

        /*
         * An optional prefix to prepended to the name of each created table.
         * Do not use the same prefix for other programs.
         */
        prefix = "anope_db_"

        /* Whether or not to import data from another database module in to SQL on startup.
         * If you enable this, be sure that the database services is configured to use is
         * empty and that another database module to import from is loaded before db_sql.
         * After you enable this and do a database import you should disable it for
         * subsequent restarts.
         *
         * Note that you can not import databases using db_sql_live. If you want to import
         * databases and use db_sql_live you should import them using db_sql, then shut down
         * and start services with db_sql_live.
         */
        import = false
}

Code: [Select]
/*
 * m_mysql [EXTRA]
 *
 * This module allows other modules to use MySQL.
 */
module
{
        name = "m_mysql"

        mysql
        {
                /* The name of this service. */
                name = "mysql/main"
                database = "anope"
                server = "localhost"
                username = "root"
                password = "root_password"
                port = 3306
        }
}

and when I'm in phpmyadmin, the anope database still empty. I've try to setup with db_flatfile & db_sql with the import set to true, but nothing came up even if I do /os update. Of course, in ./extras I've enable the mysql.cpp option. So each time that my anope's services restart, I loose all the conf (chan, nick registered, botlist, ...)

If anybody have to solution at this problem, it will be really kind to share.

The -debug output with a grep on sql
Code: [Select]
./services/bin/services -nofork -debug | grep sql
[Jul 05 21:10:48.972805 2014] Debug: ln 829 EOL: s='opertype' 'commands' set to 'chanserv/list chanserv/suspend chanserv/topic memoserv/staff nickserv/list nickserv/suspend operserv/mode operserv/chankill operserv/akill operserv/session operserv/modinfo operserv/sqline operserv/oper operserv/kick operserv/ignore operserv/snline'
[Jul 05 21:10:48.990278 2014] Debug: ln 1126 EOL: s='module' 'name' set to 'db_sql_live'
[Jul 05 21:10:48.991793 2014] Debug: ln 1132 EOL: s='module' 'engine' set to 'mysql/main'
[Jul 05 21:10:48.997989 2014] Debug: ln 1254 EOL: s='include' 'name' set to 'irc2sql.conf'
[Jul 05 21:10:49.554378 2014] Debug: ln 75 EOL: s='module' 'sqlineexpiry' set to '30d'
[Jul 05 21:10:49.557092 2014] Debug: ln 100 EOL: s='module' 'killonsqline' set to 'yes'
[Jul 05 21:10:49.671421 2014] Debug: ln 690 EOL: s='command' 'command' set to 'operserv/sqline'
[Jul 05 21:10:49.672888 2014] Debug: ln 690 EOL: s='command' 'permission' set to 'operserv/sqline'
[Jul 05 21:10:49.702605 2014] Debug: Start to read conf irc2sql.conf
[Jul 05 21:10:49.706711 2014] Debug: ln 53 EOL: s='module' 'name' set to 'irc2sql'
[Jul 05 21:10:49.709140 2014] Debug: ln 65 EOL: s='module' 'engine' set to 'mysql/main'
[Jul 05 21:10:49.710652 2014] Debug: ln 71 EOL: s='module' 'prefix' set to 'anope_irc2_sql'
[Jul 05 21:10:49.898908 2014] Debug: Trying to load module: db_sql_live
[Jul 05 21:10:49.904446 2014] Debug: Module db_sql_live loaded.
[Jul 05 21:10:50.761334 2014] Debug: Trying to load module: irc2sql
[Jul 05 21:10:50.768843 2014] Debug: IRC2SQL: no database connection to mysql/main
[Jul 05 21:10:50.783554 2014] Debug: Module irc2sql loaded.

regards,

tiphergane
« Last Edit: July 05, 2014, 08:24:14 PM by tiphergane »
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: [2.0.1][mysql]Anope database won't fill
« Reply #1 on: July 05, 2014, 08:12:50 PM »

You should see m_mysql loading in that log output if you grepped for sql.
Logged

tiphergane

  • Anope User
  • Offline Offline
  • Posts: 3
Re: [2.0.1][mysql]Anope database won't fill
« Reply #2 on: July 05, 2014, 08:15:31 PM »

You should see m_mysql loading in that log output if you grepped for sql.

Ok, seem to be a begin, when I do the grop on m_mysql, nothing came up. I must go take a look at the m_mysql load in the conf

The modules.conf have the m_mysql uncommented, and the m_mysql.so is in the folder:
Code: [Select]
pi@raspberrypi ~/services/lib/modules $ ls | grep m_mysql
m_mysql.so
« Last Edit: July 05, 2014, 08:18:23 PM by tiphergane »
Logged

tiphergane

  • Anope User
  • Offline Offline
  • Posts: 3
Re: [2.0.1][mysql]Anope database won't fill
« Reply #3 on: July 05, 2014, 08:22:42 PM »

SOLVED

My bad, I just do a misconfig. Thx a lot for the m_mysql spotlight !! I was loading the modules.example.conf instead of modules.conf

You can set it to solved guy !
Logged
Pages: [1]   Go Up