Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: V2.0.1 start errors  (Read 3909 times)

0 Members and 1 Guest are viewing this topic.

John

  • Anope User
  • Offline Offline
  • Posts: 4
V2.0.1 start errors
« on: June 23, 2014, 07:47:53 AM »

I've recently built a new IRC server which I want to run Unreal 3.2.10.3 and Anope 2.0.1 on. All software is installed without problems and IRCd is running however Anope will not start and the following dialogue appears:-



Nothing I've read in the install instructions seems to relate to how this can be cured. I've also done a few Net searches with the only suggestion being to install the DLL which the error refers to however this DLL is already in place.

Any ideas on a cure?

OS: Windows 2008 Enterprise Server 32bit (SP2).

I should add that I have read the thread two below this one that contains a similar error and screenshot but it seems unrelated to the error I am experiencing.
« Last Edit: June 23, 2014, 07:56:09 AM by John »
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: V2.0.1 start errors
« Reply #1 on: June 23, 2014, 10:44:37 AM »

You have the VS 2010 runtimes correct? http://www.microsoft.com/en-us/download/details.aspx?id=5555

Also are you trying to use m_mysql?
Logged

John

  • Anope User
  • Offline Offline
  • Posts: 4
Re: V2.0.1 start errors
« Reply #2 on: June 23, 2014, 01:02:01 PM »

Yes, vcredist_x86.exe is installed as Unreal requires it too.

Also are you trying to use m_mysql?

No. We've always used the text files for the databases.
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: V2.0.1 start errors
« Reply #3 on: June 23, 2014, 01:06:06 PM »

There's more than one version of vcredist_x86.exe, you specifically need the 2010 one that I linked.
Logged

John

  • Anope User
  • Offline Offline
  • Posts: 4
Re: V2.0.1 start errors
« Reply #4 on: June 23, 2014, 01:37:59 PM »

Okay, headway is being made.

The version I had was a later one and filesize was about 1/3 larger. No errors now, so I can finish off services.conf.

Thanks Adam, much appreciated.
Logged

John

  • Anope User
  • Offline Offline
  • Posts: 4
Re: V2.0.1 start errors
« Reply #5 on: June 23, 2014, 01:52:56 PM »

Okay, more good news. Services is now working perfectly.

Adam, thankyou for your help.
Logged
Pages: [1]   Go Up