Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Database migration  (Read 3566 times)

0 Members and 1 Guest are viewing this topic.

Kaj

  • Anope User
  • Offline Offline
  • Posts: 9
Database migration
« on: April 16, 2014, 06:19:40 PM »

Hello,


I am running Anope version 1.8 and I want to migrate to 2.0.

Currently, my database is not encrypted. So i tried to follow the following steps:


1. Put de .db files from my old anope database in the data/ folder of the anope2.0 services directory
2. Enabled db_old (with hash set on 'plain') and db_flatfile
3. Enabled enc_none and enc_sha1.
4. Start the server

5.After this, I disable the db_old and the enc_none parameters.

But if I want to log in now, it says the password is incorrect, except if I logged in on this account between steps 4 and 5. So it looks like it only encrypts the passwords of accounts being used during that period (4->5). How can I make it encrypt all the passwords at once?


Grtz,

Kaj

Logged

Andromeda

  • Anope User
  • Offline Offline
  • Posts: 17
Re: Database migration
« Reply #1 on: April 16, 2014, 06:23:49 PM »

If I'm mistaken the migration cannot convert the encryption on passwords and such, so if you used plain previously, I believe you're stuck with it... I'm not 100% on this though, but it's what I figured when I tried to do the same from sha1 to sha256... perhaps there is an encryption tool as well? I never actually checked.
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: Database migration
« Reply #2 on: April 16, 2014, 08:41:40 PM »

Do not disable enc_none. Read the comments in example.conf near the encryption modules for an explanation of how they work.
Logged

Kaj

  • Anope User
  • Offline Offline
  • Posts: 9
Re: Database migration
« Reply #3 on: April 17, 2014, 01:54:41 AM »

Okay thanks, got it working now (leaving both enc_none and enc_sha1 enabled).

Thanks
Logged

Seroczynski

  • Anope User
  • Offline Offline
  • Posts: 1
Re: Database migration
« Reply #4 on: April 17, 2014, 11:28:24 AM »

I can't get it to work. I am trying to do the same, upgrade from 1.8.x to 2.0 but for some reason my .db files aren't being read. I placed them in the same directory as OP, but think I got them setup wrong in the configuration file. What would be the correct way of including them?

Edit: Nevermind, it was really stupid. I should have looked at my config file better.
« Last Edit: May 16, 2014, 11:34:35 AM by Seroczynski »
Logged
Pages: [1]   Go Up