Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: [RESOLVED] fantasy commands !help, !cmdlist  (Read 8143 times)

0 Members and 1 Guest are viewing this topic.

quentin

  • Anope User
  • Offline Offline
  • Posts: 8
[RESOLVED] fantasy commands !help, !cmdlist
« on: February 21, 2014, 10:05:12 AM »

Hi all,

UPDATE: Ok with your advices I now have !op and !voice working commands. But I have no response for all other commands and no help available. Do you know how debug this ?

I am new on anope.  I use UnreIrcd 3.2 as ircd server.

I installed  anope 1.8.8 with eggdrop to get oper status on channel when I need.
No problem, thanks for the very good services server.

One of my user is a old irc user and h usually used "!op" alias to get oper status.
To get oper status with eggdrop I send command "/msg eggdrop OP 'pass' '#channel'"
I see on wiki anope allow it with BotServ configuration.
So I send "/msg BotServ SET #channel FANTASY ON" to enable !commands
But, whe I send "!op" command, no result and I think I must alias !op to my eggdrop command bu I don't know how do this.

Do you know how do it ?

Thanks for your help.

Best regards.
« Last Edit: March 12, 2014, 11:57:34 AM by quentin »
Logged

CrazyCat

  • Anope User
  • Offline Offline
  • Posts: 155
    • French Eggdrop community
Re: create "!op" command
« Reply #1 on: February 21, 2014, 11:50:01 AM »

You make a confusion between eggdrop and botserv.
The fantasy mode is for botserv, so you need a chanserv access to the channel (/msg ChanServ AOP|SOP add <you>) and a botserv' bot on your channel (/msg BotServ assign <channel> <name of bot>), and so the fantasy mode will work without eggdrop.

If you want a fantasy-like command in eggdrop, you shall have a look on egghelp and particularly in the tcl scripts.
Logged
I'm currently

quentin

  • Anope User
  • Offline Offline
  • Posts: 8
Re: create "!op" command
« Reply #2 on: February 27, 2014, 08:24:31 PM »

Hmm ok, I'm confuse.
In fact, I use eggdrop only to allow some of my users to get oper status.
If it is possible with botserv without eggdrop I think it is better.
I read the doc about botserv and I understand that it is a service which allow users to add bot on a channel.
But I don't understand how add a bot, and what bot if it is not eggdrop, which op me when I run "!op" command.
Could you redirect me on procedure to do this please ?
Thanks you very much for your answer.
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: create "!op" command
« Reply #3 on: February 28, 2014, 03:43:22 PM »

https://modules.anope.org/index.php?page=view&id=42


Read the supplied documentation that comes with every single copy of Anope on how to compile/install modules.
Logged

quentin

  • Anope User
  • Offline Offline
  • Posts: 8
Re: create "!op" command
« Reply #4 on: March 06, 2014, 10:52:47 PM »

Hi,
Thanks for you answer.
I download fantasy_ext and extract in modules folder.
I recompiled anope and run it.
Then, I send on irc "/msg botserv set #test fantasy on"
No error, but when I send "!HELP" or "!CMDLIST" no answer and no log.
Have you an idea ?
Thanks
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: create "!op" command
« Reply #5 on: March 07, 2014, 12:48:21 AM »

Is there a botserv bot in the channel?
Logged

quentin

  • Anope User
  • Offline Offline
  • Posts: 8
Re: create "!op" command
« Reply #6 on: March 08, 2014, 02:26:00 AM »

I created a botserv "bot"  whith msg "BOT ADD pseudo user host real"
Then I assigned on channel, enabled fantasy and but no answer to cmd "!help".
But I have not a real bot started on my host. Do I have it ?
Thanks
Logged

quentin

  • Anope User
  • Offline Offline
  • Posts: 8
Re: create "!op" command
« Reply #7 on: March 10, 2014, 03:53:41 PM »

In fact, it seems work.
The "!cmdlist" and "!help" command does not work but "!op" and "!kick" and "!voice" work.
My last problem is that it works only if I already have an oper status.
But the object of this feature is to get oper status when I have not.
Do you know what is condition to use "!op" command or how change configuration ?
Thanks
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
Re: create "!op" command
« Reply #8 on: March 10, 2014, 03:57:10 PM »

!cmdlist and !help are commands provided by the module bs_fantasy_ext, they are not part of the anope core.. you 'll have to install that module if you want more fantasy commands then those provided by the core.
And if you are on the channel's access list and identified to your nick, your should get access to the command, regardless of you mode in the channel.. you must have identified with nickserv though..
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

quentin

  • Anope User
  • Offline Offline
  • Posts: 8
Re: create "!op" command
« Reply #9 on: March 10, 2014, 05:08:16 PM »

Thanks Jan for your answer.
I am identified by nickserv.
It is exact the mode is not right.
Do you know how set mode for a specific user ? I tested :
/msg Chanserv access #test add mylogin 5
But, I get answer : You can't use this command. Use the AOP, SOP, HOP and VOP commands instead.
Also, I installed fantasy_ext. I have the "bs_fantasy_ext.so" in modules folder. Do you know how check if it is really started ?
Thanks for your help
Logged

quentin

  • Anope User
  • Offline Offline
  • Posts: 8
Re: create "!op" command
« Reply #10 on: March 11, 2014, 10:52:48 AM »

Ok. I added my "opable" user to SOP group.
Now, "!op", "!deop", "!voice" and "!devoice" commands work for SOP users and no for other. Perfect.
But I can't list commands with "!help" or "!cmdlist" and most commands give no response.
I have bs_fantasy_ext.so in my module folder but I don't know if it is really enabled.
Someone have the same problem ?
Best regards
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: create "!op" command
« Reply #11 on: March 11, 2014, 12:39:13 PM »

Ok. I added my "opable" user to SOP group.
Now, "!op", "!deop", "!voice" and "!devoice" commands work for SOP users and no for other. Perfect.
But I can't list commands with "!help" or "!cmdlist" and most commands give no response.
I have bs_fantasy_ext.so in my module folder but I don't know if it is really enabled.
Someone have the same problem ?
Best regards

You need to load the module using the directions I've already given you. Once you do that you can verify that the module is loaded by typing: /os modinfo bs_fantasy_ext
Logged

quentin

  • Anope User
  • Offline Offline
  • Posts: 8
Re: fantasy commands !help, !cmdlist
« Reply #12 on: March 12, 2014, 11:57:07 AM »

Ok. I added "bs_fantasy_ext" to "BotCoreModules" option in my services.conf and restart it.
Now "/os modinfo bs_fantasy_ext" works and "!help", "!cmdlist" also.
Thanks you very much for your help. All is ok now :)
Logged
Pages: [1]   Go Up