Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Botserv crashes services when assigned to a chan  (Read 4806 times)

0 Members and 1 Guest are viewing this topic.

Ian

  • Anope User
  • Offline Offline
  • Posts: 9
Botserv crashes services when assigned to a chan
« on: February 07, 2014, 03:50:22 PM »

Every time I assign a botserv bot to a channel the entire services dies with
Code: [Select]
  irc.mynet.org:BS-IRCNet : *** Notice -- Max SendQ limit exceeded for services.mynet.org[127.0.0.1]: 1000008 > 1000000
  irc.mynet.org:BS-IRCNet : *** Global -- Closing link: Max SendQ exceeded - services.mynet.org[127.0.0.1]

When creating the bot it shows
Code: [Select]
*** Permanent Global Q:line added for BS on Fri Feb  7 14:18:33 2014 GMT (from services.mynet.org: Reserved for services)
-BotServ- BS!BS@services.mynet.org (MyNet) added to the bot list.

Upon assigning the bot :-
Code: [Select]
—— JOIN #test « BS (BS@services.mynet.org)
 —— QUIT « BS (BS@services.mynet.org) » irc.mynet.org services.mynet.org ——
  irc.mynet.org:BS-IRCNet : *** Notice -- Max SendQ limit exceeded for services.mynet.org[127.0.0.1]: 1000008 > 1000000
  irc.mynet.org:BS-IRCNet : *** Global -- Closing link: Max SendQ exceeded - services.mynet.org[127.0.0.1]

Ulines :-
Code: [Select]
ulines {
services.mynet.org:*:*;
};

Server Name :-
Code: [Select]
ServerName  "services.mynet.org"
Have to add a global uline for *, rahash the ircd, restart services and unassign bot before the links closed.

Can anyone help me on this please?

[EDIT for requested info]

Code: [Select]
class           servers
{
pingfreq 90;
maxclients 10; /* Max servers we can have linked at a time */
sendq 1000000;
connfreq 100; /* How many seconds between each connection attempt */
};

class           clients
{
pingfreq 90;
maxclients 90;
sendq 100000;
recvq 8000;
};

Code: [Select]
link            services.mynet.org
{
username *;
hostname 127.0.0.1;
bind-ip *;
port 7555;
hub             *;
password-connect "mypass";
password-receive "mypass";
class           servers;
options {
/* Note: You should not use autoconnect when linking services */
# autoconnect;
# ssl;
# zip;
};
};
« Last Edit: February 07, 2014, 05:55:58 PM by Ian »
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 462
Re: Botserv crashes services when assigned to a chan
« Reply #1 on: February 07, 2014, 03:52:41 PM »

Use just:

Code: [Select]
ulines {
services.mynet.org;
};

For starters. Also pastebin your class{} and link{} blocks if it persists.
Logged

Ian

  • Anope User
  • Offline Offline
  • Posts: 9
Re: Botserv crashes services when assigned to a chan
« Reply #2 on: February 07, 2014, 05:50:13 PM »

Thanks for the reply, made the change you said and created a bot :-
Code: [Select]
-irc.mynet.org- *** Permanent Global Q:line added for TZ on Fri Feb  7 17:43:14 2014 GMT (from services.mynet.org: Reserved for services)
-
 -BotServ- TZ!TZ@services.mynet.org (Botserv Bot) added to the bot list.
-
-BotServ- Bot TZ has been assigned to #test
 -irc.mynet.org- *** Notice -- Max SendQ limit exceeded for services.mynet.org[127.0.0.1]: 1000032 > 1000000
-
-irc.mynet.org- *** Global -- Closing link: Max SendQ exceeded - services.mynet.org[127.0.0.1]

—— JOIN #test « TZ (TZ@services.mynet.org) »  ——
—— QUIT « TZ (TZ@services.mynet.org) » irc.mynet.org services.mynet.org ——

and services dies again.

If I add a global Uline (which i have to do to restart services and remove the bot)
Code: [Select]
—— JOIN #test « TZ (TZ@services.mynet.org) »  ——
* TZ sets mode: +ao TZ TZ

« Last Edit: February 07, 2014, 05:54:26 PM by Ian »
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Botserv crashes services when assigned to a chan
« Reply #3 on: February 07, 2014, 08:15:53 PM »

1. There is no such thing as a "global U:Line". U:Lines are local to the ircd only, thus every ircd *must* have an exact matching ulines block BEFORE services is started. Don't forget to /rehash your ircd(s) after making changes.
2. If you are still seeing max sendQ exceeded, then the ircd doesn't have the correct ulines block. double check them all on all ircds and /rehash if any changes are made and (re)start services.
3. Services must be introduced as an U:Lined server so ANY changes requires services to be introduced to said ircd.
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 462
Re: Botserv crashes services when assigned to a chan
« Reply #4 on: February 07, 2014, 08:18:34 PM »

Use just:

Code: [Select]
ulines {
services.mynet.org;
};

For starters. Also pastebin your class{} and link{} blocks if it persists.

As I said, pastebin the class blocks, as Unreal applies their sendq limits even to ulines.
Logged

Ian

  • Anope User
  • Offline Offline
  • Posts: 9
Re: Botserv crashes services when assigned to a chan
« Reply #5 on: February 07, 2014, 08:56:18 PM »

My apologies for being inexact katsklaw, i meant a uline of
Code: [Select]
uline { *; };

to enable me to remove the bot and then reset the uline.

There are only the unreal server and services, no other servers. The ircd is rehashed after changes.

Also I've no idea what you mean by "introduced".

@Adam:
The blocks are in the original post.
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Botserv crashes services when assigned to a chan
« Reply #6 on: February 07, 2014, 11:02:41 PM »

ulines blocks are explicit, Adam didn't tell you to use * as the server name.

Use this, exactly this and ONLY this:
Code: [Select]
ulines {
services.mynet.org;
};
Logged

Ian

  • Anope User
  • Offline Offline
  • Posts: 9
Re: Botserv crashes services when assigned to a chan
« Reply #7 on: February 07, 2014, 11:10:32 PM »

ulines blocks are explicit, Adam didn't tell you to use * as the server name.

Use this, exactly this and ONLY this:
Code: [Select]
ulines {
services.mynet.org;
};

Please read what I have said. That uline was required to enable services to connect and for me to remove the bot otherwise services died on connect and the bot could not be removed.

I also said that after this i reset the uline.
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Botserv crashes services when assigned to a chan
« Reply #8 on: February 07, 2014, 11:14:22 PM »

you don't need any other ulines block than services.mynet.org. Once this block is properly set you can do what you need to do. using * as the host in the ulines block is not needed, required or even recommended.


Have a great day. :)
Logged

Ian

  • Anope User
  • Offline Offline
  • Posts: 9
Re: Botserv crashes services when assigned to a chan
« Reply #9 on: February 07, 2014, 11:21:00 PM »

I am aware of that fact lol, however the situation remains that with a uline of "services.mynet.org" services die when a services bot enters a channel.

Also until the bot is removed services continues to crash whenever they are restarted, hence having to use a uline of "*" to enable me to remove the bot. I have already stated several times that I then reset the Uline to services.mynet.org as services no longer crash once the bot is removed from the channel.

[EDIT]
I have used the same Unreal and Anope confs on my Windows PC and there's no issue, the bot joins the channel and services doesn't die.

On my PC I have Unreal3.2.10.2 and Anope 1.8.8
On the actual ircd I have Unreal3.2.8.1 and Anope 1.8.5

[Further Edit]
ohh boy

Installed anope-1.8.8 and services linked fine except
Code: [Select]
OperServ- Unknown command SHUTDOWN.  "/msg OperServ HELP" for help.
OperServ- Unknown command help.  "/msg OperServ HELP" for help.

Gone back to the old version for now :(
« Last Edit: February 09, 2014, 01:06:21 AM by Ian »
Logged
Pages: [1]   Go Up