Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: NickServ not functioning properly.  (Read 6740 times)

0 Members and 1 Guest are viewing this topic.

Mr. Vengeance

  • Anope User
  • Offline Offline
  • Posts: 5
NickServ not functioning properly.
« on: February 04, 2014, 04:15:35 PM »

Hey guys! New to all this stuff and have got Unreal 3.2.10.2 up and running and connected to Anope. The issue seems (which for some reason I had it working yesterday until a reboot of the Ubuntu VPS I had set it on) that I cannot get NickServ to force registration of the nick. Which allows me to use everyone's nick whenever I see fit. I want it so you cannot join rooms and such without registering a nick on the network. I have altered the NSDefKillQuick and such:


#NSDefNone

#NSDefKill
NSDefKillQuick
NSDefSecure
NSDefPrivate
NSDefHideEmail
NSDefHideUsermask
#NSDefHideQuit
#NSDefMsg
NSDefMemoSignon
NSDefMemoReceive
NSDefAutoop

Here's pieces of the services.conf:

UlineServers "service.127.0.0.1"
NetworkName "XionIRC"
ServiceUser "services@localhost.net"
ServerDesc  "Services for IRC Networks"
ServerName  "services.127.0.0.1"
RemoteServer    127.0.0.1 1337 "xxx"


Here is my unrealircd.conf:

loadmodule "src/modules/commands.so";
loadmodule "src/modules/cloak.so";

include "help.conf";
include "badwords.channel.conf";
include "badwords.message.conf";
include "badwords.quit.conf";
include "spamfilter.conf";


me
{
   name "Xion.IRC";
   info "XionIRC";
   numeric 1;
};


admin {
        "VengeancE";
};


class           clients
{
   pingfreq 90;
   maxclients 500;
   sendq 100000;
   recvq 8000;
};

class           servers
{
   pingfreq 90;
   maxclients 64000;      /* Max servers we can have linked at a time */
   sendq 1000000;
   connfreq 10; /* How many seconds between each connection attempt */
};

allow {
   ip             *@*;
   hostname       *@*;
   class           clients;
   maxperip 5;
};

oper GOD {
   class           clients;
   from {
      userhost *@*;
   };
   password "xxx";
   flags
   {
      netadmin;
      can_zline;
      can_gzline;
      can_gkline;
      global;
   };
};

listen         *:1337;

drpass {
   restart "restartnow";
   die "dienow";
};

log "ircd.log" {
   /* Delete the log file and start a new one when it reaches 2MB, leave this out

to always use the
      same log */
   maxsize 2097152;
   flags {
      oper;
      connects;
      server-connects;
      kills;
      errors;
      sadmin-commands;
      chg-commands;
      oper-override;
      spamfilter;
   };
};

alias "services" {
   format "^#" {
      target "chanserv";
      type services;
      parameters "%1-";
   };
   format "^[^#]" {
      target "nickserv";
      type services;
      parameters "%1-";
   };
   type command;
};

alias "identify" {
   format "^#" {
      target "chanserv";
      type services;
      parameters "IDENTIFY %1-";
   };
   format "^[^#]" {
      target "nickserv";
      type services;
      parameters "IDENTIFY %1-";
   };
   type command;
};


/* Network configuration */
set {
   network-name       "XionIRC";
   default-server       "none.none";
   services-server    "none.none";
   stats-server       "none.none";
   help-channel       "none.none";
   hiddenhost-prefix   "xion";
   cloak-keys {
        "BoAr4xnR6pl3stttVz4Zb7x4Y32f";
        "G23e1Hntttl32J7hV55ab7x4YwpW";
        "ToAr1HnRxgl3Z57hVtttb7x4Ywqa";
   };
   /* on-oper host */
   hosts {
      local      "none";
      global      "none";
      coadmin      "none";
      admin      "none";
      servicesadmin    "none";
      netadmin    "none";
      host-on-oper-up "no";
   };
};

/* Server specific configuration */

set {
   kline-address "xxx@blah.org";
   modes-on-connect "+xw";
   modes-on-oper    "+xwgs";
   oper-auto-join "#opers";
   options {
      
      identd-check;
      show-connect-info;
   };

   maxchannelsperuser 3;
   throttle {
      connections 3;
      period 60s;
   };

   /* Anti flood protection */
   anti-flood {
      nick-flood 3:60;   /* 3 nickchanges per 60 seconds (the default)

*/
   };

   /* Spam filter */
   spamfilter {
      ban-time 1d; /* default duration of a *line ban set by spamfilter */
      ban-reason "Spam/Advertising"; /* default reason */
      virus-help-channel "#help"; /* channel to use for 'viruschan' action */
      /* except "#help"; channel to exempt from filtering */
   };
};

ulines {
   services.127.0.0.1;
};


 link services.127.0.0.1
{
 username *;
 hostname 127.0.0.1;
 port 1337;
 password-connect "xxx";
 password-receive "xxx";
 class servers;
};


I am still kinda new to all this and have tried to trouble shoot the issue and read through countless posts with no answer/fix in reach. All help is greatly appreciated.  I am currently running Ubuntu x64, Anope 1.8.8 & Unreal 3.2.10.2.
« Last Edit: February 04, 2014, 04:19:03 PM by Mr. Vengeance »
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 462
Re: NickServ not functioning properly.
« Reply #1 on: February 04, 2014, 04:18:06 PM »

I want it so you cannot join rooms and such without registering a nick on the network.

Use channel mode +R? Also note NSDefKillQuick only affects newly created accounts.
Logged

Mr. Vengeance

  • Anope User
  • Offline Offline
  • Posts: 5
Re: NickServ not functioning properly.
« Reply #2 on: February 04, 2014, 04:23:04 PM »

Use channel mode +R? Also note NSDefKillQuick only affects newly created accounts.

Thanks for the response. So set the channel mode as follows?

   modes-on-connect "+xw";  <---Add R to this list?
   modes-on-oper    "+xwgs";
   oper-auto-join "#opers";

Yes I know it does it for NEW accounts. I had set it before I fired up Unreal and ./services and switched nicks multiple times and tried to switch to newly registered nick's and it will give me the warning that I need to identify and such and tells me that the nick is registered and to change it. Problem is it dont force me to change it at all. Just the warning. So i can use whoever's nick without any restriction.
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 462
Re: NickServ not functioning properly.
« Reply #3 on: February 04, 2014, 04:28:46 PM »

No, +R is a channel mode, that setting is for user modes. I'm not sure offhand if its possible to set all channels +R by default on Unreal.

You also need to configure unrealircd.conf correctly by adding a uline{} block for services.
Logged

Mr. Vengeance

  • Anope User
  • Offline Offline
  • Posts: 5
Re: NickServ not functioning properly.
« Reply #4 on: February 04, 2014, 04:32:27 PM »

Care to elaborate on how I go amongst doing this?
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 462
Re: NickServ not functioning properly.
« Reply #5 on: February 04, 2014, 04:38:00 PM »

/mode #channel +R
Logged

lovenix

  • Anope User
  • Offline Offline
  • Posts: 2
Re: NickServ not functioning properly.
« Reply #6 on: February 04, 2014, 04:40:08 PM »

Care to elaborate on how I go amongst doing this?

you can do set::restrict-chanmodes R on UnrealIRCD so every new channel will be +R
for more detailed infos you should check this:
http://www.unrealircd.com/files/docs/unreal32docs.html#setblock
Logged

Mr. Vengeance

  • Anope User
  • Offline Offline
  • Posts: 5
Re: NickServ not functioning properly.
« Reply #7 on: February 04, 2014, 06:48:36 PM »

No, +R is a channel mode, that setting is for user modes. I'm not sure offhand if its possible to set all channels +R by default on Unreal.

You also need to configure unrealircd.conf correctly by adding a uline{} block for services.

I was refering to your last statement. Creating a uline block for services.
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 462
Re: NickServ not functioning properly.
« Reply #8 on: February 04, 2014, 06:49:34 PM »

You already have one, except its for the wrong server ('services' vs 'service')
Logged

Mr. Vengeance

  • Anope User
  • Offline Offline
  • Posts: 5
Re: NickServ not functioning properly.
« Reply #9 on: February 04, 2014, 07:05:21 PM »

You already have one, except its for the wrong server ('services' vs 'service')

Can you elaborate on that for me? Whats the difference between the two? Thanks for all the assistance as well.
« Last Edit: February 04, 2014, 07:13:47 PM by Mr. Vengeance »
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 462
Re: NickServ not functioning properly.
« Reply #10 on: February 04, 2014, 09:06:59 PM »

Your uline is for services.127.0.0.1 and  your services server name is service.127.0.0.1. They are not the same.
Logged
Pages: [1]   Go Up