Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Anope XMLRPC HTTP 1.1 404 Not Found  (Read 3622 times)

0 Members and 1 Guest are viewing this topic.

deiks

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 139
  • Shizle my nizle
Anope XMLRPC HTTP 1.1 404 Not Found
« on: December 26, 2013, 04:43:26 PM »

Hi,

I'm using Anope 1.9.9

# modules.conf

Quote
module { name = "help" }

module
{
        name = "m_httpd"

        httpd
        {
                name = "httpd/main"
                ip = "SHELL-IP"
                port = 7880
                timeout = 30
                #ssl = yes
        }
}

module
{
        name = "m_xmlrpc"
        server = "httpd/main"
}

module { name = "m_xmlrpc_main" }

module {
   name = "m_helpchan"
   helpchannel = "#help" }
   
module {
   name = "m_mysql"
   mysql
   {
            # MYSQL DATA
   }
}

module { name = "m_regex_pcre" }
module { name = "m_regex_posix" }
#module { name = "m_regex_tre" }

#module { name = "m_ssl" cert = "data/anope.crt"   key = "data/anope.key" }

I'm using this .php example: https://github.com/anope/anope/blob/1.9/docs/XMLRPC/xmlrpc.php

With $anopexmlrpc = new AnopeXMLRPC("http://SHELL-IP:7880/xmlrpc"); // Tried with and without /xmlrpc

Scanning open port on 7880 results open port. If I go through xmlrpc.php file I'm getting error file_get_contents 404 Not Found (like in topic title).

If I go directly in http://SHELL-IP:7880 there's message "Page not found"

Here's list of modules:

Quote
[17:38:08] -OperServ- Current module list:
[17:38:08] -OperServ- Module: inspircd20 [1.9.9] [Protocol, Vendor]
[17:38:08] -OperServ- Module: db_sql_live [1.9.9] [Database, Vendor]
[17:38:08] -OperServ- Module: enc_md5 [1.9.9] [Encryption, Vendor]
[17:38:08] -OperServ- Module: m_httpd [1.9.9] [Vendor, Extra]
[17:38:08] -OperServ- Module: m_xmlrpc [1.9.9] [Vendor, Extra]
[17:38:08] -OperServ- Module: m_xmlrpc_main [1.9.9] [Vendor, Extra]
[17:38:08] -OperServ- Module: m_mysql [1.9.9] [Vendor, Extra]
[17:38:08] -OperServ- Module: m_regex_pcre [1.9.9] [Vendor, Extra]
[17:38:08] -OperServ- Module: m_regex_posix [1.9.9] [Vendor, Extra]
[17:38:08] -OperServ- 9 modules loaded.

./services -debug=2 -nofork produces this:

Quote
[Dec 26 08:40:04.132900 2013] Debug: Accepted connection 14 from WEB-IP
[Dec 26 08:40:04.133112 2013] Debug: Top of main loop
[Dec 26 08:40:04.133196 2013] Debug: HTTP from WEB-IP: POST / HTTP/1.0
[Dec 26 08:40:04.133265 2013] Debug: Top of main loop
[Dec 26 08:40:04.208018 2013] Debug: HTTP from WEB-IP: Host: SHELL-IP:7880
[Dec 26 08:40:04.208083 2013] Debug: HTTP from WEB-IP: Content-Length: 336
[Dec 26 08:40:04.208157 2013] Debug: HTTP from WEB-IP: Content-Type: text/html
[Dec 26 08:40:04.208209 2013] Debug: HTTP POST from WEB-IP: <?xml version: "1.0" encoding="iso-8859-1"?>
<methodCall>
<methodName>command</methodName>
<params>
 <param>
  <value>
   <string>nickserv</string>
  </value>
 </param>
 <param>
  <value>
   <string>nickname</string>
  </value>
 </param>
 <param>
  <value>
   <string>identify passwd</string>
  </value>
 </param>
</params>
</methodCall>

[Dec 26 08:40:04.208422 2013] Debug: Top of main loop
[Dec 26 08:40:04.208505 2013] Debug: Top of main loop
[Dec 26 08:40:04.208558 2013] Debug: Top of main loop
[Dec 26 08:40:04.208615 2013] Debug: Top of main loop
[Dec 26 08:40:04.208662 2013] Debug: Top of main loop
[Dec 26 08:40:04.208709 2013] Debug: Top of main loop
[Dec 26 08:40:04.208759 2013] Debug: Top of main loop
[Dec 26 08:40:04.208837 2013] Debug: Top of main loop
[Dec 26 08:40:04.208895 2013] Debug: Top of main loop
[Dec 26 08:40:04.358578 2013] Debug: Closing connection 14 from WEB-IP

If you need anything else, feel free to ask :)

Best regards.
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: Anope XMLRPC HTTP 1.1 404 Not Found
« Reply #1 on: December 26, 2013, 04:46:13 PM »

I recall this being one of the things fixed in Anope 2.0.0-rc. You should upgrade to it.
Logged

deiks

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 139
  • Shizle my nizle
Re: Anope XMLRPC HTTP 1.1 404 Not Found
« Reply #2 on: December 26, 2013, 05:02:19 PM »

Will upgrade change anything in Anope, like modules, configs, databases etc. since it's branch change?
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: Anope XMLRPC HTTP 1.1 404 Not Found
« Reply #3 on: December 26, 2013, 05:03:10 PM »

No, it isn't really a branch change, 1.9 is just the development name for 2.0.
Logged
Pages: [1]   Go Up