Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Anope + Unreal 3.2 password protected ?  (Read 9991 times)

0 Members and 1 Guest are viewing this topic.

Uli

  • Anope User
  • Offline Offline
  • Posts: 7
Anope + Unreal 3.2 password protected ?
« on: November 19, 2013, 10:35:39 PM »

Please would someone take away a doubt I have.. but first here's my conf :

Code: [Select]
IRCD :
link services.xxxxx.xxx {
username services@xxxxx.xxx;
hostname 127.0.0.1;
bind-ip 127.0.0.1;
port 6669;
password-connect "xxxxx";
password-receive         "xxxxx";
class servers;
};

ulines {
services.xxxxx.xxx;
};
Code: [Select]
ANOPE:
define
{
name = "services.host"
value = "services.xxxxx.xxx"
}

uplink
{
host = "127.0.0.1"
ipv6 = no
ssl = no
port = 6669
password = "xxxxxx"
}

Now I always get the MISSING PASSWORD error.
Now for my doubt : My IRCD server is password protected, so the question is, is it due to that ? Is it messed up between my server's password and the link's password ??

Cheers
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: Anope + Unreal 3.2 password protected ?
« Reply #1 on: November 19, 2013, 10:38:41 PM »

serverinfo:name is what should be set to 'services.xxxxx.xxx', not necessarially the define{}.
Logged

Uli

  • Anope User
  • Offline Offline
  • Posts: 7
Re: Anope + Unreal 3.2 password protected ?
« Reply #2 on: November 19, 2013, 10:52:52 PM »

I based this from example.cnf in 1.9.9.
It is also defined  :
Code: [Select]
serverinfo{
name = "services.xxxxx.xxx"
...
}
« Last Edit: November 19, 2013, 10:55:24 PM by Uli »
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: Anope + Unreal 3.2 password protected ?
« Reply #3 on: November 19, 2013, 11:11:50 PM »

set username to * in the link block, too. If that doesn't fix it pastebin your ircd and services config.
Logged

Uli

  • Anope User
  • Offline Offline
  • Posts: 7
Re: Anope + Unreal 3.2 password protected ?
« Reply #4 on: November 20, 2013, 02:30:31 AM »

Didn't fix it :(
Logged

Romeo

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 31
Re: Anope + Unreal 3.2 password protected ?
« Reply #5 on: November 20, 2013, 03:28:55 AM »

Code: [Select]
link            services.testnet.us {
username *;
hostname 192.55.17.1;
bind-ip *;
port 6669;
hub             *;
password-connect "bigmama";
password-receive "bigmama";
class           servers;
};

This is exactly what i have in Unreal's IRCD, and it works, And  or course i have my "bigmama" as my password in the anope's conf
I would have said you haven't defined listening ports, but you said they are communicating, So i know that's defined. Only thing is check your spelling and make sure you didn't add unnecessary characters or space in your password.
Logged
running Unreal 3.2.10.1, Anope 1.9.9 on Ubuntu Server

Uli

  • Anope User
  • Offline Offline
  • Posts: 7
Re: Anope + Unreal 3.2 password protected ?
« Reply #6 on: November 20, 2013, 09:47:27 PM »

Yup my ircd ports are defined
Code: [Select]
listen         *:7000
{
options
{
ssl;
clientsonly;
};
};

listen         *:6667-6669;
Logged

Romeo

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 31
Re: Anope + Unreal 3.2 password protected ?
« Reply #7 on: November 20, 2013, 10:37:29 PM »

Code: [Select]
listen  195.75.30.2:6669 {
options {
serversonly;
};
};

 I dont know what you have under there, but try making yours look like mine.  Yes, with the actual IP in there too.  And make sure its serversonly.. I remember having this same issue, but that was years ago, cant remember what i did to fix it.  So my first guess would be to eliminate all holes. And make it 1 port for the communication from IRCD to ANope.  This way we know what we are working with, And dont forget to rehash :-)
Logged
running Unreal 3.2.10.1, Anope 1.9.9 on Ubuntu Server

Uli

  • Anope User
  • Offline Offline
  • Posts: 7
Re: Anope + Unreal 3.2 password protected ?
« Reply #8 on: November 21, 2013, 02:52:15 AM »

added the following instead :

Code: [Select]
listen         *:7000
{
options
{
ssl;
clientsonly;
};
};

listen 127.0.0.1:6669{
options{
serversonly;
}
}

listen         *:6667-6668;

no change :(
BTW i'm on windows if that matters...
Logged

Romeo

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 31
Re: Anope + Unreal 3.2 password protected ?
« Reply #9 on: November 21, 2013, 04:09:29 AM »

set username to * in the link block, too. If that doesn't fix it pastebin your ircd and services config.
Well, im kinda outta ideas, Lets go with what Adam says !!
Logged
running Unreal 3.2.10.1, Anope 1.9.9 on Ubuntu Server

Uli

  • Anope User
  • Offline Offline
  • Posts: 7
Re: Anope + Unreal 3.2 password protected ?
« Reply #10 on: November 21, 2013, 10:59:22 PM »

went back to 1.8.8 ...
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Anope + Unreal 3.2 password protected ?
« Reply #11 on: November 23, 2013, 02:20:42 AM »

Remove the * from your listen blocks and always use the IP instead. Logically it shouldn't make a difference but weirder things have happened. Always remove as much ambiguity as possible. Especially with listen and link blocks.

Also there is an odd bug in Unreal that  causes strangeness related to binding to the IP in the last listen block so move your 127.0.0.1 listen block to the bottom of the listen block list and specify the bind-ip in services link block so both link::hostname and link::bind-ip are set to 127.0.0.1.
Logged

thcobl

  • Anope User
  • Offline Offline
  • Posts: 1
Re: Anope + Unreal 3.2 password protected ?
« Reply #12 on: December 09, 2013, 10:35:34 PM »

I have same problem.
I keep getting :
                      marco@generals:/home/srvrs/anope/bin$ ./services
                      Anope 1.9.9, build #2, compiled 21:38:52 Dec  8 2013
                      Using configuration file conf/services.conf
                      Attempting to connect to uplink #1 127.0.0.1 (127.0.0.1), port 6668
                      Successfully connected to uplink #1 127.0.0.1:6668
                      ERROR: Missing password
                      ERROR: Closing Link: [127.0.0.1] (Missing password)


I my unrealircd.conf  and in services.conf the pass is there

anyone ?
Logged

Romeo

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 31
Re: Anope + Unreal 3.2 password protected ?
« Reply #13 on: December 10, 2013, 03:13:58 PM »

try pasting the link area of both of your confs.  . No one can tell you what is wrong without looking at the codes itself.
Logged
running Unreal 3.2.10.1, Anope 1.9.9 on Ubuntu Server
Pages: [1]   Go Up