Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: set language on 1.9.8  (Read 3408 times)

0 Members and 1 Guest are viewing this topic.

Gianluca

  • Anope User
  • Offline Offline
  • Posts: 27
set language on 1.9.8
« on: July 23, 2013, 12:26:54 AM »

hi i use your developer version 1.9.8 and i try for install italan language:

Code: [Select]
3[01:17:29] 12Nickserv *** Syntax: set language language
3[01:17:29] 12Nickserv ***
3[01:17:29] 12Nickserv *** Changes the language Services uses when sending messages to
3[01:17:29] 12Nickserv *** you (for example, when responding to a command you send).
3[01:17:29] 12Nickserv *** language should be chosen from the following list of
3[01:17:29] 12Nickserv *** supported languages:
3[01:17:29] 12Nickserv *** en (English)

with the SET Language i choose only ES Lang

on SSH i have installed all language:

Code: [Select]
~/anope-1.9.8-source/build/language$ make install
Install the project...
-- Install configuration: "DEBUG"
-- Up-to-date: /home/gianluca/services/locale/ca_ES/LC_MESSAGES/anope.mo
-- Up-to-date: /home/gianluca/services/locale/de_DE/LC_MESSAGES/anope.mo
-- Up-to-date: /home/gianluca/services/locale/el_GR/LC_MESSAGES/anope.mo
-- Up-to-date: /home/gianluca/services/locale/es_ES/LC_MESSAGES/anope.mo
-- Up-to-date: /home/gianluca/services/locale/fr_FR/LC_MESSAGES/anope.mo
-- Up-to-date: /home/gianluca/services/locale/hu_HU/LC_MESSAGES/anope.mo
-- Up-to-date: /home/gianluca/services/locale/it_IT/LC_MESSAGES/anope.mo
-- Up-to-date: /home/gianluca/services/locale/nl_NL/LC_MESSAGES/anope.mo
-- Up-to-date: /home/gianluca/services/locale/pl_PL/LC_MESSAGES/anope.mo
-- Up-to-date: /home/gianluca/services/locale/pt_PT/LC_MESSAGES/anope.mo
-- Up-to-date: /home/gianluca/services/locale/ru_RU/LC_MESSAGES/anope.mo
-- Up-to-date: /home/gianluca/services/locale/tr_TR/LC_MESSAGES/anope.mo

and:

Code: [Select]
3[01:27:05] Operserv*** languages ca_ES.UTF-8 de_DE.UTF-8 el_GR.UTF-8 es_ES.UTF-8 fr_FR.UTF-8 hu_HU.UTF-8 it_IT.UTF-8 nl_NL.UTF-8 pl_PL.UTF-8 pt_PT.UTF-8 ru_RU.UTF-8 tr_TR.UTF-8
3[01:27:05] Operserv*** defaultlanguage it_IT.UTF-8

My error is in configuration debug? Tnk for your reply :)
« Last Edit: July 23, 2013, 12:30:17 AM by Gianluca »
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: set language on 1.9.8
« Reply #1 on: July 23, 2013, 01:55:35 AM »

You need to have the locales installed on your system. On Debian you can apt-get install locales-all && locale-gen
Logged

Gianluca

  • Anope User
  • Offline Offline
  • Posts: 27
Re: set language on 1.9.8
« Reply #2 on: July 23, 2013, 08:35:54 AM »

good morning, sorry what is locales and local-gen? are lib?

i use Linux  2.6.32-042stab078.27
« Last Edit: July 23, 2013, 10:04:30 AM by Gianluca »
Logged
Pages: [1]   Go Up