Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Anope 1.9x SQLlite Compile problem  (Read 9499 times)

0 Members and 1 Guest are viewing this topic.

Matt Smith

  • Anope User
  • Offline Offline
  • Posts: 9
Anope 1.9x SQLlite Compile problem
« on: April 23, 2013, 08:45:31 PM »

When I go to Compile Anope I get this:

Code: [Select]
Building CXX object modules/CMakeFiles/m_sqlite.so.dir/extra/m_sqlite.o
An error occured when executing: /usr/bin/c++ -Dm_sqlite_so_EXPORTS -fPIC -I/var/www/vhosts/kinksterschat.com/private/anope-1.9.8-source/build/include -I/var/www/vhosts/kinksterschat.com/private/anope-1.9.8-source/include -I/var/www/vhosts/kinksterschat.com/private/anope-1.9.8-source/build/language -I/var/www/vhosts/kinksterschat.com/private/anope-1.9.8-source/modules/pseudoclients -Wall -Wshadow -ansi -pedantic -Wno-long-long -fno-leading-underscore -o CMakeFiles/m_sqlite.so.dir/extra/m_sqlite.o -c /var/www/vhosts/kinksterschat.com/private/anope-1.9.8-source/modules/extra/m_sqlite.cpp
/var/www/vhosts/kinksterschat.com/private/anope-1.9.8-source/modules/extra/m_sqlite.cpp: In constructor âSQLiteService::SQLiteService(Module*, const Anope::string&, const Anope::string&)â:
/var/www/vhosts/kinksterschat.com/private/anope-1.9.8-source/modules/extra/m_sqlite.cpp:133: error: âSQLITE_OPEN_READWRITEâ was not declared in this scope
/var/www/vhosts/kinksterschat.com/private/anope-1.9.8-source/modules/extra/m_sqlite.cpp:133: error: âSQLITE_OPEN_CREATEâ was not declared in this scope
/var/www/vhosts/kinksterschat.com/private/anope-1.9.8-source/modules/extra/m_sqlite.cpp:133: error: âsqlite3_open_v2â was not declared in this scope
/var/www/vhosts/kinksterschat.com/private/anope-1.9.8-source/modules/extra/m_sqlite.cpp: In member function âvirtual SQL::Result SQLiteService::RunQuery(const SQL::Query&)â:
/var/www/vhosts/kinksterschat.com/private/anope-1.9.8-source/modules/extra/m_sqlite.cpp:157: error: âsqlite3_prepare_v2â was not declared in this scope
make[2]: *** [modules/CMakeFiles/m_sqlite.so.dir/extra/m_sqlite.o] Error 1
make[1]: *** [modules/CMakeFiles/m_sqlite.so.dir/all] Error 2
make: *** [all] Error 2

I suspect this has something to do with a library file mixup but everything seems ok.  Any thoughts
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Anope 1.9x SQLlite Compile problem
« Reply #1 on: April 23, 2013, 09:22:23 PM »

OS?
Logged

Matt Smith

  • Anope User
  • Offline Offline
  • Posts: 9
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: Anope 1.9x SQLlite Compile problem
« Reply #3 on: April 23, 2013, 09:49:43 PM »

Sqlite version?
Logged

Matt Smith

  • Anope User
  • Offline Offline
  • Posts: 9
Re: Anope 1.9x SQLlite Compile problem
« Reply #4 on: April 23, 2013, 10:19:48 PM »

Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: Anope 1.9x SQLlite Compile problem
« Reply #5 on: April 23, 2013, 10:22:56 PM »

I have sqlite 3.6.20 on centos 6.3 and it works for me.
Logged

Matt Smith

  • Anope User
  • Offline Offline
  • Posts: 9
Re: Anope 1.9x SQLlite Compile problem
« Reply #6 on: April 24, 2013, 12:53:31 AM »

I have sqlite 3.6.20 on centos 6.3 and it works for me.

could I have an older version installed and not realize it?
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: Anope 1.9x SQLlite Compile problem
« Reply #7 on: April 24, 2013, 12:55:09 AM »

That's why I asked you what version you had installed, but you gave a vague answer.
Logged

Matt Smith

  • Anope User
  • Offline Offline
  • Posts: 9
Re: Anope 1.9x SQLlite Compile problem
« Reply #8 on: April 24, 2013, 01:37:19 AM »

That's why I asked you what version you had installed, but you gave a vague answer.

Package sqlite-3.3.6-6.x86_64 already installed and latest version
Package sqlite-3.3.6-6.i386 already installed and latest version
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: Anope 1.9x SQLlite Compile problem
« Reply #9 on: April 24, 2013, 01:38:33 AM »

That is from 2006. Can you try to find a newer package?
Logged

Matt Smith

  • Anope User
  • Offline Offline
  • Posts: 9
Re: Anope 1.9x SQLlite Compile problem
« Reply #10 on: April 24, 2013, 03:22:54 AM »

That is from 2006. Can you try to find a newer package?

Wow, that will be tomorrow's project :)
Logged

Matt Smith

  • Anope User
  • Offline Offline
  • Posts: 9
Re: Anope 1.9x SQLlite Compile problem
« Reply #11 on: April 24, 2013, 09:46:42 PM »

Wow, that will be tomorrow's project :)

Updated to Sqllite 3.7.16.2 and it's still doing it  >:(
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: Anope 1.9x SQLlite Compile problem
« Reply #12 on: April 24, 2013, 10:13:02 PM »

Are you sure the old one isn't installed still and it isn't using the header from it?
Logged

Matt Smith

  • Anope User
  • Offline Offline
  • Posts: 9
Re: Anope 1.9x SQLlite Compile problem
« Reply #13 on: April 24, 2013, 10:31:48 PM »

Are you sure the old one isn't installed still and it isn't using the header from it?

I did a make clean....Is there something I missed?
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: Anope 1.9x SQLlite Compile problem
« Reply #14 on: April 24, 2013, 10:33:31 PM »

I mean remove the older sqlite package.

You actually want to use sqlite right? If you don't need sqlite you can just remove m_sqlite.cpp and re ./Config and it will continue on.
Logged

Matt Smith

  • Anope User
  • Offline Offline
  • Posts: 9
Re: Anope 1.9x SQLlite Compile problem
« Reply #15 on: April 24, 2013, 10:43:59 PM »

I did point ./Config at the new SQLlite location
Logged
Pages: [1]   Go Up