Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Database Problems  (Read 6235 times)

0 Members and 1 Guest are viewing this topic.

R.M.

  • Anope User
  • Offline Offline
  • Posts: 4
Database Problems
« on: February 08, 2013, 12:08:55 PM »

Hello there,

I searched the board, but couldn't find an answer to my problem. I use Anope since many years. Now i made an upgrade to 1.9. and runs perfect. But after any restart Anope creates a new anope.db file. Then i loose all my rooms. Is there an error by me or is this default?

Ty very much

Snape
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Database Problems
« Reply #1 on: February 08, 2013, 12:20:14 PM »

What type of database do you have configured?

Please provide the relevant info from your config.
Logged

R.M.

  • Anope User
  • Offline Offline
  • Posts: 4
Re: Database Problems
« Reply #2 on: February 08, 2013, 12:26:32 PM »

Ty for your answer. Here is a copy of my database part in my conf file:

---------------------------------------------------------------------

module { name = "db_plain" }
db_plain
{
   /*
    * The database name db_plain should use
    */
   database = "anope.db"
}


module { name = "db_flatfile" }
db_flatfile
{
   /*
    * The database name db_flatfile should use
    */
   database = "anope.db"
}

db_sql
{
   /*
    * The SQL service db_sql(_live) should use, these are configured in modules.conf.
    * For MySQL, this should probably be mysql/main.
    */
   engine = "mysql/main"

   /*
    * An optional prefix to prepended to the name of each created table.
    * Do not use the same prefix for other programs.
    */
   prefix = "anope_db_"
}

-------------------------------------------------------------------------

Ty :)
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Database Problems
« Reply #3 on: February 08, 2013, 12:28:52 PM »

Please provide debug logs showing this happening

./services -debug
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Database Problems
« Reply #4 on: February 08, 2013, 12:30:10 PM »

12:29 <~DukePyrolator> ah, he is loading db_plain and db_flatfile at the same time ... and both modules try to use the same database file
12:29 <~DukePyrolator> thats bad


^ See above.
Logged

R.M.

  • Anope User
  • Offline Offline
  • Posts: 4
Re: Database Problems
« Reply #5 on: February 08, 2013, 12:40:46 PM »

Ahh yes he's right..error by me. Which one is the right block for me, in use with mysql?
Logged

R.M.

  • Anope User
  • Offline Offline
  • Posts: 4
Re: Database Problems
« Reply #6 on: February 08, 2013, 12:58:55 PM »

This my output everytime:

Using IRCd protocol unreal
Loading databases...
Unable to open data/anope.db for reading!
Databases loaded
Logged
Pages: [1]   Go Up