Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: as I put the Spanish language as default?  (Read 5666 times)

0 Members and 1 Guest are viewing this topic.

Erick Damian

  • Anope User
  • Offline Offline
  • Posts: 2
as I put the Spanish language as default?
« on: May 23, 2012, 04:34:35 PM »

I have a question, as I put the Spanish language as default. I do not want the English language by default.
Logged

Jens Voss

  • Team
  • *
  • Offline Offline
  • Posts: 123
Re: as I put the Spanish language as default?
« Reply #1 on: May 23, 2012, 04:46:18 PM »

Quote from: nickserv.conf
/*
 * Default language that non- and newly-registered nicks will receive messages in.
* Leave empty to default to English.
*/
#defaultlanguage = "es_ES"

dont forget to remove the '#' before the "defaultlanguage"
Logged

Erick Damian

  • Anope User
  • Offline Offline
  • Posts: 2
Re: as I put the Spanish language as default?
« Reply #2 on: May 24, 2012, 01:46:52 AM »

Thanks, but does not work.
nickserv.conf in my file, the line that you put under me exactly what you got. And stay like this:
Quote
/ *
* A list of languages ​​to load on startup That will be available in / nickserv set language.
* Useful if you translate to your language Anope. (Further Explained in docs / LANGUAGE).
* NOTE THAT english Should not be listed here it is the basis Because language.
* /
languages ​​= "en_US fr_FR de_DE el_GR ca_ES hu_HU it_IT ru_RU nl_NL pl_PL pt_PT tr_TR"

/ *
* Default language That non-and newly-registered nicks will Receive messages in.
* Leave empty to default to English.
* /
DefaultLanguage = "en_US"
Type this in irc:
Quote
/ msg nickserv help set language and I get this:

-NickServ-Changes the language Services When sending messages to use
-
-NickServ-you (for example, when to Responding to a command you send).
-
-NickServ-language CHOSEN Should Be Following from the list of
-
-NickServ-supported languages:
-
-NickServ-en (English)
Only appears languages ​​English, the lenguage Spanish no appears. That may be happening here?
Logged

Jens Voss

  • Team
  • *
  • Offline Offline
  • Posts: 123
Re: as I put the Spanish language as default?
« Reply #3 on: May 24, 2012, 04:07:29 AM »

You have no gettext installed. Without gettext anope supports only the english language.
Install gettext and try again. :-)

In your paste you have still "en_US" as default language.
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: as I put the Spanish language as default?
« Reply #4 on: May 25, 2012, 05:01:18 AM »

It should be noted that changing this setting now will not affect users that are already registered. It will only affect NEW users. Existing users will need to set their own language in their NickServ set language option. Please see the help menu for exact syntax and supported languages.
Logged

rastamanx

  • Anope User
  • Offline Offline
  • Posts: 3
Re: as I put the Spanish language as default?
« Reply #5 on: June 02, 2013, 01:15:36 PM »

Any idea what gettext packages exactly are needed for anope to be able to use other locales correctly on Debian 7 ?
I first compile anope 1.9.8 without gettext, so I didn't get any locales compiled.
After digging the Makefiles etc, I found out it needed gettext to compile them, so i installed gettext, and it compiled the locales, and installed them in anope/locale on 'make install'.
But I still don't have anything except english available.
I have only 4 gettext packages installed :
gettext
gettext-base
libgettextpo0
liblocale-gettext-perl
Does it need another one to work properly ?

By the way, logs clearly state 'Unable to use language ca_ES' for every locale. So i guess it's not a path issue.

EDIT: Fixed it by myself.
I just installed gettext-lint and locales-all and it seems to work now. Maybe it'll help someone else having troubles with languages.
« Last Edit: June 02, 2013, 02:42:05 PM by rastamanx »
Logged
Pages: [1]   Go Up