Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: enforcing channel modes on ircd startup/restart  (Read 6881 times)

0 Members and 1 Guest are viewing this topic.

aberant

  • Anope User
  • Offline Offline
  • Posts: 6
enforcing channel modes on ircd startup/restart
« on: April 24, 2012, 10:10:38 PM »

I can't figure out why ChanServ isn't enforcing modes on ircd startup.  Unreal3.2.9 and Anope 1.9.6

If I /restart unreal, ChanServ will join all registered channels, but not set modes.  Modes are set as expected if a channel is empty, and then re-joined.

I can get ChanServ to set locked modes by restarting services after the IRCd restart, but that's the only way.

Am I missing something, or is this intended behavior?

Below is a log of creating a channel, setting mode locks, restarting the IRCd, and modes not being set when chanserv joins on startup.

* Now talking on #staff-admin
/msg ChanServ register #staff-admin
* ChanServ sets mode +r #staff-admin
* ChanServ sets mode +q #staff-admin aberrant
/msg ChanServ mode #staff-admin lock add +MNRTinstK
* ChanServ sets mode +s #staff-admin
* ChanServ sets mode +i #staff-admin
* ChanServ sets mode +R #staff-admin
* ChanServ sets mode +K #staff-admin
* ChanServ sets mode +M #staff-admin
* ChanServ sets mode +N #staff-admin
* ChanServ sets mode +T #staff-admin
-ChanServ- +M locked on #staff-admin
-ChanServ- +N locked on #staff-admin
-ChanServ- +R locked on #staff-admin
-ChanServ- +T locked on #staff-admin
-ChanServ- +i locked on #staff-admin
-ChanServ- +n locked on #staff-admin
-ChanServ- +s locked on #staff-admin
-ChanServ- +t locked on #staff-admin
-ChanServ- +K locked on #staff-admin
---
issue a /restart
---
-Global- Services are now back online.
* ChanServ (services@[...]) has joined #staff-admin
* ChanServ sets mode +a #staff-admin ChanServ
* ChanServ gives channel operator status to ChanServ
* Channel #staff-admin modes: +
(modes are empty, chanserv does not set them)
---
>ChanServ< mode #staff-admin lock list
-ChanServ- Mode locks for #staff-admin:
-ChanServ- Mode  Param  Creator  Created
-ChanServ- +i           aberrant  [...]
-ChanServ- +n           aberrant [...]
-ChanServ- +r           aberrant  [...]
-ChanServ- +s           aberrant  [...]
-ChanServ- +t           aberrant  [...]
-ChanServ- +K           aberrant  [...]
-ChanServ- +M           aberrant  [...]
-ChanServ- +N           aberrant  [...]
-ChanServ- +R           aberrant  [...]
-ChanServ- +T           aberrant  [...]
(chanserv still knows the modes should be enforced, but doesn't set them).
« Last Edit: April 24, 2012, 11:13:24 PM by aberant »
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: enforcing channel modes on ircd startup/restart
« Reply #1 on: April 24, 2012, 11:46:31 PM »

Can ChanServ set any modes? for example does ChanServ op it's self when it joins? If not, check your U:Lines.
Logged

aberant

  • Anope User
  • Offline Offline
  • Posts: 6
Re: enforcing channel modes on ircd startup/restart
« Reply #2 on: June 05, 2012, 11:06:36 PM »

Can ChanServ set any modes? for example does ChanServ op it's self when it joins? If not, check your U:Lines.
As I said originally, "I can get ChanServ to set locked modes by restarting services after the IRCd restart, but that's the only way."  So yes, ChanServ sets modes fine, just not when the ircd is restarted.   Also, chanserv never seems to op itself for me.  It always just joins, and then enforces modes/topic without oping.

At the moment if the ircd is restarted for some reason, msg operserv restart will cause chanserv to instate channel modes and topics.  I am just hoping there is a way to have chanserv recover and set modes without needing a restart.
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: enforcing channel modes on ircd startup/restart
« Reply #3 on: June 06, 2012, 12:24:07 AM »

You shouldn't have to restart. Please reply with the output of /msg operserv modlist
Logged

aberant

  • Anope User
  • Offline Offline
  • Posts: 6
Re: enforcing channel modes on ircd startup/restart
« Reply #4 on: June 06, 2012, 01:02:45 AM »

>operserv< modlist
-OperServ- Current Module list:
-OperServ- Module: unreal [1.9.6 (1)] [Protocol]
-OperServ- Module: db_flatfile [1.9.6 (1)] [Database]
-OperServ- Module: enc_sha256 [1.9.6 (1)] [Encryption]
-OperServ- Module: enc_none [1.9.6 (1)] [Encryption]
-OperServ- Module: m_dnsbl [1.9.6 (1)] [Supported]
-OperServ- Module: m_helpchan [1.9.6 (1)] [Supported]
-OperServ- Module: m_proxyscan [1.9.6 (1)] [Supported]
-OperServ- Module: m_statusupdate [1.9.6 (1)] [Supported]
-OperServ- Module: ns_maxemail [1.9.6 (1)] [Supported]
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: enforcing channel modes on ircd startup/restart
« Reply #5 on: June 10, 2012, 08:44:23 PM »

ok, I should have asked for this too.

paste the output of /tsctl alltime please.
Logged

aberant

  • Anope User
  • Offline Offline
  • Posts: 6
Re: enforcing channel modes on ircd startup/restart
« Reply #6 on: June 25, 2012, 07:16:11 AM »

ok, I should have asked for this too.

paste the output of /tsctl alltime please.

*** Server=<servername> TStime=1340604888 time()=1340612213 TSoffset=-7324
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: enforcing channel modes on ircd startup/restart
« Reply #7 on: June 27, 2012, 09:53:40 PM »

That's the problem, your systems time is WAAAAY out of sync.

If you have Anope and the ircd on the same machine, disable Unreal's timesynch function explained at http://www.unrealircd.com/files/docs/unreal32docs.html#feature_timesync This is enabled by default and no documents say that this is a bad thing if you run ircd and services on the same box without ntpd, which running a system ntpd would negate the reason for unreal having timesynch in the first place.

Anyway, what's happening is unreal is getting accurate times from the internet and Anope is getting it's time from your machine and your machine's system clock is out of adjustment. If you have root, please install ntpd (google can help you). If you are not root, then explain to the system admin, whom should already know >:( .. they need to have ntpd installed for more reasons tan just IRC, but IRC requires accurate clocks and is very sensitive to time drift.
Logged
Pages: [1]   Go Up