Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: auto logchan on  (Read 9160 times)

0 Members and 1 Guest are viewing this topic.

diskman

  • Guest
auto logchan on
« on: May 21, 2006, 10:16:07 PM »

hi ;)

i use the logchan function to post the request of a new vhost in various chanels so my helpops can see there is a new vhost request and activate or reject them
but if the services going down and starting again the logchan is always off

i think it could be a nice feauture to switch logchan permanently on via services.conf
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #1 on: May 22, 2006, 01:26:14 AM »

Ive found that after supplying the command line parameter "-logchan" on windows that it is started automatically. But unless you have properly secured the log channel i would not recommend having it start automatically anyway.

[Edited on 22-5-2006 by Jobe1986]
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

diskman

  • Guest
(No subject)
« Reply #2 on: May 22, 2006, 04:03:34 PM »

aahh wonderfull ;)
-logchan also works under linux/unix ;)
thanks
Logged

MusicMan

  • Guest
(No subject)
« Reply #3 on: July 30, 2006, 09:10:34 PM »

i still dont understand how to set -logchan..i know i can start services by typing ./services -logchan....but how do i set it to auto start..in a cron job?..i tried adding ./services -logchan in the (input to command) but it did not work...any help would be greatful.
Logged

katsklaw

  • Guest
(No subject)
« Reply #4 on: July 30, 2006, 09:33:37 PM »

the example cron script that comes with Anope has an ANOARGS "" field ... place -logchan in it.
Logged

MusicMan

  • Guest
(No subject)
« Reply #5 on: July 30, 2006, 10:12:28 PM »

i did try that like
#ANOARGS="-debug -logchan"
and
#ANOARGS="-logchan"
it did not work...am i just not placeing it on the right line?
Logged

diskman

  • Guest
(No subject)
« Reply #6 on: July 31, 2006, 12:00:33 AM »

you have to remove the leading #
then it works...
Logged

MusicMan

  • Guest
(No subject)
« Reply #7 on: July 31, 2006, 12:17:58 PM »

doh!!!
that was a no brainer...
thnx for the help
Logged

Killerfurbies

  • Guest
(No subject)
« Reply #8 on: September 05, 2006, 02:37:00 AM »

I know that this is a bit of a bump, but i didn't want to start a topic, since i have this same problem. First of all, when i started anope through the command prompt (on windows), i typed "anope -logchan" which is what i thought this topic said to do. However, that didn't work. I also don't know where that cron script is. Any help would be greatly appreciated.
Logged

katsklaw

  • Guest
(No subject)
« Reply #9 on: September 05, 2006, 02:56:21 AM »

crontab is a Unix type program that uses scripts to perform automated tasks.

There is a win32 port for cron at: http://cronw.sourceforge.net/ but I have never used it.
Logged

TRAiNER4

  • Guest
(No subject)
« Reply #10 on: September 05, 2006, 01:29:02 PM »

Start Anope with -logchan. Also, make sure you set the LogChannel parameter in your services.conf, and make sure the channel is registered and you atleast lock modes +ntO on it (for Unreal). This will ensure only IRCops can enter it. If you only want Administrators, lock mode +A instead of +O
Logged
Pages: [1]   Go Up