Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: enc_switchover equivalent for 1.9?  (Read 2738 times)

0 Members and 1 Guest are viewing this topic.

aberant

  • Anope User
  • Offline Offline
  • Posts: 6
enc_switchover equivalent for 1.9?
« on: April 21, 2012, 07:37:32 AM »

Our IRCd server had a hard disk crash recently, so I've been rebuilding the server and configs from scratch since they were long due for a cleanup.  I have backups of the databases of course.  Now I have anope 1.9.6 running on unrealircd, and it's time to move from enc_none to encrypted nickserv passwords.

enc_switchover isn't compatible with 1.9 branch (as far as I can tell), although I remember there being talk about a similar feature being merged to main?  Is there anyway to move from enc_none to enc_sha1 without going through the effort of setting back up a 1.8 branch install?
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: enc_switchover equivalent for 1.9?
« Reply #1 on: April 21, 2012, 07:40:41 AM »

Yes if you read the example configuration you will see you want to load the encryption module you want + the current encryption module. When people identify passwords are rehashed using the encryption module with the most priority, which is the one that is listed first in the configuration.
Logged

aberant

  • Anope User
  • Offline Offline
  • Posts: 6
Re: enc_switchover equivalent for 1.9?
« Reply #2 on: April 21, 2012, 04:53:49 PM »

Thanks Adam; much appreciated.  Not sure how I missed that in the example files. 

Now to figure out how to get ChanServ to set locked modes on start up =].

Cheers
Logged
Pages: [1]   Go Up