MagIRC > MagIRC Support

SQL Password

(1/1)

Jeffrey Turner:
I was confused when I was first setting this up because I was getting an SQL Error. Normally one would assume that a typo was the cause with ether username, database, or password. I ignored the error and just saved the information when I was running the setup.

Then I looked at the generated config file and compared it to other php/sql software I have used.


--- Code: (Generated Version) ---<?php

$db['username'] = "sqlusername";
$db['password'] = "sqlpassword";
$db['database'] = "magirc";
$db['hostname'] = "mysql.server";
$db['port'] = "3306";
?>
--- End code ---

There error was a result of the $db['password'] = "sqlpassword"; if the password contain a symbol like "$", it would result in an error. However, when I changed that line to $db['password'] = 'sqlpassword'; instead, it worked and let me finish setting everything up. (IE. Changing the " to '.)

Hal9000:
thanks for pointing this out, i will fix this in git soon

Navigation

[0] Message Index

Go to full version