Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: SQL Error by !mode and unassign (BotServ not responding)  (Read 4854 times)

0 Members and 1 Guest are viewing this topic.

cmvdeeden

  • Anope User
  • Offline Offline
  • Posts: 26
SQL Error by !mode and unassign (BotServ not responding)
« on: March 02, 2012, 09:43:34 PM »

Hi guys,

After I use !mode, running Anope 1.9.6, BotServ seems to not respond anymore, however !mode did work. And when I use /bs unassign, BotServ's responding with the message that there isn't any bot assigned to the channel, which means I can assign a second bot to the channel, while that second one also doesn't seem to respond.

So, I've runned debug and THIS is the output:
Code: [Select]
[Mar 02 22:33:27.466991 2012] Debug: Received: :Rico ! #testjah :!mode lock add -s
[Mar 02 22:33:27.467821 2012] Debug: SQL query SELECT * FROM `ChannelInfo` WHERE `name` = '#testjah' returned 20 fields
[Mar 02 22:33:27.467861 2012] Debug: Field count 0 name is: bantype, data is: 2
[Mar 02 22:33:27.467890 2012] Debug: Field count 1 name is: botflags, data is: DONTKICKOPS FANTASY GREET
[Mar 02 22:33:27.467919 2012] Debug: Field count 2 name is: capsmin, data is: 0
[Mar 02 22:33:27.467947 2012] Debug: Field count 3 name is: capspercent, data is: 0
[Mar 02 22:33:27.467974 2012] Debug: Field count 4 name is: description, data is:
[Mar 02 22:33:27.468001 2012] Debug: Field count 5 name is: flags, data is: KEEPTOPIC SECUREOPS PEACE SECURE SECUREFOUNDER SIGNKICK
[Mar 02 22:33:27.468029 2012] Debug: Field count 6 name is: floodlines, data is: 0
[Mar 02 22:33:27.468056 2012] Debug: Field count 7 name is: floodsecs, data is: 0
[Mar 02 22:33:27.468084 2012] Debug: Field count 8 name is: founder, data is: Rico
[Mar 02 22:33:27.468112 2012] Debug: Field count 9 name is: last_topic, data is: woei
[Mar 02 22:33:27.468139 2012] Debug: Field count 10 name is: last_topic_setter, data is: Rico
[Mar 02 22:33:27.468167 2012] Debug: Field count 11 name is: last_topic_time, data is: 1330722137
[Mar 02 22:33:27.468348 2012] Debug: Field count 12 name is: last_used, data is: 1330724001
[Mar 02 22:33:27.468379 2012] Debug: Field count 13 name is: levels, data is: ACCESS_CHANGE 10 ACCESS_LIST 10 AKICK 10 ASSIGN 10001 AUTOHALFOP 4 AUTOOP 5 AUTOOWNER 9999 AUTOPROTECT 10 AUTOVOICE 3 BADWORDS 10 BAN 4 FANTASIA 3 FOUNDER 10001 GETKEY 5 GREET 5 HALFOP 5 HALFOPME 4 INFO 9999 INVITE 5 KICK 4 MEMO 10 MODE 5 NOKICK 1 OPDEOP 5 OPDEOPME 5 OWNER 10001 OWNERME 9999 PROTECT 9999 PROTECTME 10 SAY 5 SET 9999 SIGNKICK 9999 TOPIC 5 UNBAN 4 VOICE 4 VOICEME 3
[Mar 02 22:33:27.468412 2012] Debug: Field count 14 name is: memomax, data is: 20
[Mar 02 22:33:27.468440 2012] Debug: Field count 15 name is: name, data is: #testjah
[Mar 02 22:33:27.468467 2012] Debug: Field count 16 name is: repeattimes, data is: 0
[Mar 02 22:33:27.468494 2012] Debug: Field count 17 name is: time_registered, data is: 1330722131
[Mar 02 22:33:27.468522 2012] Debug: Field count 18 name is: ttb, data is: 0 0 0 0 0 0 0 0 0 0
[Mar 02 22:33:27.468549 2012] Debug: Field count 19 name is: bi, data is:
[Mar 02 22:33:27.469074 2012] Debug: SQL query SELECT * FROM `NickCore` WHERE `display` = 'Rico' returned 8 fields
[Mar 02 22:33:27.469110 2012] Debug: Field count 0 name is: access, data is: 134@jouwchatroom.nl
[Mar 02 22:33:27.469138 2012] Debug: Field count 1 name is: display, data is: Rico
[Mar 02 22:33:27.469165 2012] Debug: Field count 2 name is: email, data is: ricocremer@hotmail.nl
[Mar 02 22:33:27.469349 2012] Debug: Field count 3 name is: flags, data is: SECURE MEMO_SIGNON MEMO_RECEIVE PRIVATE HIDE_EMAIL HIDE_MASK AUTOOP
[Mar 02 22:33:27.469380 2012] Debug: Field count 4 name is: greet, data is:
[Mar 02 22:33:27.469408 2012] Debug: Field count 5 name is: language, data is: 0
[Mar 02 22:33:27.469435 2012] Debug: Field count 6 name is: memomax, data is: 20
[Mar 02 22:33:27.469462 2012] Debug: Field count 7 name is: pass, data is: md5:a16be2a67502d6128b2edcced413428d
[Mar 02 22:33:27.469864 2012] Debug: Sent: :Roombeheerder NOTICE Rico :-s locked on #testjah
[Mar 02 22:33:27.469933 2012] COMMAND: Rico!134@ip202-94-211-87.adsl2.static.versatel.nl used mode on #testjah to lock -s
[Mar 02 22:33:27.470283 2012] Debug: Sent: :ChanServ G #testjah -s
[Mar 02 22:33:27.470414 2012] Debug: Error executing query INSERT INTO `ModeLock` (`ci`,`created`,`name`,`param`,`set`,`setter`) VALUES ('#testjah','1330724007','CMODE_SECRET','','0','Rico') ON DUPLICATE KEY UPDATE ci=VALUES(ci),created=VALUES(created),name=VALUES(name),param=VALUES(param),set=VALUES(set),setter=VALUES(setter): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'set=VALUES(set),setter=VALUES(setter)' at line 1
[Mar 02 22:33:31.882514 2012] Debug: Received: :Rico ! #testjah :!topic woei
[Mar 02 22:33:58.284784 2012] Debug: Received: :Rico ! #testjah :!topic test

Any idea's or help?



-- EDIT --

After dropping the channel and register it again, it does seem to work again but SOMETIMES when I use !mode again it doesn't respond anymore, again. But, that's only sometimes after reregistering.
« Last Edit: March 02, 2012, 09:51:59 PM by cmvdeeden »
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Logged

cmvdeeden

  • Anope User
  • Offline Offline
  • Posts: 26
Re: SQL Error by !mode and unassign (BotServ not responding)
« Reply #2 on: March 02, 2012, 10:33:47 PM »

Its because of the set column name, I fixed it in http://anope.git.sourceforge.net/git/gitweb.cgi?p=anope/anope;a=patch;h=4ed844ffd5e19a7e95c47e34dbf7d3fd83039d3c

Hm, okay.
Could you explain me what I need to do with the code you've just given?
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: SQL Error by !mode and unassign (BotServ not responding)
« Reply #3 on: March 02, 2012, 10:39:33 PM »

Code: [Select]
wget -O - "http://anope.git.sourceforge.net/git/gitweb.cgi?p=anope/anope;a=patch;h=4ed844ffd5e19a7e95c47e34dbf7d3fd83039d3c" | patch -p1
cd build
make install
Logged

cmvdeeden

  • Anope User
  • Offline Offline
  • Posts: 26
Re: SQL Error by !mode and unassign (BotServ not responding)
« Reply #4 on: March 02, 2012, 10:48:19 PM »

Thanks a lot! :) This worked.
Logged
Pages: [1]   Go Up