Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: upgrading database to 1.9.6  (Read 11193 times)

0 Members and 1 Guest are viewing this topic.

lordcow

  • Anope User
  • Offline Offline
  • Posts: 13
upgrading database to 1.9.6
« on: February 22, 2012, 01:37:41 PM »

Hi all, we recently upgraded from 1.8.7 to 1.9.6 (on InspIRCd 2.0.5) but we lose data after a restart. We followed the cues in the .conf, loading with:

module { name = "db_old" }
#module { name = "db_plain" }
module { name = "db_flatfile" }

This correctly loaded the data from 1.8.7, and when we /operserv update or shutdown it correctly wrote everything to the new anope.db. On shutdown we hashed out the db_old module and started up to find all memos had disappeared (amongst possibly some other data). Once anope wrote to disk again the memos that had been in the new anope.db file were cleared. Is this a bug or are we doing something wrong?
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: upgrading database to 1.9.6
« Reply #1 on: February 22, 2012, 05:35:01 PM »

« Last Edit: February 22, 2012, 09:28:20 PM by Adam »
Logged

lordcow

  • Anope User
  • Offline Offline
  • Posts: 13
Re: upgrading database to 1.9.6
« Reply #2 on: February 23, 2012, 10:11:05 AM »

awesome thanx
Logged

lordcow

  • Anope User
  • Offline Offline
  • Posts: 13
Re: upgrading database to 1.9.6
« Reply #3 on: February 24, 2012, 04:38:25 PM »

we've checked out 1.9.7-avoid-direct-visual-contact - the memos are retained this time but imported in reverse order.
Logged

lordcow

  • Anope User
  • Offline Offline
  • Posts: 13
Re: upgrading database to 1.9.6
« Reply #4 on: February 24, 2012, 05:39:53 PM »

the only other issues i can pick up via diff'ing are the channel counts for each botserv bot are being double counted (after we shutdown and remove the db_old module).
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Logged

CuttingEdge

  • Guest
Re: upgrading database to 1.9.6
« Reply #6 on: February 26, 2012, 10:09:57 AM »

Found that 'noexpire' flags within nicknames aren't propagated over either from 1.8.7 to 1.9.7 (latest GIT checkout).  Looks fine for channels.
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: upgrading database to 1.9.6
« Reply #7 on: February 27, 2012, 05:18:42 AM »

Ah thanks. It appears early 1.9 changed how that worked so I've changed it back to load 1.8 style databases. If any early 1.9 people are left they're out of luck. Fixed in http://anope.git.sourceforge.net/git/gitweb.cgi?p=anope/anope;a=commitdiff;h=020467d472bc41831756e68ca341d2b166fadceb.
Logged

CuttingEdge

  • Guest
Re: upgrading database to 1.9.6
« Reply #8 on: February 27, 2012, 02:57:36 PM »

Thank you kindly!  All working as intended.  :)
Logged

CuttingEdge

  • Guest
Re: upgrading database to 1.9.6
« Reply #9 on: February 27, 2012, 03:00:54 PM »

Think I found another bug.  The ChanServ mode lock doesn't show any modes after a conversion either.

See: /msg ChanServ info #channel
« Last Edit: February 28, 2012, 07:01:52 PM by Wesley Channon »
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
Re: upgrading database to 1.9.6
« Reply #10 on: February 29, 2012, 08:21:13 AM »

mlock was removed in 1.9.6. Use CS MODE instead.
Settings from mlock are not imported into mode..
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

CuttingEdge

  • Guest
Re: upgrading database to 1.9.6
« Reply #11 on: February 29, 2012, 05:07:01 PM »

Hi Jan,

Thanks for the heads up!  I see now what you mean. :)

*makes a mental note*

--
Logged

lordcow

  • Anope User
  • Offline Offline
  • Posts: 13
Re: upgrading database to 1.9.6
« Reply #12 on: March 04, 2012, 09:24:29 PM »

Hey, something else - as soon as a host goes over the defaultsessionlimit services crashes.
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: upgrading database to 1.9.6
« Reply #13 on: March 04, 2012, 11:27:34 PM »

We need logs and a backtrace to fix that
Logged

lordcow

  • Anope User
  • Offline Offline
  • Posts: 13
Re: upgrading database to 1.9.6
« Reply #14 on: March 05, 2012, 12:39:45 PM »

our defaultsessionlimit is 3. Services logs in debug mode when sending in 4 sessions:

http://lordcow.org/sessionlimit_logs.txt

At this point services crashes. A backtrace from gdb:

http://lordcow.org/sessionlimit_gdb.txt
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: upgrading database to 1.9.6
« Reply #15 on: March 10, 2012, 08:00:19 PM »

Logged

lordcow

  • Anope User
  • Offline Offline
  • Posts: 13
Re: upgrading database to 1.9.6
« Reply #16 on: March 14, 2012, 11:51:27 AM »

Hey, nope still crashing.

I'm not sure if I got the modules/commands/os_session.cpp changes right though:

you want me to remove

Code: [Select]
          else
          {
                   u->Kill(Config->OperServ, "Session limit exceeded");
                   u = NULL; /* No guarentee u still exists */
          }

at line 656 and add

Code: [Select]
u->Kill(Config->OperServ, "Session limit exceeded");

at line 647?
Logged

lordcow

  • Anope User
  • Offline Offline
  • Posts: 13
Re: upgrading database to 1.9.6
« Reply #17 on: April 05, 2012, 05:06:23 PM »

Sorry that patch didn't apply cleanly on 1.9.7-avoid-direct-visual-contact (g92ed5d7) hence the confusion but it did on 1.9.6 stable. 1.9.6 however doesn't suffer from this problem (it doesn't crash with/without the patch). Also, have updated to ge6edc65 and that doesn't crash either.
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: upgrading database to 1.9.6
« Reply #18 on: April 05, 2012, 05:39:48 PM »

Logged
Pages: [1]   Go Up