Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Denora 1.4.5 Compile error on Darwin (Mac OS X 10.6)  (Read 3407 times)

0 Members and 1 Guest are viewing this topic.

Simen4000

  • Anope User
  • Offline Offline
  • Posts: 2
Denora 1.4.5 Compile error on Darwin (Mac OS X 10.6)
« on: May 13, 2011, 11:37:19 PM »

I'm having a hard time trying to compile Denora on my Mac OS X machines. Both of them are running OS X 10.6, and both of them get this problem when trying to compile Denora.
Code: [Select]
In file included from ../include/denora.h:187,
                 from admin.c:15:
../include/GeoIP.h:227:1: warning: "memcpy" redefined
In file included from /usr/include/string.h:148,
                 from ../include/denora.h:36,
                 from admin.c:15:
/usr/include/secure/_string.h:50:1: warning: this is the location of the previous definition
In file included from admin.c:15:
../include/denora.h:254: error: expected identifier before numeric constant
make[1]: *** [admin.o] Error 1
make: *** [build] Error 2
Any idea on how to fix this?
Logged

Hal9000

  • Team
  • *
  • Offline Offline
  • Posts: 103
Re: Denora 1.4.5 Compile error on Darwin (Mac OS X 10.6)
« Reply #1 on: May 15, 2011, 07:33:30 AM »

Sorry, we do not support Mac OS X.
Logged

Simen4000

  • Anope User
  • Offline Offline
  • Posts: 2
Re: Denora 1.4.5 Compile error on Darwin (Mac OS X 10.6)
« Reply #2 on: May 15, 2011, 11:07:47 AM »

Okay, guess I'll just try on another computer as soon as I get a new mainboard. Thanks for the help, anyways!
« Last Edit: May 15, 2011, 11:12:30 AM by Simen4000 »
Logged
Pages: [1]   Go Up