Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Unreal 3.2 and Anope 1.8  (Read 4656 times)

0 Members and 1 Guest are viewing this topic.

Mark

  • Anope User
  • Offline Offline
  • Posts: 6
Unreal 3.2 and Anope 1.8
« on: April 16, 2011, 10:36:52 PM »

I tried following the steps, checked http://forum.anope.org/index.php?topic=1267.0 and followed those steps and I still can't get Anope to stay open.
Using Windows 7 (hoping to move (setup) to my Windows XP machine once both work and I have working conifgurations)
I'm using Anope 1.8 (from non-MySQL installer) and UnrealIRCd 3.2.8.1 (both installed on the same machine)
Using Notepad++ as my text editor
Here is the debug information from Anope (see attached). Unreal's configuration has been rehashed to accept changes to the configuration (even shutdown and restarted). Unreal is working fine. Here are the general linking configurations, referenced from the link above.

unrealircd.conf
-------------------------

listen 127.0.0.1:7000;

link services.shinra.no-ip.org
{
      username *;
      hostname localhost;
      bind-ip *;
      hub *;
      port 7000;
      password-connect "password";
      password-receive "password";
      class servers;
};

ulines { services.shinra.no-ip.org; };

set { services-server "services.shinra.no-ip.org"; };

include "aliases/anope.conf";

-----------
services.conf

IRCDModule "unreal32"
Numeric 64

RemoteServer 127.0.0.1 7000 "password"

ServerName "services.shinra.no-ip.org"
-----------
Where services.shinra.no-ip.org is, I have tried shinra.no-ip.org and localhost. Nothing works and I keep getting the same information (after saving and re-running Anope) as before.
What did I miss and where do I need to go in the configuration files to fix this?
If you need more info, please let me know.
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Unreal 3.2 and Anope 1.8
« Reply #1 on: April 16, 2011, 11:40:30 PM »

Change hostname localhost; to hostname 127.0.0.1; in services link block, /rehash and try again.
Logged

Mark

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Unreal 3.2 and Anope 1.8
« Reply #2 on: April 17, 2011, 12:06:41 AM »

Thank you so much! Anope has stayed open and synced with UnrealIRCd. Didn't think localhost and 127.0.0.1 were that different and that would cause a problem. Again, thank you so much.

Now I have an issue with my nick and servicesroot. My nick isn't registered, yet it can't be registered because of the ServicesRoot. So how do I login as the "ServicesRoot" if I can't register my nick (and can't start the services without the ServicesRoot) so that I can use OperServ? I couldn't find it in the FAQ and Wiki.
Should I specify a false nickname until I register my nick, then change it to my nick once it has been registered?
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Unreal 3.2 and Anope 1.8
« Reply #3 on: April 17, 2011, 12:09:28 AM »

localhost isn't always the same as 127.0.0.1. DNS is domain name service, which simply put converts names from numbers and if there is no entry for localhost, then it will not resolve.

To register your ServicesRoot, nick you must be an IRCop first before sending the ns register command.
Logged

Mark

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Unreal 3.2 and Anope 1.8
« Reply #4 on: April 17, 2011, 12:57:19 AM »

EDIT: Ok, I got the IRCop status fixed... with different hosts being reported to me, I was using the wrong host name. ::)
Issue resolved.
« Last Edit: April 17, 2011, 01:20:11 AM by Mark »
Logged
Pages: [1]   Go Up