Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Trying to link Anope, having problems...  (Read 5207 times)

0 Members and 1 Guest are viewing this topic.

bill

  • Anope User
  • Offline Offline
  • Posts: 11
Trying to link Anope, having problems...
« on: April 14, 2011, 02:21:23 AM »

I started with this issue in the Modules forum, but it ended up being something else.  I just want to start over and try to get to the bottom of this once and for all, I am a Linux Administration student and I need this ready for my final, and I just can't figure out what I'm doing wrong, I'm a total noob, so please be as descriptive as you can be.

Icd loads without any problems, but when I try to start services I get this:
ircd.services.net- *** Notice -- Link [@192.168.1.102.41734] cancelled, server ircd.services.net already exists from ircd.services.net

here is my info:
services.conf
-------------------
RemoteServer    192.168.1.102 6667 "mypass"
-------------------
ServerName  "ircd.services.net"
-------------------

unrealircd.conf
---------------
me
{
        name "ircd.services.net";
        info "keldons Server";
        numeric 1;
-----------------------
listen         192.168.1.102:6667;
listen         192.168.1.102:6667;
----------------------
link            ircd.services.net
{
        username        *;
        hostname        192.168.1.102;
        bind-ip         *;
        port            6667;
        hub             *;
        password-connect "mypass";
        password-receive "mypass";
        class           servers;
                options {
                        /* Note: You should not use autoconnect when linking se$

                };
};
----------------------
*/
ulines { ircd.services.net; };

};

/*
---------------------
/* Network configuration */
set {
        network-name            "ROXnet";
        default-server          "irc.roxnet.org";
        services-server         "ircd.services.net";
        stats-server            "stats.roxnet.org";
        help-channel            "#ROXnet";
        hiddenhost-prefix       "rox";
        /* prefix-quit          "no"; */
     
« Last Edit: April 14, 2011, 02:24:17 AM by bill »
Logged

Jeremy

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 24
    • SmartServ Hosting
Re: Trying to link Anope, having problems...
« Reply #1 on: April 14, 2011, 02:24:13 AM »

Services and IRCd can not have the same name
Logged
Jeremy Johnston
SmartServ Hosting
http://www.smart-serv.net/

bill

  • Anope User
  • Offline Offline
  • Posts: 11
Re: Trying to link Anope, having problems...
« Reply #2 on: April 14, 2011, 02:25:52 AM »

Which block do i change? 
Logged

Jeremy

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 24
    • SmartServ Hosting
Re: Trying to link Anope, having problems...
« Reply #3 on: April 14, 2011, 02:27:37 AM »

Your choice, either change the name of the ircd in unrealircd.conf or rename the link block for services and change ServerName in services.conf
Logged
Jeremy Johnston
SmartServ Hosting
http://www.smart-serv.net/

bill

  • Anope User
  • Offline Offline
  • Posts: 11
Re: Trying to link Anope, having problems...
« Reply #4 on: April 14, 2011, 02:29:18 AM »

Excellent, got it, thanks buddy!
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Trying to link Anope, having problems...
« Reply #5 on: April 14, 2011, 10:57:12 AM »

Would be interested in where you're studying if they use Anope for the teaching?
Logged
Pages: [1]   Go Up