Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: bs_fantasy_exe  (Read 6536 times)

0 Members and 1 Guest are viewing this topic.

bill

  • Anope User
  • Offline Offline
  • Posts: 11
bs_fantasy_exe
« on: April 07, 2011, 07:36:02 AM »

Running Anope 1.8.5, Unrealircd 3.2.x
Ubuntu 10.10 Non-gui virtual server on Ubuntu 10.10 host OS

Hi, I am sort of new to the nix, but plan on staying with it, I am currently working on a project for my Linux Administration class and need a little help with this module.  I have read the README, and the INSTALL documents more than once, but maybe I'm just a newby, I never configured a module before, so i am having trouble.

I did just as the INSTALL document said, I installed bs_fantasy in the correct place, I added the modules configuration into the services.conf file (I pasted it at the very end of the file), and I successfully loaded it with my irc client.

Now for my problem, I cannot get any of the commands to work, I am not sure what I was supposed to do as far as configuring it after pasting it into the services.conf file, but I didn't change anything.  Was I supposed to uncomment some things?  Because I read it through and I didn't see any features that I thought would add to what was already supposed to be loaded (so I thought).

I tried a rehash but that didn't do anything, any suggestions?

Thank you in advance.
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
Re: bs_fantasy_exe
« Reply #1 on: April 07, 2011, 08:06:25 AM »

I will assume this is about bs_fantasy_ext..

Is the module loaded? .. verify with /os modinfo bs_fantasy_ext
You mention a rehash, a rehash will load the IRCd config, not anopes.. use /os reload instead.
Did you assign a botserv bot to the channel you want to use fantasy commands in? Do you have sufficient access to the channel?
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

bill

  • Anope User
  • Offline Offline
  • Posts: 11
Re: bs_fantasy_exe
« Reply #2 on: April 07, 2011, 08:12:35 AM »

Module is loaded --> OperServ- Module: bs_fantasy_ext Version: 1.2.0 [ M-SO-CuR0-M3-OpC0] Author: Viper loaded: Apr 07 01:52:37 2011 EDT

Did a reload, services were reloaded.

I am signed in as operator.

I actually thought bs_fantasy_exe was a bot, I did a botserv botlist and there are no available bots and so I thought this would create one that I could auto assign to channels.  Ugh..  Any advice?
Logged

bill

  • Anope User
  • Offline Offline
  • Posts: 11
Re: bs_fantasy_exe
« Reply #3 on: April 07, 2011, 08:35:54 AM »

Did some better google searches and found some useful information regarding creating bots and such.  Just one question, once I have this bot created, will the module be automatically added to the bot commands?
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
Re: bs_fantasy_exe
« Reply #4 on: April 07, 2011, 01:34:31 PM »

When you create a bot using /msg BotServ bot, and then assign the created bot to a channel, the bs_fantasy_ext commands will be available in the channel to which you assigned the BotServ bot. However if you create a bot outside of Anope, eg using an eggdrop, then bs_fantasy_ext will not be available on that bot.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

bill

  • Anope User
  • Offline Offline
  • Posts: 11
Re: bs_fantasy_exe
« Reply #5 on: April 08, 2011, 12:37:47 AM »

Ok now I am having a whole other heap of trouble.  Like I said, I loaded the module fine, no problems.  But every time I restart the service (shut the server down) or anything, anope just stops working.  I try to restart ./services, but nothing happens.  No nickserv, chanserv, nothing.  I can't even reload because operserv doesn't work as well.

I keep having to restore the snapshot I made before installing the module in order for anope to work again.

Any suggestions?
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
Re: bs_fantasy_exe
« Reply #6 on: April 08, 2011, 08:28:07 AM »

how about looking in the logfiles...  ???
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

bill

  • Anope User
  • Offline Offline
  • Posts: 11
Re: bs_fantasy_exe
« Reply #7 on: April 10, 2011, 12:48:31 AM »

Well seems this issue is not related to the module, it has something to do with my configuration but I can't seem to find it, nothing in the log seems to point it out to me, sorry I am a noob, I need some help, I have to have this thing operable for my class final.

When I make a botserv bot, that goes fine, but as soon as I send it to a room, I get this:

BotServ- Bot SMARTbot has been assigned to #quizmaster.
-
-services.irc.com- *** Notice -- Max SendQ limit exceeded for ircd.services.net[192.168.1.102]: 1000036 > 1000000
-
-services.irc.com- *** Global -- Closing link: Max SendQ exceeded - ircd.services.net[192.168.1.102]
-
-services.irc.com- *** Notice -- Connection to ircd.services.net[192.168.1.102] activated.
-
-services.irc.com- *** LocOps -- Link denied for services.irc.com(unknown@192.168.1.102) (No link block named 'services.irc.com') [@192.168.1.102.51196]
-
-services.irc.com- *** LocOps -- ERROR :from ircd.services.net[192.168.1.102] -- Link denied (No matching link configuration) [@192.168.1.102.51196]
-
-services.irc.com- *** LocOps -- ERROR :from ircd.services.net[192.168.1.102] -- Closing Link: [192.168.1.102] (Link denied (No matching link configuration))
-
-services.irc.com- *** LocOps -- Server ircd.services.net[192.168.1.102] closed the connection
-
-services.irc.com- *** Notice -- Connection to ircd.services.net[192.168.1.102] activated.
-
-services.irc.com- *** LocOps -- Link denied for services.irc.com(unknown@192.168.1.102) (No link block named 'services.irc.com') [@192.168.1.102.38191]
-
-services.irc.com- *** LocOps -- ERROR :from ircd.services.net[192.168.1.102] -- Link denied (No matching link configuration) [@192.168.1.102.38191]
-
-services.irc.com- *** LocOps -- ERROR :from ircd.services.net[192.168.1.102] -- Closing Link: [192.168.1.102] (Link denied (No matching link configuration))
-
-services.irc.com- *** LocOps -- Server ircd.services.net[192.168.1.102] closed the connection
-
-services.irc.com- *** Notice -- Connection to ircd.services.net[192.168.1.102] activated.
-services.irc.com- *** LocOps -- Link denied for services.irc.com(unknown@192.168.1.102) (No link block named 'services.irc.com') [@192.168.1.102.45123]
-
-services.irc.com- *** LocOps -- ERROR :from ircd.services.net[192.168.1.102] -- Link denied (No matching link configuration) [@192.168.1.102.45123]
-
-services.irc.com- *** LocOps -- ERROR :from ircd.services.net[192.168.1.102] -- Closing Link: [192.168.1.102] (Link denied (No matching link configuration))
-
-services.irc.com- *** LocOps -- Server ircd.services.net[192.168.1.102] closed the connection
*******************************************
Before I set the bot, everything works fine, my links in my unrealircd.conf and my services.conf file are matched correctly.

I checked my configuration and there is no link called services.irc.com, but it does say it in parenthesis in the window bar of my main server window.  I have been trying to figure this out for days!  Please help me out?
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: bs_fantasy_exe
« Reply #8 on: April 10, 2011, 04:08:20 AM »

1> you have your ircd named services.irc.com
2> sendQ exceeded message is from your misconfigured U:Lines

You should name your ircd something other than services. It looks like the ircd is trying to connect to it's self so make sure you don't have autoconnect in the link block for services.

Steps to fix:
1> rename your ircd
2> name services services.irc.com
3> edit the ulines block to match services name exactly, case sensitive.
4> add a link block for services and do NOT use autoconnect!!!
5> restart your ircd
6> start services

This tutorial should help: http://forum.anope.org/index.php?topic=1267.0

ciao
Logged

bill

  • Anope User
  • Offline Offline
  • Posts: 11
Re: bs_fantasy_exe
« Reply #9 on: April 14, 2011, 01:12:18 AM »

Ok, I read the tutorial a quite a few times, thought I had it set up correctly, but I guess I'm just a big screw-up.  Heres what the services.log file is telling me:

[Apr 13 20:10:31 2011] Every UserKey must be different. It's for YOUR safety! Remember that!
[Apr 13 20:10:31 2011] Loading IRCD Protocol Module: [unreal32]
[Apr 13 20:10:31 2011] status:
  • [Module, Okay - No Error]
[Apr 13 20:10:31 2011] Loading Encryption Module: [enc_md5]
[Apr 13 20:10:31 2011] status:
  • [Module, Okay - No Error]
[Apr 13 20:10:31 2011] Anope 1.8.5 (3037) (ircd protocol: UnrealIRCd 3.2+) starting up
[Apr 13 20:10:32 2011] MSMemoReceipt not enabled in services.conf
[Apr 13 20:10:32 2011] ms_rsend requested unload...
[Apr 13 20:10:32 2011] debug: trying to load core module [ms_rsend]
[Apr 13 20:10:32 2011] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Apr 13 20:10:32 2011] Error reading version number on nick.db: End of file detected
[Apr 13 20:10:32 2011] Error reading version number on nick.db: End of file detected
[Apr 13 20:10:32 2011] FATAL: Unsupported version number (0) on nick.db
Logged

bill

  • Anope User
  • Offline Offline
  • Posts: 11
Re: bs_fantasy_exe
« Reply #10 on: April 14, 2011, 01:18:33 AM »

Removed nick.db (it was an empty file) tried to reload, log now says:

[Apr 13 20:16:11 2011] Every UserKey must be different. It's for YOUR safety! Remember that!
[Apr 13 20:16:11 2011] Loading IRCD Protocol Module: [unreal32]
[Apr 13 20:16:11 2011] status:
  • [Module, Okay - No Error]
[Apr 13 20:16:11 2011] Loading Encryption Module: [enc_md5]
[Apr 13 20:16:11 2011] status:
  • [Module, Okay - No Error]
[Apr 13 20:16:12 2011] Anope 1.8.5 (3037) (ircd protocol: UnrealIRCd 3.2+) starting up
[Apr 13 20:16:12 2011] MSMemoReceipt not enabled in services.conf
[Apr 13 20:16:12 2011] ms_rsend requested unload...
[Apr 13 20:16:12 2011] debug: trying to load core module [ms_rsend]
[Apr 13 20:16:12 2011] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Apr 13 20:16:12 2011] Error reading version number on hosts.db: End of file detected
[Apr 13 20:16:12 2011] Error reading version number on bot.db: End of file detected
[Apr 13 20:16:12 2011] FATAL: Invalid format in bot.db -1
Logged

bill

  • Anope User
  • Offline Offline
  • Posts: 11
Re: bs_fantasy_exe
« Reply #11 on: April 14, 2011, 04:11:03 AM »

I'm all set, I ended up restoring a snapshot, got some more help, I actually never renamed my ircd...  oops.
Logged
Pages: [1]   Go Up