Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Denora with Inspircd 2.0.2  (Read 5137 times)

0 Members and 1 Guest are viewing this topic.

GhosT

  • Anope User
  • Offline Offline
  • Posts: 43
Denora with Inspircd 2.0.2
« on: November 08, 2010, 11:24:34 PM »

I just upgrade my IRCD server to inspircd 2.0.2 recently. Unfortunately, there is no denora protocol for inspircd 2 yet. I tried to load the 1.2 protocol but it does not work as expected when I enable SQL.

Is there any way to make it work with 2.0.2 properly or have to wait until denora releases the official protocol one?

Thanks,
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Denora with Inspircd 2.0.2
« Reply #1 on: November 09, 2010, 01:08:36 AM »

There is a difference between 1.2 and 2.0 ircd protocols, you are going to either have to write one yourself, in which case if you do, please submit it for review and possible inclusion, or wait for one to be written.

Unfortunately even closely associated projects like Denora and Anope can have different release schedules.

On a personal note, please don't think this is a rant, but you should always investigate support fully before upgrading to prevent this from happening. It's highly advisable to have a TestNet to test all new software on to insure things run smoothly before introducing the new software to any production network.
Logged

GhosT

  • Anope User
  • Offline Offline
  • Posts: 43
Re: Denora with Inspircd 2.0.2
« Reply #2 on: November 09, 2010, 07:35:15 AM »

I think I might have to wait until Denora releases its protocol to support Inspircd 2.0. First, I thought it worked because Denora bot was connected to Inspircd 2.0 server without any problem.
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Denora with Inspircd 2.0.2
« Reply #3 on: November 09, 2010, 06:17:16 PM »

It's not always an absolute work/don't work scenario. If the bot connects fine that could suggest there is nothing different about the connection handling part of the protocol, and not the same in other parts. I haven't looked at insp 2 proto, so I don't know how much has changed, I just know that it has.
« Last Edit: November 09, 2010, 06:19:11 PM by katsklaw »
Logged

Hal9000

  • Team
  • *
  • Offline Offline
  • Posts: 103
Re: Denora with Inspircd 2.0.2
« Reply #4 on: November 23, 2010, 02:08:48 PM »

are you using denora 1.4.4 or denora 1.4.5-SVN? i believe there have been some inspircd-related fixes in svn.
using the inspircd 1.2 module "shuold" work with inspircd 2.0.
if you are still having problems, please open detailed bug reports in the bug tracker and i will try to fix the issues asap before 1.4.5 release.
« Last Edit: November 23, 2010, 03:23:21 PM by Hal9000 »
Logged

GhosT

  • Anope User
  • Offline Offline
  • Posts: 43
Re: Denora with Inspircd 2.0.2
« Reply #5 on: November 27, 2010, 10:28:53 AM »

are you using denora 1.4.4 or denora 1.4.5-SVN? i believe there have been some inspircd-related fixes in svn.
using the inspircd 1.2 module "shuold" work with inspircd 2.0.
if you are still having problems, please open detailed bug reports in the bug tracker and i will try to fix the issues asap before 1.4.5 release.
I was using 1.4.4 not SVN. So will the 1.4.5-SVN work? I will try in next few days. Thank your,
Logged

GhosT

  • Anope User
  • Offline Offline
  • Posts: 43
Re: Denora with Inspircd 2.0.2
« Reply #6 on: November 27, 2010, 01:52:04 PM »

I just compiled the SVN version one. I am running it. It seems that the Denora bot always lost connection to mysql server and unload SQL module. Unlike before, it did not lost any connection.
Logged
Pages: [1]   Go Up