Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Question about BotServices: how to change the symbol & and actions ?!?!?  (Read 3238 times)

0 Members and 1 Guest are viewing this topic.

Bruno

  • Anope User
  • Offline Offline
  • Posts: 23

Hi.
Finally I've put up a bot using BotServices.
I've some question about this service.
After add the bot into a channel, it appear with the symbol " & ".
Is possible to give it the common symbol " @ "of an Oper ?
Another question is why it act as a Service....I'd like that only ChanServ give to the user the status and the BOT act only as a bot, with the ban and the kick function.
Tnx so much for the answers and the help!!!!!!!!

Best Regards.
Logged

LEthaLity

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 307
    • LEthaLity
Re: Question about BotServices: how to change the symbol & and actions ?!?!?
« Reply #1 on: November 08, 2010, 03:59:21 PM »

It acts as a service because it's supposed to hence BotServ, A botserv bot is just a representation of ChanServ in a channel.

As for the botmodes, which version of 1.9 are you running? They can be set in 1.9.2-p2 using the "botmodes" setting in the option block of services.conf
Logged

Bruno

  • Anope User
  • Offline Offline
  • Posts: 23
Re: Question about BotServices: how to change the symbol & and actions ?!?!?
« Reply #2 on: November 09, 2010, 02:27:26 PM »

Hi.
I'm using the version 1.9.2-p2.
When I rejoin the Chan where I've put up the bot, I see (when entering) this message:
ChanServ sets mode: +ntraq libra deejay
How I can't see the nick libra into the text?!?!?!?
Another question.... into the .conf file, I've delete the " o " flag but the bot is still with the " & " symbol.....
What can I do for have the botnick @libra ?!?!?
Tnx so much for the help!!!!!!!!!

Best Regards.
Logged

LEthaLity

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 307
    • LEthaLity
Re: Question about BotServices: how to change the symbol & and actions ?!?!?
« Reply #3 on: November 09, 2010, 02:50:33 PM »

Quote
Another question.... into the .conf file, I've delete the " o " flag but the bot is still with the " & " symbol.....

maybe learn the channel modes and the related prefixes, o = @, a = &, so for a "normal opped" bot you need o.

I assume by the other question you mean "why does ChanServ set the modes instead of your bot "libra"? This is something that has since been fixed, I'm not sure there's anything you can do about it at the moment, except wait for the next package and upgrade.
Logged
Pages: [1]   Go Up