Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Anope 1.9 Fatal: Can't connect to any servers [ SOLVED ]  (Read 9943 times)

0 Members and 1 Guest are viewing this topic.

Bruno

  • Anope User
  • Offline Offline
  • Posts: 23
Anope 1.9 Fatal: Can't connect to any servers [ SOLVED ]
« on: October 19, 2010, 10:33:05 AM »

Hi.
Now that Anope run, I receive this error message (take from the Anope log):

Done reading configuration file.
Loading IRCD Protocol Module: [unreal32]
Anope 1.9.2-p2 (2), build #1, compiled Jul 27 2010 08:52:06
Using configuration file C:\Programmi\Anope\data\services.conf
PID 7408
Launching Anope into the background
Anope 1.9.2-p2 (2) (ircd protocol: UnrealIRCd 3.2+) starting up
Error while loading ms_rsend: Don't like memo reciepts, or something.
Error while loading os_defcon: Invalid configuration settings
Loading databases...
Databases loaded
Unable to connect to server1 (services.test.srv:6667), Invalid server address
FATAL: Can't connect to any servers: No such file or directory

I post here the link to the pastebin of unrealircd.conf and of the services.conf :

http://pastebin.anope.org/index.php?page=viewpaste&id=a0b4927ba4  ( UnrealIrcd )

http://pastebin.anope.org/index.php?page=viewpaste&id=26eaf18f9f ( Anope )

I've used also the link http://www.anope.org/ilm.php?p=lm with the Anope Setup Guide .....

Can anyone help me to set correctly the link for make run the Services ?!?!?!?

Tnx so much for the answers!!!!!!!!!!!!!!!

Best Regards.
« Last Edit: October 25, 2010, 12:05:54 AM by Bruno »
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Anope 1.9 Fatal: Can't connect to any servers
« Reply #1 on: October 19, 2010, 10:47:59 AM »

Unable to connect to server1 (services.test.srv:6667), Invalid server address

Quote
0083   uplink
0084   {
0085       /*
0086        * The IP or hostname of the IRC server you wish to connect Services to.
0087        * Usually, you will want to connect Services over 127.0.0.1 (aka localhost).
0088        *
0089        * NOTE: On some shell providers, this will not be an option.
0090        */
0091       host = "services.test.srv"

services.test.srv is not a valid address on your network. Change this to an IP address.
Logged

Bruno

  • Anope User
  • Offline Offline
  • Posts: 23
Re: Anope 1.9 Fatal: Can't connect to any servers
« Reply #2 on: October 24, 2010, 01:34:40 AM »

Hi.
Still the same problem.....
Here the errors (take from the log):

Done reading configuration file.
Loading IRCD Protocol Module: [unreal32]
Anope 1.9.2-p2 (2), build #1, compiled Jul 27 2010 08:52:06
Using configuration file C:\Programmi\Anope\data\services.conf
PID 7496
Launching Anope into the background
Anope 1.9.2-p2 (2) (ircd protocol: UnrealIRCd 3.2+) starting up
Error while loading ms_rsend: Don't like memo reciepts, or something.
Error while loading os_defcon: Invalid configuration settings
Loading databases...
Unable to open anope.db for reading!
Databases loaded
Connected to Server 1 (127.0.0.1:6667)
Disconnected from the server, retrying in 60 seconds
Connected to Server 1 (127.0.0.1:6667)
Disconnected from the server, retrying in 60 seconds
Connected to Server 1 (127.0.0.1:6667)
Disconnected from the server, retrying in 60 seconds
Connected to Server 1 (127.0.0.1:6667)
Disconnected from the server, retrying in 60 seconds
Connected to Server 1 (127.0.0.1:6667)
Disconnected from the server, retrying in 60 seconds

Here the config of Unreal and Anope :

UNREAL :

 link services.test.srv
{
 username *;
 hostname 127.0.0.1;
 port *;
 bind-ip 127.0.0.1;
 password-connect ":P";
 password-receive ":P";
 class servers;
};

ulines {
 services.test.srv;
};

ANOPE:


name = "services.test.srv"

description = "Services for IRC Test Server"

host = "127.0.0.1"

#ipv6 = no

port = 6667

password = ":p"

serverinfo
{
   /*
    * The hostname that Services will be seen as, it must have no conflicts with any
    * other server names on the rest of your IRC network. Note that it does not have
    * to be an existing hostname, just one that isn't on your network already. This
    * can be overridden with the -name command-line option when starting Services.
    */
   name = "services.test.srv"



localhost = "127.0.0.1"

   /*
    * The local address that Services will bind to before connecting to the remote
    * server. This may be useful for multihomed hosts. If ommited, Services will let
    * the Operating System choose the local address. This directive is optional.
    *
    * If you don't know what this means or don't need to use it, just leave this
    * directives commented out.
    */
   localhost = "127.0.0.1"


* These identify the ident@hostname which will be used by the Services pesudoclients.
    * They can be overridden by the -user and -host command-line options when starting
    * Services.
    */
   ident = "services"
   hostname = "services.test.srv"

What I must change?!?!?!? Tnx so much!!!!!!!!!!!!!!!!!

Best Regards.
Logged

LEthaLity

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 303
    • LEthaLity
Re: Anope 1.9 Fatal: Can't connect to any servers
« Reply #3 on: October 24, 2010, 01:45:55 AM »

check you're listen block, you're connecting to port 6667, which you have set for clientsonly, you also shouldn't be using autoconnect or any other options in the link block:
Quote
/* Note: You should not use autoconnect when linking services */
 autoconnect;
zip;
Logged

Bruno

  • Anope User
  • Offline Offline
  • Posts: 23
Re: Anope 1.9 Fatal: Can't connect to any servers
« Reply #4 on: October 24, 2010, 02:35:49 PM »

Hi.
I'd like to post an old .conf file (of Unreal and Anope).
I've always left port 6667 and also autoconnect and have always run correctly......
Here the pastebin files:

http://pastebin.anope.org/index.php?page=viewpaste&id=0942c3cfdb  (Unreal)

http://pastebin.anope.org/index.php?page=viewpaste&id=4066fb5f8d  (Anope)

Why now I've problems with this settings?!?!?!?

Tnx so much for the help!!!!!!!!

Best Regards.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Anope 1.9 Fatal: Can't connect to any servers
« Reply #5 on: October 24, 2010, 02:39:25 PM »

Hi,

Look.

Quote
listen         *:6668
{
   options
   {
      clientsonly;
   };
};

listen         *:6668;
listen         *:6667;

So servers can connect on port 6667, this is good.


Quote
link            irc.server.tst
{
   username   *;
   hostname    127.0.0.1;
   bind-ip    *;
   port       6668;
   hub             *;
   password-connect "connect";
   password-receive "receive";
   class           servers;
      options {
         /* Note: You should not use autoconnect when linking services */
         autoconnect;
         ssl;
         zip;
      };
};

This is wrong on so many levels, where is the link block for services?

Do not use autoconnect, zip, or ssl with services.
Do not use port 6668 with services you have said it's clients only.

Please read your configs they are very self explanatory.
Logged

Bruno

  • Anope User
  • Offline Offline
  • Posts: 23
Re: Anope 1.9 Fatal: Can't connect to any servers
« Reply #6 on: October 24, 2010, 10:51:02 PM »

Hi.

Tnx so much!!!!!!!!!!!!!!

I've solved the problem!!!!!!!!!!!!!!!!!!

Here the pastebin :

http://pastebin.anope.org/index.php?page=viewpaste&id=e0bdfefc75  ( UnrealIrcd )

http://pastebin.anope.org/index.php?page=viewpaste&id=ff93a35d62  ( Anope )
Logged

LEthaLity

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 303
    • LEthaLity
Re: Anope 1.9 Fatal: Can't connect to any servers
« Reply #7 on: October 24, 2010, 10:56:43 PM »

it works with those configs ? that would surprise me.
Logged

Bruno

  • Anope User
  • Offline Offline
  • Posts: 23
Re: Anope 1.9 Fatal: Can't connect to any servers
« Reply #8 on: October 24, 2010, 11:19:06 PM »

MMmm...... just some minute ago yes....now...... no :(
Before I've see the services connected.....but was required the password (error password missmatch)
And now....after restart.....notthing!
(I've commented the first password of services.conf ....and I've saved the file.....after this I've had problems)

Here the Anope log :

[Oct 24 23:45:49 2010] Loading IRCD Protocol Module: [unreal32]
[Oct 24 23:45:50 2010] Anope 1.9.2-p2 (2), build #1, compiled Jul 27 2010 08:52:06
[Oct 24 23:45:50 2010] Using configuration file C:\Programmi\Anope\data\services.conf
[Oct 24 23:45:50 2010] PID 7280
[Oct 24 23:45:50 2010] Launching Anope into the background
[Oct 24 23:45:50 2010] Anope 1.9.2-p2 (2) (ircd protocol: UnrealIRCd 3.2+) starting up
[Oct 24 23:45:53 2010] Error while loading ms_rsend: Don't like memo reciepts, or something.
[Oct 24 23:45:54 2010] Error while loading os_defcon: Invalid configuration settings
[Oct 24 23:45:55 2010] Loading databases...
[Oct 24 23:45:55 2010] Unable to open anope.db for reading!
[Oct 24 23:45:55 2010] Databases loaded
[Oct 24 23:45:55 2010] Connected to Server 1 (127.0.0.1:6667)
[Oct 24 23:45:56 2010] Server irc.test.srv is done syncing
[Oct 25 00:03:52 2010] There were errors in your configuration file: The value for <uplink:password> cannot be empty!
[Oct 25 00:04:09 2010] Done reading configuration file.
« Last Edit: October 24, 2010, 11:29:07 PM by Bruno »
Logged

LEthaLity

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 303
    • LEthaLity
Re: Anope 1.9 Fatal: Can't connect to any servers
« Reply #9 on: October 24, 2010, 11:38:02 PM »

it's no wonder if the configs are the two you last posted:
Quote
http://pastebin.anope.org/index.php?page=viewpaste&id=e0bdfefc75  ( UnrealIrcd )

http://pastebin.anope.org/index.php?page=viewpaste&id=ff93a35d62  ( Anope )

Quote
  link irc.test.srv
{
 username *;
 hostname 127.0.0.1;
 port 6667;
 bind-ip 127.0.0.1;
 password-connect "montagna";
 password-receive "montagna";
 class servers;
};
the server name at the top of that link block should be your services server name eg. services.test.srv

You need to connect services to a port that is NOT set up for clients only, that shows 6667, look at your listen block for 6667, its clearly clientsonly.
Quote
listen         *:6667
{
   options
   {
      clientsonly;
   };
};

listen         *:6667;
listen         *:6668;
so there's two for 6667, to get this working quickly, just delete the larger one.

The "error" relating to passwords was because of this
Quote
allow {
   ip             *;
   hostname       127.0.0.1;
   class           clients;
   maxperip 5;
};

allow {
   ip             *;
   hostname       127.0.0.1;
   class           clients;
   password "montagna";
   maxperip 1;
};

Remove them and just put this one:
allow {
   ip             *@*;
   hostname       *@*;
   class           clients;
   maxperip 1;
};

Also this in unrealircd.conf:  default-server      "127.0.0.1";   should be irc.test.srv.
Logged
Pages: [1]   Go Up