Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Possible problem with channel MLOCK conversion  (Read 2943 times)

0 Members and 1 Guest are viewing this topic.

Josh

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 16
Possible problem with channel MLOCK conversion
« on: October 01, 2010, 08:51:42 PM »

This was not overly tested, this is why it is not reported yet.

It seems that some of my channels does not enforce their modes set in MLOCK. The info command says it is set correctly, but does not enforce them to be set.

The problem might be with the databases were used with the unreal module and now are used with the inspircd20 one, so it might be a conversion thing due to certain modes.

The reason I have not reported it yet is because I was not able to reproduce the bug on a constant basis, it seems pretty random. Also when I restart the services, everything seems to be fine and all modes are correctly set and enforced... Until it present itself again.

Nothing is sure, but if someone have ideas on how to test it more, or had similar problems in the past, let me know, so we can contribute this great project :)

Thanks.

I am running Anope 1.8.5 (latest GIT) and inspircd 2.0.2 (latest git) on ARCH linux 64 bits And services are correctly ulined.
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Possible problem with channel MLOCK conversion
« Reply #1 on: October 29, 2010, 04:01:50 AM »

You can start Anope in debug mode, /anoperc start -debug, then watch the logs for warnings from the ircd about bad/unknown modes when MLOCK is trying to be enforced. If you find something funny post it in reply, but just the odd part, not the entire log!

If you aren't sure what you are looking for you can email the log file in it's entirety to me at msn dot com and I'll review it for you.
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: Possible problem with channel MLOCK conversion
« Reply #2 on: October 29, 2010, 04:10:03 AM »

It is known 1.8 doesn't convert most modes if you change protocol modules on it. 1.9 has already had this redesigned so that it will not do this.
Logged

Josh

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 16
Re: Possible problem with channel MLOCK conversion
« Reply #3 on: November 02, 2010, 12:19:37 AM »

Thanks for the help people. Btw, I already tried the -debug parameter: and it does not show anything wrong. I bet it is as Adam says it is, a conversion problem.

Thanks again, and if you have more info about the topic, feel free to share. :)
Logged
Pages: [1]   Go Up