Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: hostserv odd issues.  (Read 4039 times)

0 Members and 1 Guest are viewing this topic.

wldone

  • Guest
hostserv odd issues.
« on: May 05, 2006, 01:03:24 AM »

I am running Ultimate3.0.1 with anope 1.7.14 on a redhat 9 system.

services started having write problems because the harddrive was full. I rebooted to drop deleted files and gained 25% of 250G drive.

I then restored the databases from backup and restarted services. When i went to put back in a couple hosts with hostserv using syntax /hs set <nick> <host> I received an error:


 *** -HostServ- Unknown set option. /msg HostServ HELP SET for more info

so I took a look at hostserv help:

*** -HostServ- The following commands can be used with HostServ:
 *** -HostServ-     HELP                 Online help
 *** -HostServ-     SET                  Configure HostServ
 *** -HostServ-     LOGIN                Login to HostServ
 *** -HostServ-     ABOUT                About HostServ
 *** -HostServ-     ADD                  Add a vhost
 *** -HostServ-     CHPASS               Change password for a vhost
 *** -HostServ-     LIST                 List vhosts
 *** -HostServ-     DEL                  Delete a vhost
 *** -HostServ- Additional commands available to Operators:
 *** -HostServ-     VIEW                 Detailed vhost list
 *** -HostServ-     LEVELS               Levels to manage HostServ
 *** -HostServ- Additional commands available to Service Admins:
 *** -HostServ-     BANS                 List banned vhosts
 *** -HostServ-  
 *** -HostServ- To use a command, type
 *** -HostServ-     /msg HostServ command
 *** -HostServ- For more information on a command, type
 *** -HostServ-     /msg HostServ HELP command.

I see a few things missing... on, off, setall, delall.

So I deleted the services dir. I recompiled with extra modules
I use. I reconfiged services.conf.

I started services with clean databases, no backups and received the same hostserv help list and same error message from hostserv :/

PLEASE HELP!

thanks in advance.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #1 on: May 05, 2006, 12:07:16 PM »

I think you are using a module which is affecting hostserv.
Logged

wldone

  • Guest
(No subject)
« Reply #2 on: May 05, 2006, 03:51:01 PM »

commented out extra modules and restarted. only modules loading now are core modules. I get the same result.

On another note, I can unload/load the modules like setall. It laods fine. /os modinfo hs_setall produces:

*** -OperServ- Module: hs_setall Version: $Id: hs_setall.c 953 2006-01-14 11:36:29Z certus $ Author: Anope loaded: May 05 12:06:56 2006 EDT

*** -OperServ- Providing command: /msg HostServ SETALL

but tryin to use it with syntax /msg hostserv setall <nick> <host> yields:

*** -HostServ- Syntax error: unknown command: setall

[Edited on 5-5-2006 by wldone]

[Edited on 5-5-2006 by wldone]
Logged

wldone

  • Guest
(No subject)
« Reply #3 on: May 08, 2006, 04:42:00 PM »

wow, I would have thought for sure someone would know something about this.

im really at a loss here and could use some help. I've been trying diff things for days.
Logged

Dave Robson

  • Team
  • *
  • Offline Offline
  • Posts: 357
(No subject)
« Reply #4 on: May 08, 2006, 05:00:43 PM »

whatever it is your using that isnt anope's default hostserv.

Remove all the extra hostserv 3rd party modules your using, and try again.

( for the record, im not even sure thats anope, are you sure it isnt neostats hostserv or something? )



[Edited on 8-5-2006 by Rob]
Logged

wldone

  • Guest
(No subject)
« Reply #5 on: May 08, 2006, 05:09:17 PM »

see, you rock!!! host for neostats was loaded... im gonna kill someone. it doesnt load on start. appreciate the pointer!
Logged

stu

  • Guest
(No subject)
« Reply #6 on: May 08, 2006, 05:13:51 PM »

No more calls, we have a winner!
Logged
Pages: [1]   Go Up