Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: UnrealIRCD3.2 problem  (Read 8343 times)

0 Members and 1 Guest are viewing this topic.

erfg1

  • Guest
UnrealIRCD3.2 problem
« on: May 01, 2006, 04:13:36 PM »

----------------------------------------------------------------
[unrealircd.conf]

link 68.201.4.157
{
 username *;
 hostname 127.0.0.1;
 port *;
 bind-ip 127.0.0.1;
 password-connect "fger1";
 password-receive "fger1";
 class servers;
};

ulines {
 68.201.4.157;
};

----------------------------------------------------------------
[services.conf]

RemoteServer 68.201.4.157 6667 "fger1"

ServerName "68.201.4.157"
-----------------------------------------------------------------

I am on a Linksys router, but I did do DMZ and port forwarding so I can host outside the router just fine. The IRCD server runs just fine, but the Anobe doesn't. I host both the services and unrealircd on the same computer. I typed in...

cd ~/services
./services
(says nothing)

cd /home/Unreal3.2
./unreal start
(starts up IRCD)

The NickServ, ChanServ, etc. don't connect and I can't do any of their commands.

[Edited on 1-5-2006 by erfg1]

[Edited on 1-5-2006 by erfg1]

[Edited on 1-5-2006 by erfg1]

[Edited on 1-5-2006 by erfg1]
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #1 on: May 01, 2006, 06:01:54 PM »

you should try using 127.0.0.1 as RemoteServer.. unreal uses hostname  hostname 127.0.0.1 for the remote connection to i guess it s local

i dunno about your router, but mine won't let my connect to my own irc server using my i-net side ip so, might be part of the problem
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

erfg1

  • Guest
(No subject)
« Reply #2 on: May 01, 2006, 07:05:50 PM »

Changed

----------------------------------------------------------------
[unrealircd.conf]

link 127.0.0.1
{
username *;
hostname 127.0.0.1;
port *;
bind-ip 127.0.0.1;
password-connect "fger1";
password-receive "fger1";
class servers;
};

ulines {
68.201.4.157;
};

----------------------------------------------------------------
[services.conf]

RemoteServer 127.0.0.1 6667 "fger1"

ServerName "127.0.0.1"
-----------------------------------------------------------------


Still doesnt work.
Logged

Zerratar

  • Guest
(No subject)
« Reply #3 on: May 19, 2006, 04:43:51 PM »

Code: [Select]

hostname 127.0.0.1;
port *;


try setting a port? 6667 should work i think. mines connect but then terminates :/
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #4 on: May 19, 2006, 06:43:49 PM »

what about the ulines ?
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.

diskman

  • Guest
(No subject)
« Reply #5 on: May 22, 2006, 11:37:33 PM »

cd ~/services
./services
(says nothing)

cd /home/Unreal3.2
./unreal start
(starts up IRCD)


^^ ehm you first starting the ircd and then services right?
if yes have a look at the anope logfile
Logged

malice

  • Anope User
  • Offline Offline
  • Posts: 10
(No subject)
« Reply #6 on: July 04, 2006, 01:32:08 PM »

With your IRCd running, start services in debug mode.

./services -debug -nofork

Please post output on forums.
Logged

katsklaw

  • Guest
(No subject)
« Reply #7 on: July 04, 2006, 06:52:53 PM »

Quote
Originally posted by erfg1
Changed

----------------------------------------------------------------
[unrealircd.conf]

link 127.0.0.1
{
username *;
hostname 127.0.0.1;
port *;
bind-ip 127.0.0.1;
password-connect "fger1";
password-receive "fger1";
class servers;
};

ulines {
68.201.4.157;
};

----------------------------------------------------------------
[services.conf]

RemoteServer 127.0.0.1 6667 "fger1"

ServerName "127.0.0.1"
-----------------------------------------------------------------


Still doesnt work.


Your link block is wrong ...

link  services.name
{

ulines block should match the link block and ServerName fields

as far as Services conf

ServerName services.mynet.org or the like

Services name doesn't need to be a real name .. but it does have to match the ulines block and the link block.

Code: [Select]

----------------------------------------------------------------
[unrealircd.conf]

link services.name
{
username *;
hostname 127.0.0.1;
port *;
bind-ip 127.0.0.1;
password-connect "fger1";
password-receive "fger1";
class servers;
};

ulines {
services.name;
};

----------------------------------------------------------------
[services.conf]

RemoteServer 127.0.0.1 6667 "fger1"

ServerName "services.name"
-----------------------------------------------------------------

[Edited on 4-7-2006 by katsklaw]
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #8 on: July 04, 2006, 07:39:47 PM »

Thread is 6 weeks old .. probably committed suicide by now.
Logged

Wulfstan

  • Guest
(No subject)
« Reply #9 on: July 06, 2006, 04:48:55 AM »

*/
link services.gorean-chat.dyndns.ws
{
   username   *;
   hostname    *;
   bind-ip    *;
   port       8067;
   hub             hub;
   password-connect "randolph";
   password-receive "randolph";
   class           servers;
      options {
         /* Note: You should not use autoconnect when linking services */
         ssl;
      };
};
/*



^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
THAT WORKS
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #10 on: July 06, 2006, 08:41:41 AM »

Whilst it may work its wrong.

You should not be using ssl, and hub should be hub *. You should also specify an IP to stop _anyone_ from connecting to you.
Logged
Pages: [1]   Go Up